aboutsummaryrefslogtreecommitdiff
path: root/emulators/mame-devel/Makefile
diff options
context:
space:
mode:
authorAlejandro Pulver <alepulver@FreeBSD.org>2008-02-05 17:09:42 +0000
committerAlejandro Pulver <alepulver@FreeBSD.org>2008-02-05 17:09:42 +0000
commitccef9a672044dca06194c678db4e03d621762004 (patch)
treeddec199b5d286b799d44fa9600262b11cbb948b1 /emulators/mame-devel/Makefile
parenta63d2315e5583ffe1034dc9f1a6959be540a0060 (diff)
Notes
Diffstat (limited to 'emulators/mame-devel/Makefile')
-rw-r--r--emulators/mame-devel/Makefile11
1 files changed, 4 insertions, 7 deletions
diff --git a/emulators/mame-devel/Makefile b/emulators/mame-devel/Makefile
index 599dafc0adf6..24f2cd7889ea 100644
--- a/emulators/mame-devel/Makefile
+++ b/emulators/mame-devel/Makefile
@@ -6,7 +6,7 @@
#
PORTNAME= sdlmame
-PORTVERSION= 0.120u2
+PORTVERSION= 0.122u8
CATEGORIES= emulators
MASTER_SITES= ftp://ftp.alepulver.com.ar/distfiles/
DISTNAME= ${PORTNAME}${PORTVERSION:S/.//}
@@ -17,6 +17,7 @@ COMMENT= SDL port of the popular MAME (Multi Arcade Machine Emulator)
USE_ZIP= yes
USE_GL= yes
USE_GMAKE= yes
+MAKE_ENV= PTHREAD_LIBS="${PTHREAD_LIBS}"
USE_SDL= sdl
MAKEFILE= makefile
@@ -25,8 +26,8 @@ SUB_FILES= ${PORTNAME} pkg-message
do-install:
${INSTALL_SCRIPT} ${WRKDIR}/${PORTNAME} ${PREFIX}/bin
${MKDIR} ${PREFIX}/libexec/sdlmame
-.for f in obj/sdl/mame/build/file2str obj/sdl/mame/build/png2bdc mame testkeys romcmp \
- chdman jedutil makemeta regrep srcclean
+.for f in obj/sdl/mame/build/file2str obj/sdl/mame/build/png2bdc mame \
+ testkeys romcmp chdman jedutil makemeta regrep srcclean
${INSTALL_PROGRAM} ${WRKSRC}/${f} ${PREFIX}/libexec/sdlmame
.endfor
${MKDIR} ${DATADIR}
@@ -52,8 +53,4 @@ post-install:
USE_GCC= 4.2+
.endif
-.if ${ARCH} == "sparc64"
-BROKEN= Does not compile
-.endif
-
.include <bsd.port.post.mk>