aboutsummaryrefslogtreecommitdiff
path: root/emulators/mame-devel
diff options
context:
space:
mode:
authorAlejandro Pulver <alepulver@FreeBSD.org>2007-09-05 22:38:15 +0000
committerAlejandro Pulver <alepulver@FreeBSD.org>2007-09-05 22:38:15 +0000
commitd6ebd6c6f8b30f4465b2a5e699261668d63f9000 (patch)
treeacc1c2ce65aeb1b69e15c7799854d050ba377118 /emulators/mame-devel
parent018f022d33b7824556c386272a9e5ac4cb1f9bee (diff)
downloadports-d6ebd6c6f8b30f4465b2a5e699261668d63f9000.tar.gz
ports-d6ebd6c6f8b30f4465b2a5e699261668d63f9000.zip
Notes
Diffstat (limited to 'emulators/mame-devel')
-rw-r--r--emulators/mame-devel/Makefile8
-rw-r--r--emulators/mame-devel/distinfo6
-rw-r--r--emulators/mame-devel/files/patch-makefile43
-rw-r--r--emulators/mame-devel/files/patch-src__osd__sdl__sdltime.c11
-rw-r--r--emulators/mame-devel/files/sdlmame.in7
-rw-r--r--emulators/mame-devel/pkg-plist2
6 files changed, 39 insertions, 38 deletions
diff --git a/emulators/mame-devel/Makefile b/emulators/mame-devel/Makefile
index d52f864b8595..d0269fc34d46 100644
--- a/emulators/mame-devel/Makefile
+++ b/emulators/mame-devel/Makefile
@@ -6,7 +6,7 @@
#
PORTNAME= sdlmame
-PORTVERSION= 0.117
+PORTVERSION= 0.118u3
CATEGORIES= emulators
MASTER_SITES= http://rbelmont.mameworld.info/
DISTNAME= ${PORTNAME}${PORTVERSION:S/.//}
@@ -24,10 +24,10 @@ SUB_FILES= ${PORTNAME} pkg-message
do-install:
${INSTALL_SCRIPT} ${WRKDIR}/${PORTNAME} ${PREFIX}/bin
- ${MKDIR} ${PREFIX}/libexec/${PORTNAME}
-.for f in obj/sdl/mame/file2str obj/sdl/mame/png2bdc mame testkeys romcmp \
+ ${MKDIR} ${PREFIX}/libexec/sdlmame
+.for f in obj/sdl/mame/build/file2str obj/sdl/mame/build/png2bdc mame testkeys romcmp \
chdman jedutil makemeta regrep srcclean
- ${INSTALL_PROGRAM} ${WRKSRC}/${f} ${PREFIX}/libexec/${PORTNAME}
+ ${INSTALL_PROGRAM} ${WRKSRC}/${f} ${PREFIX}/libexec/sdlmame
.endfor
${MKDIR} ${DATADIR}
${INSTALL_DATA} ${WRKSRC}/ui.bdf ${DATADIR}
diff --git a/emulators/mame-devel/distinfo b/emulators/mame-devel/distinfo
index 0aa39dcafb8c..f406474a03c0 100644
--- a/emulators/mame-devel/distinfo
+++ b/emulators/mame-devel/distinfo
@@ -1,3 +1,3 @@
-MD5 (sdlmame0117.zip) = dfda8c92853c72e7a6bbae8e686e8cf6
-SHA256 (sdlmame0117.zip) = 083cbac7b8b906431e675933473ce10da654ad5c8a380ca8d5be920f32394526
-SIZE (sdlmame0117.zip) = 15453659
+MD5 (sdlmame0118u3.zip) = c2cd6045b57c2ae2f74c128e3a464e84
+SHA256 (sdlmame0118u3.zip) = ca10d1a28c39131dc4b29d26f9a14e37ac1332ddda21937e47bae0214498f5e5
+SIZE (sdlmame0118u3.zip) = 15636259
diff --git a/emulators/mame-devel/files/patch-makefile b/emulators/mame-devel/files/patch-makefile
index beaf875a55c4..92e19a29f2f9 100644
--- a/emulators/mame-devel/files/patch-makefile
+++ b/emulators/mame-devel/files/patch-makefile
@@ -1,10 +1,11 @@
---- makefile.orig Thu Jun 28 14:55:46 2007
-+++ makefile Fri Jul 20 14:47:57 2007
-@@ -70,10 +70,12 @@
+--- makefile.orig Thu Aug 30 23:22:34 2007
++++ makefile Fri Aug 31 11:13:31 2007
+@@ -69,11 +69,13 @@
+ # uncomment next line to include the debugger
# DEBUG = 1
- # uncomment next line to use DRC MIPS3 engine
+ifeq ($(ARCH),i386)
+ # uncomment next line to use DRC MIPS3 engine
X86_MIPS3_DRC = 1
# uncomment next line to use DRC PowerPC engine
@@ -13,7 +14,18 @@
# uncomment next line to use DRC Voodoo rasterizers
# X86_VOODOO_DRC = 1
-@@ -157,8 +159,8 @@
+@@ -96,7 +98,9 @@
+ # CELL = 1
+
+ # uncomment next line if you are building for a 64-bit target
+-# PTR64 = 1
++ifeq ($(ARCH),amd64)
++PTR64 = 1
++endif
+
+ # uncomment next line to build expat as part of MAME build
+ BUILD_EXPAT = 1
+@@ -160,8 +164,8 @@
# compiler, linker and utilities
AR = @ar
@@ -24,16 +36,16 @@
MD = -mkdir$(EXE)
RM = @rm -f
-@@ -237,7 +239,7 @@
+@@ -240,7 +244,7 @@
endif
# fullname is prefix+name+suffix
-FULLNAME = $(PREFIX)$(NAME)$(SUFFIX)
-+FULLNAME = $(NAME)$(SUFFIX)
++FULLNAME = $(NAME)
# add an EXE suffix to get the final emulator name
EMULATOR = $(FULLNAME)$(EXE)
-@@ -302,7 +304,7 @@
+@@ -305,7 +309,7 @@
#-------------------------------------------------
# we compile to C89 standard with GNU extensions
@@ -42,21 +54,22 @@
# add -g if we need symbols
ifdef SYMBOLS
-@@ -333,12 +335,11 @@
+@@ -340,12 +344,12 @@
+ # if we are optimizing, include optimization options
# and make all errors into warnings
- # but not on 64-bit or debug builds
ifneq ($(OPTIMIZE),0)
-CFLAGS += $(ARCH) -fno-strict-aliasing
+CFLAGS += -fno-strict-aliasing
# only -Werror if not PTR64 and not DEBUG
- ifndef PTR64
ifndef DEBUG
--CFLAGS += -Werror
+ ifndef PTR64
+-CFLAGS += -Werror $(ARCH) -fno-strict-aliasing
++#CFLAGS += -Werror $(ARCH) -fno-strict-aliasing
endif # !DEBUG
endif # !PTR64
endif # neq OPTIMIZE
-@@ -358,6 +359,7 @@
+@@ -366,6 +370,7 @@
-I$(SRC)/lib/util \
-I$(SRC)/osd \
-I$(SRC)/osd/$(OSD) \
@@ -64,7 +77,7 @@
-@@ -367,7 +369,7 @@
+@@ -375,7 +380,7 @@
# LDFLAGS are used generally; LDFLAGSEMULATOR are additional
# flags only used when linking the core emulator
@@ -72,4 +85,4 @@
+LDFLAGS += -L$(LOCALBASE)/lib
LDFLAGSEMULATOR =
- # strip symbols and other metadata in non-symbols builds
+ # add profiling information for the linker
diff --git a/emulators/mame-devel/files/patch-src__osd__sdl__sdltime.c b/emulators/mame-devel/files/patch-src__osd__sdl__sdltime.c
deleted file mode 100644
index 6907940ec585..000000000000
--- a/emulators/mame-devel/files/patch-src__osd__sdl__sdltime.c
+++ /dev/null
@@ -1,11 +0,0 @@
---- ./src/osd/sdl/sdltime.c.orig Tue Jul 10 13:43:47 2007
-+++ ./src/osd/sdl/sdltime.c Wed Aug 29 00:49:36 2007
-@@ -34,7 +34,7 @@
-
-
- // cheez until u3
--#if defined(LSB_FIRST) && !defined(PTR64)
-+#ifdef __i386__
- #define X86_ASM
- #endif
-
diff --git a/emulators/mame-devel/files/sdlmame.in b/emulators/mame-devel/files/sdlmame.in
index 9a7c7215f76a..099cea29a2f8 100644
--- a/emulators/mame-devel/files/sdlmame.in
+++ b/emulators/mame-devel/files/sdlmame.in
@@ -2,14 +2,11 @@
#
# The executable needs to be run from its data directory, and needs to store
# configuration in it. We therefore mirror the data directory hierarchy in
-# ~/.cube, and create symlinks to the data files.
+# ~/.sdlmame, and create symlinks to the data files.
#
-if [ -d ~/.sdlmame ]
+if [ ! -d ~/.sdlmame ]
then
- echo "Using existing ~/.sdlmame directory."
-else
- echo "Creating ~/.sdlmame directory."
cd %%DATADIR%% || exit 1
find * -type d -exec mkdir -p ~/.sdlmame/{} \;
find * -type f -exec ln -s %%DATADIR%%/{} ~/.sdlmame/{} \; 2>/dev/null
diff --git a/emulators/mame-devel/pkg-plist b/emulators/mame-devel/pkg-plist
index 38001c5dee05..7fea49b2d950 100644
--- a/emulators/mame-devel/pkg-plist
+++ b/emulators/mame-devel/pkg-plist
@@ -14,6 +14,8 @@ libexec/sdlmame/testkeys
%%PORTDOCS%%%%DOCSDIR%%/docs/mame.txt
%%PORTDOCS%%%%DOCSDIR%%/docs/newvideo.txt
%%PORTDOCS%%%%DOCSDIR%%/docs/windows.txt
+%%PORTDOCS%%%%DOCSDIR%%/docs/config.txt
+%%PORTDOCS%%%%DOCSDIR%%/whatsnew_0118u3.txt
%%PORTDOCS%%%%DOCSDIR%%/whatsnew.txt
%%DATADIR%%/keymaps/km-ch.txt
%%DATADIR%%/keymaps/km-de.txt