aboutsummaryrefslogtreecommitdiff
path: root/emulators/mame
diff options
context:
space:
mode:
authorPawel Pekala <pawel@FreeBSD.org>2013-10-30 20:42:02 +0000
committerPawel Pekala <pawel@FreeBSD.org>2013-10-30 20:42:02 +0000
commitd0bbb68224ca2f18a6d7d5443dfe00fa0f7b8b71 (patch)
tree16908a730cd74b524b53f23a35877ac027b4d53c /emulators/mame
parent2cd503bcdb5f9bb9fadb663412a68fb84e801524 (diff)
downloadports-d0bbb68224ca2f18a6d7d5443dfe00fa0f7b8b71.tar.gz
ports-d0bbb68224ca2f18a6d7d5443dfe00fa0f7b8b71.zip
Notes
Diffstat (limited to 'emulators/mame')
-rw-r--r--emulators/mame/Makefile67
-rw-r--r--emulators/mame/distinfo4
-rw-r--r--emulators/mame/files/patch-src__emu__cpu__m6502__m6502make.py20
-rw-r--r--emulators/mame/files/patch-src__emu__cpu__m6809__m6809make.py11
-rw-r--r--emulators/mame/files/patch-src__emu__cpu__mcs96__mcs96make.py11
-rw-r--r--emulators/mame/files/patch-src__emu__cpu__tms57002__tmsmake.py11
-rw-r--r--emulators/mame/files/patch-src__osd__sdl__input.c14
-rw-r--r--emulators/mame/files/patch-src__osd__sdl__testkeys.c18
-rw-r--r--emulators/mame/pkg-plist11
9 files changed, 81 insertions, 86 deletions
diff --git a/emulators/mame/Makefile b/emulators/mame/Makefile
index 30a59d84aece..97e16b19c14d 100644
--- a/emulators/mame/Makefile
+++ b/emulators/mame/Makefile
@@ -2,8 +2,7 @@
# $FreeBSD$
PORTNAME= mame
-PORTVERSION= 0.149${PATCHSUFFIX}
-PORTREVISION= 1
+PORTVERSION= 0.150${PATCHSUFFIX}
CATEGORIES= emulators
MASTER_SITES= SF/${PORTNAME}.mirror/${PORTNAME:U}%20${PORTVERSION} \
http://mame.mirrors.zippykid.com/releases/ \
@@ -17,34 +16,34 @@ DIST_SUBDIR= ${PORTNAME}
MAINTAINER= ports@FreeBSD.org
COMMENT= Multi Arcade Machine Emulator
-LIB_DEPENDS= FLAC:${PORTSDIR}/audio/flac \
- jpeg:${PORTSDIR}/graphics/jpeg \
- expat:${PORTSDIR}/textproc/expat2 \
- fontconfig:${PORTSDIR}/x11-fonts/fontconfig
+LIB_DEPENDS= libFLAC.so:${PORTSDIR}/audio/flac \
+ libjpeg.so:${PORTSDIR}/graphics/jpeg \
+ libexpat.so:${PORTSDIR}/textproc/expat2 \
+ libfontconfig.so:${PORTSDIR}/x11-fonts/fontconfig
RUN_DEPENDS= liberation-fonts-ttf>=0:${PORTSDIR}/x11-fonts/liberation-fonts-ttf
-OPTIONS_DEFINE= DEBUG DOCS EXAMPLES
+OPTIONS_DEFINE= SDL2 DEBUG DOCS EXAMPLES
OPTIONS_RADIO= BUILTIN_DEBUGGER
OPTIONS_RADIO_BUILTIN_DEBUGGER= GTK2 QT4
+SDL2_DESC= SDL2 libraries support
BUILTIN_DEBUGGER_DESC= Builtin debugger support
NO_WRKSUBDIR= yes
USE_ZIP= yes
-USES= pkgconfig shebangfix
+USES= gmake pkgconfig shebangfix
SHEBANG_FILES= src/emu/cpu/m6502/m6502make.py \
src/emu/cpu/m6809/m6809make.py \
src/emu/cpu/mcs96/mcs96make.py \
src/emu/cpu/tms57002/tmsmake.py
-USE_DOS2UNIX= ${SHEBANG_FILES}
+USE_DOS2UNIX= src/osd/sdl/input.c \
+ src/osd/sdl/testkeys.c
USE_XORG= xext xi xinerama xrender
USE_GL= gl
-USE_SDL= sdl ttf
USE_PYTHON_BUILD=yes
-USE_GMAKE= yes
-MAKE_ENV= NOWERROR=1 OPTIMIZE=0 USE_NETWORK=1 \
+MAKE_ENV= NOWERROR=1 USE_NETWORK=1 \
OPT_FLAGS="${CXXFLAGS}" GCC_LDFLAGS="${LDFLAGS}" \
- TARGET="${PORTNAME}"
+ TARGET="${PORTNAME}" FULLNAME="${PORTNAME}"
MAKEFILE= makefile
SUB_FILES= pkg-message
@@ -58,9 +57,15 @@ UPDATE_PATCHES!= /usr/bin/jot -s " " \
${PATCHLEVEL} 1 ${PATCHLEVEL}
.endif
-NO_STAGE= yes
.include <bsd.port.options.mk>
+.if ${PORT_OPTIONS:MSDL2}
+USE_SDL= sdl2 ttf2
+MAKE_ENV+= SDL_LIBVER="sdl2"
+.else
+USE_SDL= sdl ttf
+.endif
+
.if ${PORT_OPTIONS:MDEBUG}
MAKE_ENV+= DEBUG=1
.endif
@@ -120,12 +125,14 @@ post-patch:
s|^BUILD_JPEGLIB|# BUILD_JPEGLIB| ; \
s| = @gcc| := $$(CC)| ; \
s| = @g++| := $$(CXX)| ; \
- s|^FULLNAME =.*|FULLNAME = $$(NAME)| ; \
+ s|-O$$(OPTIMIZE)|| ; \
/--warn-common/s|= -Wl,|= $$(GCC_LDFLAGS) -Wl,| ; \
/LDFLAGS/s|-s|| ; \
/LIBS/s|-lstdc++|| ; \
/LIBS/s|-lpthread|-pthread|' ${WRKSRC}/makefile
@${REINPLACE_CMD} -e \
+ '/realloc/s|^|// |' ${WRKSRC}/src/emu/emualloc.h
+ @${REINPLACE_CMD} -e \
'/LIBS/s|-lpthread|-pthread| ; \
/-system/s|/usr/local/|${LOCALBASE}/| ; \
/--cflags-only-I gtk+-2.0/s|=.*|= $$(GTK_INCPATH)| ; \
@@ -134,23 +141,21 @@ post-patch:
/X11R6/s|^|#|' ${WRKSRC}/src/osd/sdl/sdl.mak
do-install:
- ${INSTALL_PROGRAM} ${WRKSRC}/${PORTNAME} ${PREFIX}/bin
- @${MKDIR} ${PREFIX}/libexec/${PORTNAME}
+ (cd ${WRKSRC} && ${INSTALL_PROGRAM} ${PORTNAME} \
+ ${STAGEDIR}${PREFIX}/bin)
+ @${MKDIR} ${STAGEDIR}${PREFIX}/libexec/${PORTNAME}
.for F in chdman jedutil ldresample ldverify romcmp testkeys unidasm
- ${INSTALL_PROGRAM} ${WRKSRC}/${F} ${PREFIX}/libexec/${PORTNAME}
+ (cd ${WRKSRC} && ${INSTALL_PROGRAM} ${F} \
+ ${STAGEDIR}${PREFIX}/libexec/${PORTNAME})
.endfor
- @${MKDIR} ${DATADIR}
- @(cd ${WRKSRC} && ${COPYTREE_SHARE} artwork ${DATADIR})
- @(cd ${WRKSRC} && ${COPYTREE_SHARE} hash ${DATADIR})
- @(cd ${WRKSRC}/src/osd/sdl && ${COPYTREE_SHARE} keymaps ${DATADIR})
-.if ${PORT_OPTIONS:MDOCS}
- @${MKDIR} ${DOCSDIR}
- @(cd ${WRKSRC} && ${COPYTREE_SHARE} docs ${DOCSDIR})
-.endif
-.if ${PORT_OPTIONS:MEXAMPLES}
- @${MKDIR} ${EXAMPLESDIR}
- ${INSTALL_DATA} ${FILESDIR}/mame.ini ${EXAMPLESDIR}
-.endif
- @${CAT} ${PKGMESSAGE}
+ @${MKDIR} ${STAGEDIR}${DATADIR}
+ @(cd ${WRKSRC} && ${COPYTREE_SHARE} artwork ${STAGEDIR}${DATADIR})
+ @(cd ${WRKSRC} && ${COPYTREE_SHARE} hash ${STAGEDIR}${DATADIR})
+ @(cd ${WRKSRC}/src/osd/sdl && ${COPYTREE_SHARE} keymaps \
+ ${STAGEDIR}${DATADIR})
+ @${MKDIR} ${STAGEDIR}${DOCSDIR}
+ @(cd ${WRKSRC} && ${COPYTREE_SHARE} docs ${STAGEDIR}${DOCSDIR})
+ @${MKDIR} ${STAGEDIR}${EXAMPLESDIR}
+ (cd ${FILESDIR} && ${INSTALL_DATA} mame.ini ${STAGEDIR}${EXAMPLESDIR})
.include <bsd.port.post.mk>
diff --git a/emulators/mame/distinfo b/emulators/mame/distinfo
index 9c58a01a740f..5bb6ca1b12f7 100644
--- a/emulators/mame/distinfo
+++ b/emulators/mame/distinfo
@@ -1,2 +1,2 @@
-SHA256 (mame/mame0149s.zip) = 0e41b5773bea217d3ca04002903ac5ef569e6f5b67c05c72496d2cd7993b0a6b
-SIZE (mame/mame0149s.zip) = 35160585
+SHA256 (mame/mame0150s.zip) = e672b033baa001e1a909498b6c9206c68d0456fd883e410ad50f1a4f4c2253f7
+SIZE (mame/mame0150s.zip) = 35999158
diff --git a/emulators/mame/files/patch-src__emu__cpu__m6502__m6502make.py b/emulators/mame/files/patch-src__emu__cpu__m6502__m6502make.py
deleted file mode 100644
index acabda7a8e01..000000000000
--- a/emulators/mame/files/patch-src__emu__cpu__m6502__m6502make.py
+++ /dev/null
@@ -1,20 +0,0 @@
---- src/emu/cpu/m6502/m6502make.py.orig
-+++ src/emu/cpu/m6502/m6502make.py
-@@ -14,7 +14,7 @@
- opcodes = []
- logging.info("load_opcodes: %s", fname)
- try:
-- f = open(fname, "r")
-+ f = open(fname, "rU")
- except Exception, err:
- logging.error("cannot read opcodes file %s [%s]", fname, err)
- sys.exit(1)
-@@ -36,7 +36,7 @@
- logging.info("load_disp: %s", fname)
- states = []
- try:
-- f = open(fname, "r")
-+ f = open(fname, "rU")
- except Exception, err:
- logging.error("cannot read display file %s [%s]", fname, err)
- sys.exit(1)
diff --git a/emulators/mame/files/patch-src__emu__cpu__m6809__m6809make.py b/emulators/mame/files/patch-src__emu__cpu__m6809__m6809make.py
deleted file mode 100644
index ce17f473a708..000000000000
--- a/emulators/mame/files/patch-src__emu__cpu__m6809__m6809make.py
+++ /dev/null
@@ -1,11 +0,0 @@
---- src/emu/cpu/m6809/m6809make.py.orig
-+++ src/emu/cpu/m6809/m6809make.py
-@@ -16,7 +16,7 @@
- if path != "":
- path = path + '/'
- try:
-- f = open(fname, "r")
-+ f = open(fname, "rU")
- except Exception, err:
- print "Cannot read opcodes file %s [%s]" % (fname, err)
- sys.exit(1)
diff --git a/emulators/mame/files/patch-src__emu__cpu__mcs96__mcs96make.py b/emulators/mame/files/patch-src__emu__cpu__mcs96__mcs96make.py
deleted file mode 100644
index 9095178a3c53..000000000000
--- a/emulators/mame/files/patch-src__emu__cpu__mcs96__mcs96make.py
+++ /dev/null
@@ -1,11 +0,0 @@
---- src/emu/cpu/mcs96/mcs96make.py.orig
-+++ src/emu/cpu/mcs96/mcs96make.py
-@@ -69,7 +69,7 @@
- self.ea = {}
- self.macros = {}
- try:
-- f = open(fname, "r")
-+ f = open(fname, "rU")
- except Exception, err:
- print "Cannot read opcodes file %s [%s]" % (fname, err)
- sys.exit(1)
diff --git a/emulators/mame/files/patch-src__emu__cpu__tms57002__tmsmake.py b/emulators/mame/files/patch-src__emu__cpu__tms57002__tmsmake.py
deleted file mode 100644
index b5d72575246d..000000000000
--- a/emulators/mame/files/patch-src__emu__cpu__tms57002__tmsmake.py
+++ /dev/null
@@ -1,11 +0,0 @@
---- src/emu/cpu/tms57002/tmsmake.py.orig
-+++ src/emu/cpu/tms57002/tmsmake.py
-@@ -328,7 +328,7 @@
- def LoadLst(filename):
- instructions = []
- ins = None
-- for n, line in enumerate(open(filename)):
-+ for n, line in enumerate(open(filename, "rU")):
- line = line.rstrip()
- if not line and ins:
- # new lines separate intructions
diff --git a/emulators/mame/files/patch-src__osd__sdl__input.c b/emulators/mame/files/patch-src__osd__sdl__input.c
new file mode 100644
index 000000000000..2b2c0bf9e9fc
--- /dev/null
+++ b/emulators/mame/files/patch-src__osd__sdl__input.c
@@ -0,0 +1,14 @@
+--- src/osd/sdl/input.c.orig
++++ src/osd/sdl/input.c
+@@ -720,7 +720,11 @@
+ mame_printf_verbose("Joystick: Start initialization\n");
+ for (physical_stick = 0; physical_stick < SDL_NumJoysticks(); physical_stick++)
+ {
++#if (SDLMAME_SDL2)
++ char *joy_name = remove_spaces(machine, SDL_JoystickNameForIndex(physical_stick));
++#else
+ char *joy_name = remove_spaces(machine, SDL_JoystickName(physical_stick));
++#endif
+
+ devmap_register(&joy_map, physical_stick, joy_name);
+ }
diff --git a/emulators/mame/files/patch-src__osd__sdl__testkeys.c b/emulators/mame/files/patch-src__osd__sdl__testkeys.c
new file mode 100644
index 000000000000..70a72ac1f615
--- /dev/null
+++ b/emulators/mame/files/patch-src__osd__sdl__testkeys.c
@@ -0,0 +1,18 @@
+--- src/osd/sdl/testkeys.c.orig
++++ src/osd/sdl/testkeys.c
+@@ -146,7 +146,6 @@
+ printf("ITEM_ID_XY %s 0x%x 0x%x %s\n",
+ lookup_key_name(sdl_lookup, event.key.keysym.scancode),
+ (int) event.key.keysym.scancode,
+- (int) event.key.keysym.unicode,
+ "");
+ lasttext[0] = 0;
+ #else
+@@ -165,7 +164,6 @@
+ printf("ITEM_ID_XY %s 0x%x 0x%x %s\n",
+ lookup_key_name(sdl_lookup, event.key.keysym.scancode),
+ (int) event.key.keysym.scancode,
+- (int) event.key.keysym.unicode,
+ lasttext);
+ #else
+ memset(buf, 0, 19);
diff --git a/emulators/mame/pkg-plist b/emulators/mame/pkg-plist
index 5043c5e3d99b..6f4b264cf33c 100644
--- a/emulators/mame/pkg-plist
+++ b/emulators/mame/pkg-plist
@@ -27,6 +27,7 @@ libexec/mame/unidasm
%%DATADIR%%/hash/a5200.xml
%%DATADIR%%/hash/a7800.xml
%%DATADIR%%/hash/a800.xml
+%%DATADIR%%/hash/a800_flop.xml
%%DATADIR%%/hash/abc1600.xml
%%DATADIR%%/hash/abc80.xml
%%DATADIR%%/hash/abc800.xml
@@ -39,6 +40,7 @@ libexec/mame/unidasm
%%DATADIR%%/hash/aim65_cart.xml
%%DATADIR%%/hash/alice32.xml
%%DATADIR%%/hash/alice90.xml
+%%DATADIR%%/hash/alphatro_flop.xml
%%DATADIR%%/hash/amiga1000_flop.xml
%%DATADIR%%/hash/amiga1200_flop.xml
%%DATADIR%%/hash/amiga3000_flop.xml
@@ -49,6 +51,7 @@ libexec/mame/unidasm
%%DATADIR%%/hash/amigaaga_flop.xml
%%DATADIR%%/hash/amigaecs_flop.xml
%%DATADIR%%/hash/amigaocs_flop.xml
+%%DATADIR%%/hash/ampro.xml
%%DATADIR%%/hash/apc.xml
%%DATADIR%%/hash/apfm1000.xml
%%DATADIR%%/hash/apogee.xml
@@ -67,6 +70,7 @@ libexec/mame/unidasm
%%DATADIR%%/hash/bbcm_cart.xml
%%DATADIR%%/hash/bbcm_cass.xml
%%DATADIR%%/hash/bk0010.xml
+%%DATADIR%%/hash/bml3_flop.xml
%%DATADIR%%/hash/bw12.xml
%%DATADIR%%/hash/bw2.xml
%%DATADIR%%/hash/bx256hp_flop.xml
@@ -89,16 +93,19 @@ libexec/mame/unidasm
%%DATADIR%%/hash/coleco.xml
%%DATADIR%%/hash/compis.xml
%%DATADIR%%/hash/comx35_flop.xml
+%%DATADIR%%/hash/copera.xml
%%DATADIR%%/hash/cpc_cass.xml
%%DATADIR%%/hash/cpc_flop.xml
%%DATADIR%%/hash/crvision.xml
%%DATADIR%%/hash/dim68k.xml
+%%DATADIR%%/hash/dps1.xml
%%DATADIR%%/hash/ec1841.xml
%%DATADIR%%/hash/einstein.xml
%%DATADIR%%/hash/electron_cart.xml
%%DATADIR%%/hash/ep64_cart.xml
%%DATADIR%%/hash/ep64_cass.xml
%%DATADIR%%/hash/ep64_flop.xml
+%%DATADIR%%/hash/famicom_cass.xml
%%DATADIR%%/hash/famicom_flop.xml
%%DATADIR%%/hash/fm77av.xml
%%DATADIR%%/hash/fm7_cass.xml
@@ -246,6 +253,7 @@ libexec/mame/unidasm
%%DATADIR%%/hash/snes.xml
%%DATADIR%%/hash/snes_bspack.xml
%%DATADIR%%/hash/snes_strom.xml
+%%DATADIR%%/hash/snes_vkun.xml
%%DATADIR%%/hash/socrates.xml
%%DATADIR%%/hash/softbox.xml
%%DATADIR%%/hash/softwarelist.dtd
@@ -294,13 +302,16 @@ libexec/mame/unidasm
%%DATADIR%%/hash/vic1001_cart.xml
%%DATADIR%%/hash/vic1001_cass.xml
%%DATADIR%%/hash/vic1001_flop.xml
+%%DATADIR%%/hash/victor9k_flop.xml
%%DATADIR%%/hash/vidbrain.xml
%%DATADIR%%/hash/vii.xml
%%DATADIR%%/hash/vip.xml
+%%DATADIR%%/hash/visicom.xml
%%DATADIR%%/hash/vixen.xml
%%DATADIR%%/hash/vsmile_cart.xml
%%DATADIR%%/hash/vsmile_cd.xml
%%DATADIR%%/hash/wangpc.xml
+%%DATADIR%%/hash/wicat.xml
%%DATADIR%%/hash/wmbullet.xml
%%DATADIR%%/hash/wscolor.xml
%%DATADIR%%/hash/wswan.xml