aboutsummaryrefslogtreecommitdiff
path: root/emulators/mednafen
diff options
context:
space:
mode:
authorRene Ladan <rene@FreeBSD.org>2014-02-28 21:11:09 +0000
committerRene Ladan <rene@FreeBSD.org>2014-02-28 21:11:09 +0000
commitde27093f4ad77f522c1a2b1c7ca8f77c4f6cf76b (patch)
tree5b760f07af7adef878a2ba68374697345fe6d73e /emulators/mednafen
parentc41439ff51d7d54b8ae85a4436586d458796afeb (diff)
downloadports-de27093f4ad77f522c1a2b1c7ca8f77c4f6cf76b.tar.gz
ports-de27093f4ad77f522c1a2b1c7ca8f77c4f6cf76b.zip
Notes
Diffstat (limited to 'emulators/mednafen')
-rw-r--r--emulators/mednafen/Makefile86
-rw-r--r--emulators/mednafen/distinfo4
-rw-r--r--emulators/mednafen/files/patch-src__file.cpp29
-rw-r--r--emulators/mednafen/files/patch-src__pcfx__pcfx.cpp10
-rw-r--r--emulators/mednafen/pkg-descr2
5 files changed, 93 insertions, 38 deletions
diff --git a/emulators/mednafen/Makefile b/emulators/mednafen/Makefile
index e3be92a3e9c1..5d02386aa6ab 100644
--- a/emulators/mednafen/Makefile
+++ b/emulators/mednafen/Makefile
@@ -1,8 +1,7 @@
# $FreeBSD$
PORTNAME= mednafen
-PORTVERSION= 0.8.B
-PORTREVISION= 8
+PORTVERSION= 0.8.D.3
PORTEPOCH= 1
CATEGORIES= emulators games
MASTER_SITES= SF/${PORTNAME}/Mednafen/${PORTVERSION}
@@ -10,54 +9,71 @@ MASTER_SITES= SF/${PORTNAME}/Mednafen/${PORTVERSION}
MAINTAINER= acm@FreeBSD.org
COMMENT= Portable multi-system emulator
-LIB_DEPENDS= cdio.13:${PORTSDIR}/sysutils/libcdio \
- sndfile.1:${PORTSDIR}/audio/libsndfile \
- vorbis.4:${PORTSDIR}/audio/libvorbis
+LICENSE= GPLv2
-BROKEN= Does not build
-DEPRECATED= Broken for more than 6 month
-EXPIRATION_DATE= 2014-02-27
+LIB_DEPENDS= libcdio.so:${PORTSDIR}/sysutils/libcdio \
+ libsndfile.so:${PORTSDIR}/audio/libsndfile \
+ libvorbis.so:${PORTSDIR}/audio/libvorbis
-MAKE_JOBS_UNSAFE= yes
-USES= gmake
USE_BZIP2= yes
GNU_CONFIGURE= yes
USE_SDL= sdl net
-USE_XORG= x11
-USE_GL= glut
+USE_GL= gl glu
CPPFLAGS+= -I${LOCALBASE}/include
-LDFLAGS+= -L${LOCALBASE}/lib ${PTHREAD}
+LDFLAGS+= -L${LOCALBASE}/lib
WRKSRC= ${WRKDIR}/${PORTNAME}
SUB_FILES= pkg-message
-OPTIONS_DEFINE= NLS DOCS
+CONFIGURE_ARGS+=--disable-alsa --disable-alsatest \
+ --with-sdl-prefix=${LOCALBASE}
-NO_STAGE= yes
-.include <bsd.port.options.mk>
+USES= iconv pkgconfig:build
-.if ${PORT_OPTIONS:MNLS}
-USES+= gettext
-PLIST_SUB+= NLS=""
-FLAG_NLS= true
-.else
-CONFIGURE_ARGS+= --disable-nls
-PLIST_SUB+= NLS="@comment "
-.endif
+OPTIONS_DEFINE= NLS DOCS JACK
+OPTIONS_MULTI= EMU
+OPTIONS_MULTI_EMU= GB GBA LINX NES NGP PCE PCFX SMS SWAN
+OPTIONS_DEFAULT= GB GBA LINX NES NGP PCE PCFX SMS SWAN
-.if ${ARCH}==sparc64
-BROKEN= does not compile on ${ARCH} due to internal compiler error
-.endif
+GB_DESC= build with GameBoy emulation
+GBA_DESC= build with GameBoy Advance emulation
+LINX_DESC= build with Atari Lynx emulation
+NES_DESC= build with Nintendo Entertainment System emulation
+NGP_DESC= build with Neo Geo Pocket emulation
+PCE_DESC= build with PC Engine (TurboGrafx 16) emulation
+PCFX_DESC= build with PC-FX emulation
+SMS_DESC= build with SMS+GG emulation
+SWAN_DESC= build with WonderSWan emulation
+JACK_DESC= support the JACK audio API
+
+OPTIONS_SUB= yes
+
+NLS_USES= gettext
+NLS_CONFIGURE_ENABLE=nls
+
+JACK_LIB_DEPENDS=libjack.so:${PORTSDIR}/audio/jack
+JACK_CONFIGURE_ENABLE=jack
+
+GB_CONFIGURE_ENABLE=gb
+GBA_CONFIGURE_ENABLE=gba
+LINX_CONFIGURE_ENABLE=lynx
+NES_CONFIGURE_ENABLE=nes
+NGP_CONFIGURE_ENABLE=ngp
+PCE_CONFIGURE_ENABLE=pce
+PCFX_CONFIGURE_ENABLE=pcfx
+SMS_CONFIGURE_ENABLE=sms
+SWAN_CONFIGURE_ENABLE=wswan
+
+BROKEN_sparc64= does not compile due to internal compiler error
pre-configure:
- @${REINPLACE_CMD} -e 's|sdl-config|${SDL_CONFIG}|g' -e \
- 's|/usr/local|${LOCALBASE}|g' -e 's|/usr/X11R6|${LOCALBASE}|g' \
- ${WRKSRC}/configure
+ @${REINPLACE_CMD} -e 's|/usr/local|${LOCALBASE}|g' \
+ -e 's|/usr/X11R6|${LOCALBASE}|g' \
+ ${WRKSRC}/configure
+ @${REINPLACE_CMD} -e 's|NetBSD|FreeBSD|' \
+ ${WRKSRC}/include/trio/triodef.h
post-install:
-.if ${PORT_OPTIONS:MDOCS}
- @${MKDIR} ${DOCSDIR}
- @${INSTALL_DATA} ${WRKSRC}/Documentation/mednafen.html ${DOCSDIR}
-.endif
- @${CAT} ${PKGMESSAGE}
+ @${MKDIR} ${STAGEDIR}${DOCSDIR}
+ @${INSTALL_DATA} ${WRKSRC}/Documentation/mednafen.html ${STAGEDIR}${DOCSDIR}
.include <bsd.port.mk>
diff --git a/emulators/mednafen/distinfo b/emulators/mednafen/distinfo
index 31d84981c191..bf4497db8eca 100644
--- a/emulators/mednafen/distinfo
+++ b/emulators/mednafen/distinfo
@@ -1,2 +1,2 @@
-SHA256 (mednafen-0.8.B.tar.bz2) = d7f5122ddab321f971833733f20858e2300693b1b489cc78f06aa7fd08f0b892
-SIZE (mednafen-0.8.B.tar.bz2) = 2414246
+SHA256 (mednafen-0.8.D.3.tar.bz2) = d678178f0dc03c89c7a0c83bf0c721af406ee53dfa79295432ab13722ed0eea2
+SIZE (mednafen-0.8.D.3.tar.bz2) = 2442705
diff --git a/emulators/mednafen/files/patch-src__file.cpp b/emulators/mednafen/files/patch-src__file.cpp
new file mode 100644
index 000000000000..1012cc3b6eff
--- /dev/null
+++ b/emulators/mednafen/files/patch-src__file.cpp
@@ -0,0 +1,29 @@
+--- src/file.cpp.orig 2009-05-15 06:12:55.000000000 +0400
++++ src/file.cpp 2013-06-07 18:52:21.000000000 +0400
+@@ -229,7 +229,7 @@
+ goto doret;
+ }
+
+- while((howmany = gzread(tz, tmp->data + cur_size, cur_alloced - cur_size)) > 0)
++ while((howmany = gzread((gzFile)tz, tmp->data + cur_size, cur_alloced - cur_size)) > 0)
+ {
+ cur_size += howmany;
+ cur_alloced <<= 1;
+@@ -282,7 +282,7 @@
+ }
+ else if(type == MDFN_FILETYPE_GZIP)
+ {
+- gzclose(tz);
++ gzclose((gzFile)tz);
+ }
+ else if(type == MDFN_FILETYPE_ZIP)
+ {
+@@ -444,7 +444,7 @@
+
+ if(!(fceufp = MakeMemWrap(t, 1)))
+ {
+- gzclose(t);
++ gzclose((gzFile)t);
+ return(0);
+ }
+
diff --git a/emulators/mednafen/files/patch-src__pcfx__pcfx.cpp b/emulators/mednafen/files/patch-src__pcfx__pcfx.cpp
new file mode 100644
index 000000000000..286480c230b8
--- /dev/null
+++ b/emulators/mednafen/files/patch-src__pcfx__pcfx.cpp
@@ -0,0 +1,10 @@
+--- src/pcfx/pcfx.cpp.orig 2009-12-24 11:03:43.000000000 +0100
++++ src/pcfx/pcfx.cpp 2014-02-28 21:38:56.000000000 +0100
+@@ -35,6 +35,7 @@
+ #include <errno.h>
+ #include <string.h>
+ #include <math.h>
++#include <unistd.h>
+
+ #ifdef WANT_PCFX_MMAP
+ #include <sys/mman.h>
diff --git a/emulators/mednafen/pkg-descr b/emulators/mednafen/pkg-descr
index a3dab749d492..ff41201e8373 100644
--- a/emulators/mednafen/pkg-descr
+++ b/emulators/mednafen/pkg-descr
@@ -13,4 +13,4 @@ a joystick is preferred over a keyboard to play games, as the joystick will have
slightly less latency, although the latency differences may not be perceptible
to most people.
-WWW: http://mednafen.sf.net/
+WWW: http://mednafen.sf.net/