aboutsummaryrefslogtreecommitdiff
path: root/emulators/mess
diff options
context:
space:
mode:
authorMax Brazhnikov <makc@FreeBSD.org>2010-08-08 12:52:14 +0000
committerMax Brazhnikov <makc@FreeBSD.org>2010-08-08 12:52:14 +0000
commit0dc963d6c3a293eeb80819d9571798fbd130763e (patch)
tree093c84c2ac9564c5dafe8eb2c78eeb0b3e62f14b /emulators/mess
parent6edde950789e865dec7cdc1de5f9b82113d91752 (diff)
downloadports-0dc963d6c3a293eeb80819d9571798fbd130763e.tar.gz
ports-0dc963d6c3a293eeb80819d9571798fbd130763e.zip
Notes
Diffstat (limited to 'emulators/mess')
-rw-r--r--emulators/mess/Makefile47
-rw-r--r--emulators/mess/distinfo9
-rw-r--r--emulators/mess/files/patch-debugcpu.c13
-rw-r--r--emulators/mess/files/patch-makefile22
-rw-r--r--emulators/mess/files/patch-makefile.sdl57
-rw-r--r--emulators/mess/files/sdl.mak.patch47
-rw-r--r--emulators/mess/pkg-plist41
7 files changed, 106 insertions, 130 deletions
diff --git a/emulators/mess/Makefile b/emulators/mess/Makefile
index 884bbcf89491..06035d3b0506 100644
--- a/emulators/mess/Makefile
+++ b/emulators/mess/Makefile
@@ -5,28 +5,33 @@
# $FreeBSD$
#
-PORTNAME= sdlmess
-PORTVERSION= 0.136
+PORTNAME= mess
+PORTVERSION= 0.139
CATEGORIES= emulators
-MASTER_SITES= ftp://ftp.arcadebsd.org/pub/ArcadeBSD/ports/distfiles/
-DISTNAME= ${PORTNAME}${PORTVERSION:S/.//}
+MASTER_SITES= http://www.aarongiles.com/mirror/releases/:mame \
+ http://www.mess.org/files/:mess \
+ ftp://ftp.arcadebsd.org/pub/ArcadeBSD/ports/distfiles/
+DISTFILES= mame${PORTVERSION:S/.//}s.zip:mame \
+ mess${PORTVERSION:S/.//}s.zip:mess
MAINTAINER= elbarto@ArcadeBSD.org
-COMMENT= SDL port of the popular MESS (Multiple Emulator Super System)
+COMMENT= The popular MESS (Multiple Emulator Super System)
-FETCH_ENV= HTTP_USER_AGENT=defined
USE_ZIP= yes
+NO_WRKSUBDIR= yes
USE_XORG= xext xrender xinerama xi
USE_GL= gl
USE_GNOME?= gtk20 gconf2
USE_GMAKE= yes
-MAKE_ENV= PTHREAD_LIBS="${PTHREAD_LIBS}"
+MAKE_ENV= PTHREAD_LIBS="${PTHREAD_LIBS}" TARGET=mess
USE_SDL= sdl
-MAKEFILE= makefile.sdl
+USE_GCC= 4.4+
+MAKEFILE= makefile
ONLY_FOR_ARCHS= i386 amd64
SUB_FILES= pkg-message
+USE_DOS2UNIX= sdl.mak debugcpu.c makefile
-OPTIONS= DEBUG "Build sdlmess debugger" off
+OPTIONS= DEBUG "Build mess debugger" off
.include <bsd.port.pre.mk>
@@ -35,7 +40,7 @@ USE_GNOME= #
EXTRA_PATCHES+= ${FILESDIR}/sdl.mak.patch
.endif
-MAKE_JOBS_UNSAFE= yes
+MAKE_JOBS_SAFE= yes
.if ${ARCH} == "amd64"
MAKE_ENV+= PTR64=1
@@ -44,27 +49,29 @@ MAKE_ENV+= PTR64=1
BROKEN= Does not compile on sparc64
.endif
+post-extract:
+ @${EXTRACT_CMD} ${EXTRACT_BEFORE_ARGS} ${WRKDIR}/mame.zip ${EXTRACT_AFTER_ARGS}
+ @${RM} -f ${WRKDIR}/mame.zip
+
post-patch:
@${REINPLACE_CMD} -e "s|ui.bdf|${DATADIR}/ui.bdf|g" ${WRKSRC}/src/emu/ui.c
do-install:
${INSTALL_PROGRAM} ${WRKSRC}/${PORTNAME} ${PREFIX}/bin/
- ${MKDIR} ${PREFIX}/libexec/sdlmess
- ${INSTALL_PROGRAM} ${WRKSRC}/chdman ${PREFIX}/libexec/sdlmess
- ${INSTALL_PROGRAM} ${WRKSRC}/imgtool ${PREFIX}/libexec/sdlmess
- ${INSTALL_PROGRAM} ${WRKSRC}/jedutil ${PREFIX}/libexec/sdlmess
- ${INSTALL_PROGRAM} ${WRKSRC}/ldresample ${PREFIX}/libexec/sdlmess
- ${INSTALL_PROGRAM} ${WRKSRC}/ldverify ${PREFIX}/libexec/sdlmess
- ${INSTALL_PROGRAM} ${WRKSRC}/testkeys ${PREFIX}/libexec/sdlmess
- ${INSTALL_PROGRAM} ${WRKSRC}/unidasm ${PREFIX}/libexec/sdlmess
+ ${MKDIR} ${PREFIX}/libexec/${PORTNAME}
+ ${INSTALL_PROGRAM} ${WRKSRC}/chdman ${PREFIX}/libexec/${PORTNAME}
+ ${INSTALL_PROGRAM} ${WRKSRC}/imgtool ${PREFIX}/libexec/${PORTNAME}
+ ${INSTALL_PROGRAM} ${WRKSRC}/jedutil ${PREFIX}/libexec/${PORTNAME}
+ ${INSTALL_PROGRAM} ${WRKSRC}/ldresample ${PREFIX}/libexec/${PORTNAME}
+ ${INSTALL_PROGRAM} ${WRKSRC}/ldverify ${PREFIX}/libexec/${PORTNAME}
+ ${INSTALL_PROGRAM} ${WRKSRC}/testkeys ${PREFIX}/libexec/${PORTNAME}
+ ${INSTALL_PROGRAM} ${WRKSRC}/unidasm ${PREFIX}/libexec/${PORTNAME}
.if !defined(NOPORTDOCS)
${MKDIR} ${DOCSDIR}
${INSTALL_DATA} ${WRKSRC}/*.txt ${DOCSDIR}
${CP} -R ${WRKSRC}/docs ${DOCSDIR}
.endif
${MKDIR} ${DATADIR}
- ${CP} ${WRKSRC}/ui.bdf ${DATADIR}/
- ${CP} -R ${WRKSRC}/keymaps ${DATADIR}/
${CP} -R ${WRKSRC}/hash ${DATADIR}/
${CP} -R ${WRKSRC}/artwork ${DATADIR}/
${MKDIR} ${EXAMPLESDIR}
diff --git a/emulators/mess/distinfo b/emulators/mess/distinfo
index 684dd62075ff..15c660436eda 100644
--- a/emulators/mess/distinfo
+++ b/emulators/mess/distinfo
@@ -1,3 +1,6 @@
-MD5 (sdlmess0136.zip) = ad07a5df80f0f7a548f14703aa6ff756
-SHA256 (sdlmess0136.zip) = c8be6f3c939738370bcfabd629661691926d00ae0f70032d8f8379313dca88bb
-SIZE (sdlmess0136.zip) = 36705871
+MD5 (mame0139s.zip) = e9f81e86b786e0131eb6fb59e6bfe189
+SHA256 (mame0139s.zip) = e9dc268530b9a2b6fe17330af96dc5680dadba1b5e444bf7ef8fa1f15de7f3d6
+SIZE (mame0139s.zip) = 16706970
+MD5 (mess0139s.zip) = 21617dc50408612905c138ed2d6b2930
+SHA256 (mess0139s.zip) = def723e0e87c6b541c145c9a5c92d86187d530662fb88b186f0c596e1e1309ed
+SIZE (mess0139s.zip) = 18474426
diff --git a/emulators/mess/files/patch-debugcpu.c b/emulators/mess/files/patch-debugcpu.c
new file mode 100644
index 000000000000..a1ae1edd89ed
--- /dev/null
+++ b/emulators/mess/files/patch-debugcpu.c
@@ -0,0 +1,13 @@
+--- src/emu/debug/debugcpu.c.orig 2010-08-01 23:31:06.000000000 +0200
++++ src/emu/debug/debugcpu.c 2010-08-01 23:31:23.000000000 +0200
+@@ -49,7 +49,9 @@
+ #include "debugint/debugint.h"
+ #include "uiinput.h"
+ #include <ctype.h>
+-
++#ifdef __FreeBSD__
++#undef tolower
++#endif
+
+
+ /***************************************************************************
diff --git a/emulators/mess/files/patch-makefile b/emulators/mess/files/patch-makefile
new file mode 100644
index 000000000000..f9d1b57ad89d
--- /dev/null
+++ b/emulators/mess/files/patch-makefile
@@ -0,0 +1,22 @@
+--- makefile.orig 2010-08-01 23:04:35.000000000 +0200
++++ makefile 2010-08-01 23:04:58.000000000 +0200
+@@ -295,8 +295,8 @@
+
+ # compiler, linker and utilities
+ AR = @ar
+-CC = @gcc
+-LD = @g++
++CC:= @$(CC)
++LD:= @$(CXX)
+ MD = -mkdir$(EXE)
+ RM = @rm -f
+ OBJDUMP = @objdump
+@@ -344,7 +344,7 @@
+ endif
+
+ # fullname is prefix+name+suffix+suffix64+suffixdebug
+-FULLNAME = $(PREFIX)$(PREFIXSDL)$(NAME)$(SUFFIX)$(SUFFIX64)$(SUFFIXDEBUG)$(SUFFIXPROFILE)
++FULLNAME = $(NAME)
+
+ # add an EXE suffix to get the final emulator name
+ EMULATOR = $(FULLNAME)$(EXE)
diff --git a/emulators/mess/files/patch-makefile.sdl b/emulators/mess/files/patch-makefile.sdl
deleted file mode 100644
index cc14870893d9..000000000000
--- a/emulators/mess/files/patch-makefile.sdl
+++ /dev/null
@@ -1,57 +0,0 @@
---- makefile.sdl.orig 2009-09-17 02:49:53.000000000 +0200
-+++ makefile.sdl 2009-11-24 07:25:56.000000000 +0100
-@@ -59,7 +59,7 @@
- ifeq ($(OSD),windows)
- TARGETOS = win32
- else
--TARGETOS = unix
-+TARGETOS = freebsd
- endif
- endif
-
-@@ -197,8 +197,8 @@
-
- # compiler, linker and utilities
- AR = @ar
--CC = @gcc
--LD = @gcc
-+CC := @$(CC)
-+LD := @$(CC)
- MD = -mkdir$(EXE)
- RM = @rm -f
-
-@@ -227,7 +227,7 @@
- endif
-
- # fullname is prefix+name+suffix+debugsuffix
--FULLNAME = $(PREFIX)$(NAME)$(CPPSUFFIX)$(SUFFIX)$(DEBUGSUFFIX)
-+FULLNAME = sdl$(NAME)$(CPPSUFFIX)$(SUFFIX)$(DEBUGSUFFIX)
-
- # add an EXE suffix to get the final emulator name
- EMULATOR = $(FULLNAME)$(EXE)
-@@ -338,7 +338,7 @@
- ifneq ($(OPTIMIZE),0)
- ifneq ($(TARGETOS),os2)
- ifndef IA64
--CCOMFLAGS += -Werror -fno-strict-aliasing $(ARCHOPTS)
-+CCOMFLAGS += -fno-strict-aliasing $(ARCHOPTS)
- else
- endif
- else
-@@ -382,6 +382,7 @@
- -I$(SRC)/lib/util \
- -I$(SRC)/osd \
- -I$(SRC)/osd/$(OSD) \
-+ -I$(LOCALBASE)/include \
-
-
-
-@@ -395,7 +396,7 @@
- ifneq ($(TARGETOS),macosx)
- ifneq ($(TARGETOS),os2)
- ifneq ($(TARGETOS),solaris)
--LDFLAGS = -Wl,--warn-common
-+LDFLAGS = -Wl,--warn-common $(PTHREAD_LIBS) -L$(LOCALBASE)/lib
- endif
- endif
- endif
diff --git a/emulators/mess/files/sdl.mak.patch b/emulators/mess/files/sdl.mak.patch
index 9623fe59ac74..182a912af4d3 100644
--- a/emulators/mess/files/sdl.mak.patch
+++ b/emulators/mess/files/sdl.mak.patch
@@ -1,25 +1,32 @@
---- src/osd/sdl/sdl.mak.orig 2009-11-13 11:09:21.000000000 +0100
-+++ src/osd/sdl/sdl.mak 2009-11-13 11:10:24.000000000 +0100
-@@ -140,6 +140,7 @@
- endif
-
+--- src/osd/sdl/sdl.mak.orig 2010-02-14 04:47:30.000000000 +0100
++++ src/osd/sdl/sdl.mak 2010-08-02 11:50:12.000000000 +0200
+@@ -139,7 +139,8 @@
ifeq ($(TARGETOS),freebsd)
-+DEFS += -DNO_DEBUGGER
- TARGETOS = unix
- SYNC_IMPLEMENTATION = ntc
- endif
-@@ -288,10 +289,10 @@
+ BASE_TARGETOS = unix
+ SYNC_IMPLEMENTATION = tc
+-DEFS += -DNO_AFFINITY_NP
++DEFS += -DNO_AFFINITY_NP -DNO_DEBUGGER
++NO_DEBUGGER=1
+ # /usr/local/include is not considered a system include directory
+ # on FreeBSD. GL.h resides there and throws warnings
+ CCOMFLAGS += -isystem /usr/local/include
+@@ -304,7 +305,7 @@
+ ifeq ($(BASE_TARGETOS),unix)
+
+ DEFS += -DSDLMAME_UNIX
+-DEBUGOBJS = $(SDLOBJ)/debugwin.o $(SDLOBJ)/dview.o $(SDLOBJ)/debug-sup.o $(SDLOBJ)/debug-intf.o
++DEBUGOBJS = $(SDLOBJ)/debugwin.o
+ LIBGL = -lGL
+ ifeq ($(NO_X11),1)
+ NO_DEBUGGER = 1
+@@ -454,8 +455,8 @@
+
# the new debugger relies on GTK+ in addition to the base SDLMAME needs
# Non-X11 builds can not use the debugger
- ifndef NO_X11
--OSDCOREOBJS += $(SDLOBJ)/debugwin.o $(SDLOBJ)/dview.o $(SDLOBJ)/debug-sup.o $(SDLOBJ)/debug-intf.o
--CFLAGS += `pkg-config --cflags gtk+-2.0` `pkg-config --cflags gconf-2.0`
+-CCOMFLAGS += `pkg-config --cflags gtk+-2.0` `pkg-config --cflags gconf-2.0`
-LIBS += `pkg-config --libs gtk+-2.0` `pkg-config --libs gconf-2.0`
--CFLAGS += -DGTK_DISABLE_DEPRECATED
-+OSDCOREOBJS += $(SDLOBJ)/debugwin.o
-+#CFLAGS += `pkg-config --cflags gtk+-2.0` `pkg-config --cflags gconf-2.0`
++#CCOMFLAGS += `pkg-config --cflags gtk+-2.0` `pkg-config --cflags gconf-2.0`
+#LIBS += `pkg-config --libs gtk+-2.0` `pkg-config --libs gconf-2.0`
-+#CFLAGS += -DGTK_DISABLE_DEPRECATED
- else
- OSDCOREOBJS += $(SDLOBJ)/debugwin.o
- endif # NO_X11
+ #CCOMFLAGS += -DGTK_DISABLE_DEPRECATED
+
+ # some systems still put important things in a different prefix
diff --git a/emulators/mess/pkg-plist b/emulators/mess/pkg-plist
index 971268587d4d..da0c180d4e22 100644
--- a/emulators/mess/pkg-plist
+++ b/emulators/mess/pkg-plist
@@ -1,12 +1,11 @@
-bin/sdlmess
-libexec/sdlmess/chdman
-libexec/sdlmess/imgtool
-libexec/sdlmess/jedutil
-libexec/sdlmess/ldresample
-libexec/sdlmess/ldverify
-libexec/sdlmess/testkeys
-libexec/sdlmess/unidasm
-%%PORTDOCS%%%%DOCSDIR%%/SDLMESS.txt
+bin/mess
+libexec/mess/chdman
+libexec/mess/imgtool
+libexec/mess/jedutil
+libexec/mess/ldresample
+libexec/mess/ldverify
+libexec/mess/testkeys
+libexec/mess/unidasm
%%PORTDOCS%%%%DOCSDIR%%/whatsnew.txt
%%PORTDOCS%%%%DOCSDIR%%/docs/config.txt
%%PORTDOCS%%%%DOCSDIR%%/docs/credits.htm
@@ -18,7 +17,6 @@ libexec/sdlmess/unidasm
%%PORTDOCS%%%%DOCSDIR%%/docs/newvideo.txt
%%PORTDOCS%%%%DOCSDIR%%/docs/windows.txt
%%PORTDOCS%%%%DOCSDIR%%/docs/wintoc.xml
-%%PORTDOCS%%%%DOCSDIR%%/docs/images/logo.gif
%%PORTDOCS%%%%DOCSDIR%%/docs/windows/choice.htm
%%PORTDOCS%%%%DOCSDIR%%/docs/windows/compile.htm
%%PORTDOCS%%%%DOCSDIR%%/docs/windows/config.htm
@@ -26,10 +24,8 @@ libexec/sdlmess/unidasm
%%PORTDOCS%%%%DOCSDIR%%/docs/windows/guiconf.htm
%%PORTDOCS%%%%DOCSDIR%%/docs/windows/guiuse.htm
%%PORTDOCS%%%%DOCSDIR%%/docs/windows/install.htm
-%%PORTDOCS%%%%DOCSDIR%%/docs/windows/instbios.htm
%%PORTDOCS%%%%DOCSDIR%%/docs/windows/instroms.htm
%%PORTDOCS%%%%DOCSDIR%%/docs/windows/main.htm
-%%PORTDOCS%%%%DOCSDIR%%/docs/windows/mgebios.htm
%%PORTDOCS%%%%DOCSDIR%%/docs/windows/mgeroms.htm
%%PORTDOCS%%%%DOCSDIR%%/docs/windows/osmenu.htm
%%PORTDOCS%%%%DOCSDIR%%/docs/windows/runsw.htm
@@ -62,9 +58,6 @@ libexec/sdlmess/unidasm
%%DATADIR%%/artwork/dallas.zip
%%DATADIR%%/artwork/dallas16.zip
%%DATADIR%%/artwork/dallas32.zip
-%%DATADIR%%/artwork/dir.txt
-%%DATADIR%%/artwork/floppyr.png
-%%DATADIR%%/artwork/floppyw.png
%%DATADIR%%/artwork/glasgow.zip
%%DATADIR%%/artwork/hp48g.zip
%%DATADIR%%/artwork/hp48gp.zip
@@ -73,8 +66,6 @@ libexec/sdlmess/unidasm
%%DATADIR%%/artwork/hp48sx.zip
%%DATADIR%%/artwork/junior.zip
%%DATADIR%%/artwork/kim1.zip
-%%DATADIR%%/artwork/ledoff.png
-%%DATADIR%%/artwork/ledon.png
%%DATADIR%%/artwork/mk1.zip
%%DATADIR%%/artwork/mk2.zip
%%DATADIR%%/artwork/mm4.zip
@@ -82,14 +73,12 @@ libexec/sdlmess/unidasm
%%DATADIR%%/artwork/mm50.zip
%%DATADIR%%/artwork/mpf1.zip
%%DATADIR%%/artwork/mpf1b.zip
-%%DATADIR%%/artwork/nes.zip
%%DATADIR%%/artwork/pc1401.zip
%%DATADIR%%/artwork/pc1402.zip
%%DATADIR%%/artwork/pc1403.zip
%%DATADIR%%/artwork/rebel5.zip
%%DATADIR%%/artwork/roma32.zip
%%DATADIR%%/artwork/ssystem3.zip
-%%DATADIR%%/artwork/thomson.lay
%%DATADIR%%/artwork/thomson.zip
%%DATADIR%%/hash/a2600.hsi
%%DATADIR%%/hash/a5200.hsi
@@ -117,7 +106,6 @@ libexec/sdlmess/unidasm
%%DATADIR%%/hash/channelf.hsi
%%DATADIR%%/hash/coco.hsi
%%DATADIR%%/hash/coleco.hsi
-%%DATADIR%%/hash/coupe.hsi
%%DATADIR%%/hash/cpc464.hsi
%%DATADIR%%/hash/cpc6128.hsi
%%DATADIR%%/hash/dragon64.hsi
@@ -140,6 +128,7 @@ libexec/sdlmess/unidasm
%%DATADIR%%/hash/mc10.hsi
%%DATADIR%%/hash/megaduck.hsi
%%DATADIR%%/hash/microtan.hsi
+%%DATADIR%%/hash/mo5.hsi
%%DATADIR%%/hash/msx.hsi
%%DATADIR%%/hash/msx2.hsi
%%DATADIR%%/hash/mtx512.hsi
@@ -165,26 +154,18 @@ libexec/sdlmess/unidasm
%%DATADIR%%/hash/svision.hsi
%%DATADIR%%/hash/ti99_4a.hsi
%%DATADIR%%/hash/ts2068.hsi
+%%DATADIR%%/hash/vboy.hsi
%%DATADIR%%/hash/vc4000.hsi
%%DATADIR%%/hash/vectrex.hsi
%%DATADIR%%/hash/vic20.hsi
%%DATADIR%%/hash/wswan.hsi
-%%DATADIR%%/keymaps/km-be.txt
-%%DATADIR%%/keymaps/km-ch.txt
-%%DATADIR%%/keymaps/km-de.txt
-%%DATADIR%%/keymaps/km-fr-OSX.txt
-%%DATADIR%%/keymaps/km-fr.txt
-%%DATADIR%%/keymaps/km_it.txt
-%%DATADIR%%/ui.bdf
%%EXAMPLESDIR%%/mess.ini
@dirrm %%DATADIR%%/artwork
@dirrm %%DATADIR%%/hash
-@dirrm %%DATADIR%%/keymaps
@dirrm %%DATADIR%%
-%%PORTDOCS%%@dirrm %%DOCSDIR%%/docs/images
%%PORTDOCS%%@dirrm %%DOCSDIR%%/docs/windows/images
%%PORTDOCS%%@dirrm %%DOCSDIR%%/docs/windows
%%PORTDOCS%%@dirrm %%DOCSDIR%%/docs
%%PORTDOCS%%@dirrm %%DOCSDIR%%
@dirrm %%EXAMPLESDIR%%
-@dirrm libexec/sdlmess
+@dirrm libexec/mess