aboutsummaryrefslogtreecommitdiff
path: root/emulators/mess
diff options
context:
space:
mode:
authorJohn Marino <marino@FreeBSD.org>2015-05-25 07:29:14 +0000
committerJohn Marino <marino@FreeBSD.org>2015-05-25 07:29:14 +0000
commit9a7be0a6226ea2a6f07e3f1248bce8a82b7eb724 (patch)
tree85961cc0107c23673b6e458968293f8b724f3097 /emulators/mess
parent8056067f910cd6c9b5eb380af4a66550759bdc3d (diff)
Notes
Diffstat (limited to 'emulators/mess')
-rw-r--r--emulators/mess/Makefile129
-rw-r--r--emulators/mess/distinfo2
-rw-r--r--emulators/mess/files/extra-patch-src_osd_osdcore.c63
-rw-r--r--emulators/mess/files/mess.ini278
-rw-r--r--emulators/mess/files/patch-src__lib__lib7z__CpuArch.h11
-rw-r--r--emulators/mess/files/patch-src__lib__lua__luaconf.h11
-rw-r--r--emulators/mess/files/patch-src__osd__eigccx86.h128
-rw-r--r--emulators/mess/files/patch-src__osd__eminline.h11
-rw-r--r--emulators/mess/files/patch-src__osd__sdl__osinline.h11
-rw-r--r--emulators/mess/files/patch-src__osd__sdl__sdlsync_ntc.c29
-rw-r--r--emulators/mess/files/patch-src__osd__sdl__sdlsync_os2.c29
-rw-r--r--emulators/mess/files/pkg-message.in14
-rw-r--r--emulators/mess/pkg-plist94
13 files changed, 71 insertions, 739 deletions
diff --git a/emulators/mess/Makefile b/emulators/mess/Makefile
index 90070e607450..67b616b336c5 100644
--- a/emulators/mess/Makefile
+++ b/emulators/mess/Makefile
@@ -1,130 +1,11 @@
-# Created by: alepulver
# $FreeBSD$
PORTNAME= mess
-PORTVERSION= 0.154${PATCHSUFFIX}
-PORTREVISION= 2
-CATEGORIES= emulators
-MASTER_SITES= http://mamedev.mameworld.info/releases/ \
- http://emumovies.com/aarongiles/releases/ \
- http://mamedev.org/updates/:patchsets
-DISTFILES= mame${PORTVERSION:S/.//:C/p[0-9]*$//}s.zip \
- ${UPDATE_PATCHES:C/$/.zip:patchsets/}
-DIST_SUBDIR= mame
-
-MAINTAINER= ports@FreeBSD.org
+MTARGET= mess
COMMENT= Multiple Emulator Super System
-LIB_DEPENDS= libFLAC.so:${PORTSDIR}/audio/flac \
- libjpeg.so:${PORTSDIR}/graphics/jpeg \
- libexpat.so:${PORTSDIR}/textproc/expat2 \
- libfontconfig.so:${PORTSDIR}/x11-fonts/fontconfig
-RUN_DEPENDS= liberation-fonts-ttf>=0:${PORTSDIR}/x11-fonts/liberation-fonts-ttf
-
-NOT_FOR_ARCHS= ia64 powerpc sparc64
-
-USES= dos2unix gmake pkgconfig python:2,build shebangfix
-DOS2UNIX_FILES= src/lib/lib7z/CpuArch.h \
- src/lib/lua/luaconf.h \
- src/osd/eigccx86.h \
- src/osd/eminline.h \
- src/osd/osdcore.c \
- src/osd/sdl/osinline.h \
- src/osd/sdl/sdlsync_ntc.c \
- src/osd/sdl/sdlsync_os2.c
-SHEBANG_FILES= src/emu/cpu/m6502/m6502make.py \
- src/emu/cpu/m6809/m6809make.py \
- src/emu/cpu/mcs96/mcs96make.py \
- src/emu/cpu/tms57002/tmsmake.py
-USE_XORG= xext xi xinerama xrender
-USE_GL= gl
-NO_WRKSUBDIR= yes
-MAKE_ENV= NOWERROR=1 USE_NETWORK=1 \
- LD="${CXX}" PYTHON="${PYTHON_CMD}" \
- OPT_FLAGS="${CXXFLAGS}" GCC_LDFLAGS="${LDFLAGS}" \
- TARGET="mess" FULLNAME="mess" SDL_NETWORK="pcap"
-MAKE_ARGS= TARGETOS=freebsd
-MAKEFILE= makefile
-
-SUB_FILES= pkg-message
-
-OPTIONS_DEFINE= BUILTIN_DEBUGGER DEBUG DOCS EXAMPLES SDL2
-
-BUILTIN_DEBUGGER_DESC= Builtin debugger support
-BUILTIN_DEBUGGER_USE= QT4=gui,moc_build,qmake_build
-BUILTIN_DEBUGGER_MAKE_ENV_OFF=\
- NO_DEBUGGER=1 NO_USE_QTDEBUG=1
-DEBUG_MAKE_ENV= DEBUG=1
-SDL2_DESC= SDL2 libraries support
-SDL2_USE= SDL=sdl2,ttf2
-SDL2_MAKE_ENV= SDL_LIBVER="sdl2"
-
-PATCHLEVEL= # none
-
-.if defined(PATCHLEVEL) && ${PATCHLEVEL}
-PATCHSUFFIX= p${PATCHLEVEL}
-UPDATE_PATCHES!= /usr/bin/jot -s " " \
- -w ${PORTVERSION:S/.//:C/\.p[0-9]*$//}u%d_diff \
- ${PATCHLEVEL} 1 ${PATCHLEVEL}
-.endif
-
-.include <bsd.port.options.mk>
-
-.if empty(PORT_OPTIONS:MSDL2)
-USE_SDL= sdl ttf
-.endif
-
-.if ${ARCH} == amd64
-MAKE_ARGS+= PTR64=1
-.endif
-
-.if ${OPSYS} == DragonFly
-EXTRA_PATCHES= ${FILESDIR}/extra-patch-src_osd_osdcore.c
-.endif
-
-post-extract:
- (cd ${WRKDIR} && ${TAR} -xf mame.zip)
- @${RM} -f ${WRKDIR}/mame.zip
-# Use post-extract target to get in before dos2unix-isation
-.if defined(UPDATE_PATCHES)
-. for patch in ${UPDATE_PATCHES:S/_/./}
- @${ECHO_MSG} -n "===> Applying upstream development patch ${patch}... "
- ${PATCH} ${PATCH_ARGS} < ${WRKSRC}/${patch}
- @${ECHO_MSG} "[DONE]"
-. endfor
-.endif
-
-post-patch:
- @${REINPLACE_CMD} -e \
- 's|^\(BUILD_EXPAT \)|#\1| ; \
- s|^\(BUILD_ZLIB \)|#\1| ; \
- s|^\(BUILD_FLAC \)|#\1| ; \
- s|^\(BUILD_JPEGLIB \)|#\1| ; \
- s|^\(CC \)|#\1| ; \
- s|^\(LD \)|#\1| ; \
- s|^\(PYTHON \)|#\1| ; \
- s|-O$$(OPTIMIZE)|| ; \
- /--warn-common/s|= -Wl,|= $$(GCC_LDFLAGS) -Wl,| ; \
- /LDFLAGS/s|-s|| ; \
- /LIBS/s|-lstdc++||' ${WRKSRC}/makefile
- @${REINPLACE_CMD} -e \
- '/-isystem/s|^|#| ; \
- /X11R6/s|^|#|' ${WRKSRC}/src/osd/sdl/sdl.mak
-
-do-install:
- @${MKDIR} ${STAGEDIR}${DATADIR} \
- ${STAGEDIR}${DOCSDIR} \
- ${STAGEDIR}${EXAMPLESDIR} \
- ${STAGEDIR}${PREFIX}/libexec/mess
- ${INSTALL_PROGRAM} ${WRKSRC}/mess ${STAGEDIR}${PREFIX}/bin
- (cd ${WRKSRC} && ${INSTALL_PROGRAM} castool chdman imgtool jedutil \
- ldresample ldverify romcmp testkeys unidasm \
- ${STAGEDIR}${PREFIX}/libexec/mess)
- (cd ${WRKSRC} && ${COPYTREE_SHARE} artwork ${STAGEDIR}${DATADIR})
- (cd ${WRKSRC} && ${COPYTREE_SHARE} hash ${STAGEDIR}${DATADIR})
- (cd ${WRKSRC}/src/osd/sdl && \
- ${COPYTREE_SHARE} keymaps ${STAGEDIR}${DATADIR})
- (cd ${WRKSRC} && ${COPYTREE_SHARE} docs ${STAGEDIR}${DOCSDIR})
- ${INSTALL_DATA} ${FILESDIR}/mess.ini ${STAGEDIR}${EXAMPLESDIR}
+MASTERDIR= ${.CURDIR}/../mame
+DESCR= ${.CURDIR}/pkg-descr
+PLIST= ${.CURDIR}/pkg-plist
-.include <bsd.port.mk>
+.include "${MASTERDIR}/Makefile"
diff --git a/emulators/mess/distinfo b/emulators/mess/distinfo
deleted file mode 100644
index 571d8a60cb20..000000000000
--- a/emulators/mess/distinfo
+++ /dev/null
@@ -1,2 +0,0 @@
-SHA256 (mame/mame0154s.zip) = 522ba9275e9f633ab616dcd0ac0ab4fcd3b72690ed09915dcd4d0b627c696149
-SIZE (mame/mame0154s.zip) = 39697095
diff --git a/emulators/mess/files/extra-patch-src_osd_osdcore.c b/emulators/mess/files/extra-patch-src_osd_osdcore.c
deleted file mode 100644
index 0892d35e5366..000000000000
--- a/emulators/mess/files/extra-patch-src_osd_osdcore.c
+++ /dev/null
@@ -1,63 +0,0 @@
---- src/osd/osdcore.c.orig 2014-10-05 09:30:10 UTC
-+++ src/osd/osdcore.c
-@@ -2,6 +2,10 @@
- #include "osdcore.h"
- #include "portmidi/portmidi.h"
-
-+typedef struct __FILE_public FILEX;
-+FILEX dummyval;
-+FILEX * dummy = &dummyval;
-+
- bool g_print_verbose = false;
-
-
-@@ -10,9 +14,14 @@ bool g_print_verbose = false;
- for file output
- -------------------------------------------------*/
-
--void osd_file_output_callback(FILE *param, const char *format, va_list argptr)
-+void osd_file_std_output_callback(FILEX *param, const char *format, va_list argptr)
-+{
-+ vfprintf(stdout, format, argptr);
-+}
-+
-+void osd_file_err_output_callback(FILEX *param, const char *format, va_list argptr)
- {
-- vfprintf(param, format, argptr);
-+ vfprintf(stderr, format, argptr);
- }
-
-
-@@ -21,7 +30,7 @@ void osd_file_output_callback(FILE *para
- for no output
- -------------------------------------------------*/
-
--void osd_null_output_callback(FILE *param, const char *format, va_list argptr)
-+void osd_null_std_output_callback(FILEX *param, const char *format, va_list argptr)
- {
- }
-
-@@ -30,16 +39,16 @@ void osd_null_output_callback(FILE *para
- /* output channels */
- static output_delegate output_cb[OSD_OUTPUT_CHANNEL_COUNT] =
- {
-- output_delegate(FUNC(osd_file_output_callback), stderr), // OSD_OUTPUT_CHANNEL_ERROR
-- output_delegate(FUNC(osd_file_output_callback), stderr), // OSD_OUTPUT_CHANNEL_WARNING
-- output_delegate(FUNC(osd_file_output_callback), stdout), // OSD_OUTPUT_CHANNEL_INFO
-+ output_delegate(FUNC(osd_file_err_output_callback), dummy), // OSD_OUTPUT_CHANNEL_ERROR
-+ output_delegate(FUNC(osd_file_err_output_callback), dummy), // OSD_OUTPUT_CHANNEL_WARNING
-+ output_delegate(FUNC(osd_file_std_output_callback), dummy), // OSD_OUTPUT_CHANNEL_INFO
- #ifdef MAME_DEBUG
-- output_delegate(FUNC(osd_file_output_callback), stdout), // OSD_OUTPUT_CHANNEL_DEBUG
-+ output_delegate(FUNC(osd_file_std_output_callback), dummy), // OSD_OUTPUT_CHANNEL_DEBUG
- #else
-- output_delegate(FUNC(osd_null_output_callback), stdout), // OSD_OUTPUT_CHANNEL_DEBUG
-+ output_delegate(FUNC(osd_null_std_output_callback), dummy), // OSD_OUTPUT_CHANNEL_DEBUG
- #endif
-- output_delegate(FUNC(osd_file_output_callback), stdout), // OSD_OUTPUT_CHANNEL_VERBOSE
-- output_delegate(FUNC(osd_file_output_callback), stdout) // OSD_OUTPUT_CHANNEL_LOG
-+ output_delegate(FUNC(osd_file_std_output_callback), dummy), // OSD_OUTPUT_CHANNEL_VERBOSE
-+ output_delegate(FUNC(osd_file_std_output_callback), dummy) // OSD_OUTPUT_CHANNEL_LOG
- };
-
-
diff --git a/emulators/mess/files/mess.ini b/emulators/mess/files/mess.ini
deleted file mode 100644
index e1bbab822520..000000000000
--- a/emulators/mess/files/mess.ini
+++ /dev/null
@@ -1,278 +0,0 @@
-<UNADORNED0>
-
-#
-# CORE CONFIGURATION OPTIONS
-#
-readconfig 1
-writeconfig 0
-
-#
-# CORE SEARCH PATH OPTIONS
-#
-rompath $HOME/.mess/roms
-hashpath $HOME/.mess/hash;/usr/local/share/mess/hash/
-samplepath $HOME/.mess/samples
-artpath $HOME/.mess/artwork;/usr/local/share/mess/artwork/
-ctrlrpath $HOME/.mess/ctrlr
-inipath $HOME/.mess;.;ini
-fontpath $HOME/.mess/font;/usr/local/share/mess/
-cheatpath $HOME/.mess/cheat
-crosshairpath $HOME/.mess/crosshair
-
-#
-# CORE OUTPUT DIRECTORY OPTIONS
-#
-cfg_directory $HOME/.mess/cfg
-nvram_directory $HOME/.mess/nvram
-memcard_directory $HOME/.mess/memcard
-input_directory $HOME/.mess/inp
-state_directory $HOME/.mess/sta
-snapshot_directory $HOME/.mess/snap
-diff_directory $HOME/.mess/diff
-comment_directory $HOME/.mess/comments
-
-#
-# CORE STATE/PLAYBACK OPTIONS
-#
-state
-autosave 0
-playback
-record
-mngwrite
-aviwrite
-wavwrite
-snapname %g/%i
-snapsize auto
-snapview internal
-burnin 0
-
-#
-# CORE PERFORMANCE OPTIONS
-#
-autoframeskip 0
-frameskip 0
-seconds_to_run 0
-throttle 1
-sleep 1
-speed 1.0
-refreshspeed 0
-
-#
-# CORE ROTATION OPTIONS
-#
-rotate 1
-ror 0
-rol 0
-autoror 0
-autorol 0
-flipx 0
-flipy 0
-
-#
-# CORE ARTWORK OPTIONS
-#
-artwork_crop 0
-use_backdrops 1
-use_overlays 1
-use_bezels 1
-use_cpanels 1
-use_marquees 1
-
-#
-# CORE SCREEN OPTIONS
-#
-brightness 1.0
-contrast 1.0
-gamma 1.0
-pause_brightness 0.65
-effect none
-
-#
-# CORE VECTOR OPTIONS
-#
-antialias 1
-beam 1.0
-flicker 0
-
-#
-# CORE SOUND OPTIONS
-#
-sound 1
-samplerate 48000
-samples 1
-volume 0
-
-#
-# CORE INPUT OPTIONS
-#
-coin_lockout 1
-ctrlr
-mouse 0
-joystick 1
-lightgun 0
-multikeyboard 0
-multimouse 0
-steadykey 0
-offscreen_reload 0
-joystick_map auto
-joystick_deadzone 0.3
-joystick_saturation 0.85
-natural 0
-joystick_contradictory 0
-coin_impulse 0
-
-#
-# CORE INPUT AUTOMATIC ENABLE OPTIONS
-#
-paddle_device keyboard
-adstick_device keyboard
-pedal_device keyboard
-dial_device keyboard
-trackball_device keyboard
-lightgun_device keyboard
-positional_device keyboard
-mouse_device mouse
-
-#
-# CORE DEBUGGING OPTIONS
-#
-log 0
-verbose 0
-update_in_pause 0
-debug 0
-debugscript
-debug_internal 0
-
-#
-# CORE MISC OPTIONS
-#
-bios
-cheat 0
-skip_gameinfo 0
-uifont default
-ramsize
-confirm_quit 0
-
-#
-# DEBUGGING OPTIONS
-#
-oslog 0
-watchdog 0
-
-#
-# PERFORMANCE OPTIONS
-#
-multithreading 0
-numprocessors auto
-sdlvideofps 0
-bench 0
-
-#
-# VIDEO OPTIONS
-#
-video soft
-numscreens 1
-window 0
-maximize 1
-keepaspect 1
-unevenstretch 1
-centerh 1
-centerv 1
-waitvsync 0
-syncrefresh 0
-scalemode none
-
-#
-# OpenGL-SPECIFIC OPTIONS
-#
-filter 1
-prescale 1
-gl_forcepow2texture 0
-gl_notexturerect 0
-gl_vbo 1
-gl_pbo 1
-gl_glsl 0
-gl_glsl_filter 1
-glsl_shader_mame0 none
-glsl_shader_mame1 none
-glsl_shader_mame2 none
-glsl_shader_mame3 none
-glsl_shader_mame4 none
-glsl_shader_mame5 none
-glsl_shader_mame6 none
-glsl_shader_mame7 none
-glsl_shader_mame8 none
-glsl_shader_mame9 none
-glsl_shader_screen0 none
-glsl_shader_screen1 none
-glsl_shader_screen2 none
-glsl_shader_screen3 none
-glsl_shader_screen4 none
-glsl_shader_screen5 none
-glsl_shader_screen6 none
-glsl_shader_screen7 none
-glsl_shader_screen8 none
-glsl_shader_screen9 none
-gl_glsl_vid_attr 1
-
-#
-# PER-WINDOW VIDEO OPTIONS
-#
-screen auto
-aspect auto
-resolution auto
-view auto
-screen0 auto
-aspect0 auto
-resolution0 auto
-view0 auto
-screen1 auto
-aspect1 auto
-resolution1 auto
-view1 auto
-screen2 auto
-aspect2 auto
-resolution2 auto
-view2 auto
-screen3 auto
-aspect3 auto
-resolution3 auto
-view3 auto
-
-#
-# FULL SCREEN OPTIONS
-#
-switchres 0
-useallheads 0
-
-#
-# SOUND OPTIONS
-#
-audio_latency 3
-
-#
-# SDL KEYBOARD MAPPING
-#
-keymap 0
-keymap_file keymap.dat
-uimodekey ITEM_ID_SCRLOCK
-
-#
-# SDL JOYSTICK MAPPING
-#
-joy_idx1 auto
-joy_idx2 auto
-joy_idx3 auto
-joy_idx4 auto
-joy_idx5 auto
-joy_idx6 auto
-joy_idx7 auto
-joy_idx8 auto
-sixaxis 0
-
-#
-# SDL LOWLEVEL DRIVER OPTIONS
-#
-videodriver auto
-audiodriver auto
-gl_lib auto
diff --git a/emulators/mess/files/patch-src__lib__lib7z__CpuArch.h b/emulators/mess/files/patch-src__lib__lib7z__CpuArch.h
deleted file mode 100644
index 592b8de03fff..000000000000
--- a/emulators/mess/files/patch-src__lib__lib7z__CpuArch.h
+++ /dev/null
@@ -1,11 +0,0 @@
---- src/lib/lib7z/CpuArch.h.orig
-+++ src/lib/lib7z/CpuArch.h
-@@ -16,7 +16,7 @@
- If MY_CPU_LE_UNALIGN is not defined, we don't know about these properties of platform.
- */
-
--#if defined(_M_X64) || defined(_M_AMD64) || defined(__x86_64__)
-+#if defined(__amd64__) || defined(_M_X64) || defined(_M_AMD64) || defined(__x86_64__)
- #define MY_CPU_AMD64
- #endif
-
diff --git a/emulators/mess/files/patch-src__lib__lua__luaconf.h b/emulators/mess/files/patch-src__lib__lua__luaconf.h
deleted file mode 100644
index deb447d3033a..000000000000
--- a/emulators/mess/files/patch-src__lib__lua__luaconf.h
+++ /dev/null
@@ -1,11 +0,0 @@
---- src/lib/lua/luaconf.h.orig
-+++ src/lib/lua/luaconf.h
-@@ -514,7 +514,7 @@
- #define LUA_NANTRICK
-
- /* pentium 64 bits? */
--#elif defined(__x86_64) /* }{ */
-+#elif defined(__amd64__) || defined(__x86_64__) || defined(__x86_64) /* }{ */
-
- #define LUA_IEEE754TRICK
- #define LUA_IEEEENDIAN 0
diff --git a/emulators/mess/files/patch-src__osd__eigccx86.h b/emulators/mess/files/patch-src__osd__eigccx86.h
deleted file mode 100644
index 1a05d626aca7..000000000000
--- a/emulators/mess/files/patch-src__osd__eigccx86.h
+++ /dev/null
@@ -1,128 +0,0 @@
---- src/osd/eigccx86.h.orig
-+++ src/osd/eigccx86.h
-@@ -42,7 +42,7 @@
- multiply and return the full 64 bit result
- -------------------------------------------------*/
-
--#ifndef __x86_64__
-+#if !defined(__amd64__) && !defined(__x86_64__)
- #define mul_32x32 _mul_32x32
- INLINE INT64 ATTR_CONST ATTR_FORCE_INLINE
- _mul_32x32(INT32 a, INT32 b)
-@@ -68,7 +68,7 @@
- result
- -------------------------------------------------*/
-
--#ifndef __x86_64__
-+#if !defined(__amd64__) && !defined(__x86_64__)
- #define mulu_32x32 _mulu_32x32
- INLINE UINT64 ATTR_CONST ATTR_FORCE_INLINE
- _mulu_32x32(UINT32 a, UINT32 b)
-@@ -145,7 +145,7 @@
- result to 32 bits
- -------------------------------------------------*/
-
--#ifndef __x86_64__
-+#if !defined(__amd64__) && !defined(__x86_64__)
- #define mul_32x32_shift _mul_32x32_shift
- INLINE INT32 ATTR_CONST ATTR_FORCE_INLINE
- _mul_32x32_shift(INT32 a, INT32 b, UINT8 shift)
-@@ -175,7 +175,7 @@
- result to 32 bits
- -------------------------------------------------*/
-
--#ifndef __x86_64__
-+#if !defined(__amd64__) && !defined(__x86_64__)
- #define mulu_32x32_shift _mulu_32x32_shift
- INLINE UINT32 ATTR_CONST ATTR_FORCE_INLINE
- _mulu_32x32_shift(UINT32 a, UINT32 b, UINT8 shift)
-@@ -203,7 +203,7 @@
- divide and return the 32 bit quotient
- -------------------------------------------------*/
-
--#ifndef __x86_64__
-+#if !defined(__amd64__) && !defined(__x86_64__)
- #define div_64x32 _div_64x32
- INLINE INT32 ATTR_CONST ATTR_FORCE_INLINE
- _div_64x32(INT64 a, INT32 b)
-@@ -230,7 +230,7 @@
- divide and return the 32 bit quotient
- -------------------------------------------------*/
-
--#ifndef __x86_64__
-+#if !defined(__amd64__) && !defined(__x86_64__)
- #define divu_64x32 _divu_64x32
- INLINE UINT32 ATTR_CONST ATTR_FORCE_INLINE
- _divu_64x32(UINT64 a, UINT32 b)
-@@ -258,7 +258,7 @@
- 32 bit remainder
- -------------------------------------------------*/
-
--#ifndef __x86_64__
-+#if !defined(__amd64__) && !defined(__x86_64__)
- #define div_64x32_rem _div_64x32_rem
- INLINE INT32 ATTR_FORCE_INLINE
- _div_64x32_rem(INT64 dividend, INT32 divisor, INT32 *remainder)
-@@ -286,7 +286,7 @@
- and 32 bit remainder
- -------------------------------------------------*/
-
--#ifndef __x86_64__
-+#if !defined(__amd64__) && !defined(__x86_64__)
- #define divu_64x32_rem _divu_64x32_rem
- INLINE UINT32 ATTR_FORCE_INLINE
- _divu_64x32_rem(UINT64 dividend, UINT32 divisor, UINT32 *remainder)
-@@ -337,7 +337,7 @@
- division, and returning the 32 bit quotient
- -------------------------------------------------*/
-
--#ifndef __x86_64__
-+#if !defined(__amd64__) && !defined(__x86_64__)
- #define div_32x32_shift _div_32x32_shift
- INLINE INT32 ATTR_CONST ATTR_FORCE_INLINE
- _div_32x32_shift(INT32 a, INT32 b, UINT8 shift)
-@@ -369,7 +369,7 @@
- division, and returning the 32 bit quotient
- -------------------------------------------------*/
-
--#ifndef __x86_64__
-+#if !defined(__amd64__) && !defined(__x86_64__)
- #define divu_32x32_shift _divu_32x32_shift
- INLINE UINT32 ATTR_CONST ATTR_FORCE_INLINE
- _divu_32x32_shift(UINT32 a, UINT32 b, UINT8 shift)
-@@ -400,7 +400,7 @@
- divide and return the 32 bit remainder
- -------------------------------------------------*/
-
--#ifndef __x86_64__
-+#if !defined(__amd64__) && !defined(__x86_64__)
- #define mod_64x32 _mod_64x32
- INLINE INT32 ATTR_CONST ATTR_FORCE_INLINE
- _mod_64x32(INT64 a, INT32 b)
-@@ -427,7 +427,7 @@
- divide and return the 32 bit remainder
- -------------------------------------------------*/
-
--#ifndef __x86_64__
-+#if !defined(__amd64__) && !defined(__x86_64__)
- #define modu_64x32 _modu_64x32
- INLINE UINT32 ATTR_CONST ATTR_FORCE_INLINE
- _modu_64x32(UINT64 a, UINT32 b)
-@@ -563,7 +563,7 @@
- return the previous value at 'ptr'.
- -------------------------------------------------*/
-
--#ifdef __x86_64__
-+#if defined(__amd64__) || defined(__x86_64__)
- #define compare_exchange64 _compare_exchange64
- INLINE INT64 ATTR_NONNULL(1) ATTR_FORCE_INLINE
- _compare_exchange64(INT64 volatile *ptr, INT64 compare, INT64 exchange)
-@@ -693,7 +693,7 @@
-
- #define get_profile_ticks _get_profile_ticks
-
--#ifndef __x86_64__
-+#if !defined(__amd64__) && !defined(__x86_64__)
- INLINE UINT64 ATTR_UNUSED ATTR_FORCE_INLINE _get_profile_ticks(void)
- {
- UINT64 result;
diff --git a/emulators/mess/files/patch-src__osd__eminline.h b/emulators/mess/files/patch-src__osd__eminline.h
deleted file mode 100644
index a631047e8346..000000000000
--- a/emulators/mess/files/patch-src__osd__eminline.h
+++ /dev/null
@@ -1,11 +0,0 @@
---- src/osd/eminline.h.orig
-+++ src/osd/eminline.h
-@@ -17,7 +17,7 @@
- /* we come with implementations for GCC x86 and PPC */
- #if defined(__GNUC__)
-
--#if defined(__i386__) || defined(__x86_64__)
-+#if defined(__i386__) || defined(__amd64__) || defined(__x86_64__)
- #include "eigccx86.h"
- #elif defined(__ppc__) || defined (__PPC__) || defined(__ppc64__) || defined(__PPC64__)
- #include "eigccppc.h"
diff --git a/emulators/mess/files/patch-src__osd__sdl__osinline.h b/emulators/mess/files/patch-src__osd__sdl__osinline.h
deleted file mode 100644
index 5fe71516d32d..000000000000
--- a/emulators/mess/files/patch-src__osd__sdl__osinline.h
+++ /dev/null
@@ -1,11 +0,0 @@
---- src/osd/sdl/osinline.h.orig
-+++ src/osd/sdl/osinline.h
-@@ -14,7 +14,7 @@
- // INLINE FUNCTIONS
- //============================================================
-
--#if defined(__i386__) || defined(__x86_64__)
-+#if defined(__i386__) || defined(__amd64__) || defined(__x86_64__)
-
-
- INLINE void ATTR_FORCE_INLINE
diff --git a/emulators/mess/files/patch-src__osd__sdl__sdlsync_ntc.c b/emulators/mess/files/patch-src__osd__sdl__sdlsync_ntc.c
deleted file mode 100644
index a0b3a330bdc1..000000000000
--- a/emulators/mess/files/patch-src__osd__sdl__sdlsync_ntc.c
+++ /dev/null
@@ -1,29 +0,0 @@
---- src/osd/sdl/sdlsync_ntc.c.orig
-+++ src/osd/sdl/sdlsync_ntc.c
-@@ -102,7 +102,7 @@
- {
- INT32 myslot = (atomic_increment32(&lock->nextindex) - 1) & (WORK_MAX_THREADS - 1);
-
--#if defined(__i386__) || defined(__x86_64__)
-+#if defined(__i386__) || defined(__amd64__) || defined(__x86_64__)
- register INT32 tmp;
- __asm__ __volatile__ (
- "1: clr %[tmp] ;"
-@@ -157,7 +157,7 @@
-
- void osd_scalable_lock_release(osd_scalable_lock *lock, INT32 myslot)
- {
--#if defined(__i386__) || defined(__x86_64__)
-+#if defined(__i386__) || defined(__amd64__) || defined(__x86_64__)
- register INT32 tmp = TRUE;
- __asm__ __volatile__ (
- " xchg %[haslock], %[tmp] ;"
-@@ -230,7 +230,7 @@
- do {
- register INT32 spin = 10000; // Convenient spin count
- register pthread_t tmp;
--#if defined(__i386__) || defined(__x86_64__)
-+#if defined(__i386__) || defined(__amd64__) || defined(__x86_64__)
- __asm__ __volatile__ (
- "1: pause ;"
- " mov %[holder], %[tmp] ;"
diff --git a/emulators/mess/files/patch-src__osd__sdl__sdlsync_os2.c b/emulators/mess/files/patch-src__osd__sdl__sdlsync_os2.c
deleted file mode 100644
index 14096ed98976..000000000000
--- a/emulators/mess/files/patch-src__osd__sdl__sdlsync_os2.c
+++ /dev/null
@@ -1,29 +0,0 @@
---- src/osd/sdl/sdlsync_os2.c.orig
-+++ src/osd/sdl/sdlsync_os2.c
-@@ -91,7 +91,7 @@
- {
- INT32 myslot = (atomic_increment32(&lock->nextindex) - 1) & (WORK_MAX_THREADS - 1);
-
--#if defined(__i386__) || defined(__x86_64__)
-+#if defined(__i386__) || defined(__amd64__) || defined(__x86_64__)
- register INT32 tmp;
- __asm__ __volatile__ (
- "1: clr %[tmp] ;"
-@@ -146,7 +146,7 @@
-
- void osd_scalable_lock_release(osd_scalable_lock *lock, INT32 myslot)
- {
--#if defined(__i386__) || defined(__x86_64__)
-+#if defined(__i386__) || defined(__amd64__) || defined(__x86_64__)
- register INT32 tmp = TRUE;
- __asm__ __volatile__ (
- " xchg %[haslock], %[tmp] ;"
-@@ -219,7 +219,7 @@
- do {
- register INT32 spin = 10000; // Convenient spin count
- register pthread_t tmp;
--#if defined(__i386__) || defined(__x86_64__)
-+#if defined(__i386__) || defined(__amd64__) || defined(__x86_64__)
- __asm__ __volatile__ (
- "1: pause ;"
- " mov %[holder], %[tmp] ;"
diff --git a/emulators/mess/files/pkg-message.in b/emulators/mess/files/pkg-message.in
deleted file mode 100644
index 13aa0794deb3..000000000000
--- a/emulators/mess/files/pkg-message.in
+++ /dev/null
@@ -1,14 +0,0 @@
-==============================================================================
-
-MESS has been installed.
-
-A example configuration file has been installed in
-"%%EXAMPLESDIR%%/mess.ini"
-Should you create a "~/.mess" directory and place it here or
-launch "mess -createconfig" and place the mess.ini created instead.
-
-If you have a non-qwerty keyboard, you should put in your mess.ini :
-keymap 1
-keymap_file %%DATADIR%%/keymaps/km-XX.txt
-
-==============================================================================
diff --git a/emulators/mess/pkg-plist b/emulators/mess/pkg-plist
index e2eb36ef0bc2..b4adab959e90 100644
--- a/emulators/mess/pkg-plist
+++ b/emulators/mess/pkg-plist
@@ -1,4 +1,4 @@
-bin/mess
+bin/%%EMULATOR%%
libexec/mess/castool
libexec/mess/chdman
libexec/mess/imgtool
@@ -8,19 +8,6 @@ libexec/mess/ldverify
libexec/mess/romcmp
libexec/mess/testkeys
libexec/mess/unidasm
-%%PORTDOCS%%%%DOCSDIR%%/docs/SDL.txt
-%%PORTDOCS%%%%DOCSDIR%%/docs/config.txt
-%%PORTDOCS%%%%DOCSDIR%%/docs/floppy.txt
-%%PORTDOCS%%%%DOCSDIR%%/docs/hlsl.txt
-%%PORTDOCS%%%%DOCSDIR%%/docs/imgtool.txt
-%%PORTDOCS%%%%DOCSDIR%%/docs/license.txt
-%%PORTDOCS%%%%DOCSDIR%%/docs/licenseinfo.txt
-%%PORTDOCS%%%%DOCSDIR%%/docs/m6502.txt
-%%PORTDOCS%%%%DOCSDIR%%/docs/mame.txt
-%%PORTDOCS%%%%DOCSDIR%%/docs/newvideo.txt
-%%PORTDOCS%%%%DOCSDIR%%/docs/nscsi.txt
-%%PORTDOCS%%%%DOCSDIR%%/docs/windows.txt
-%%PORTEXAMPLES%%%%EXAMPLESDIR%%/mess.ini
%%DATADIR%%/artwork/aperture.png
%%DATADIR%%/artwork/white.png
%%DATADIR%%/hash/32x.xml
@@ -33,38 +20,44 @@ libexec/mess/unidasm
%%DATADIR%%/hash/a800.xml
%%DATADIR%%/hash/a800_flop.xml
%%DATADIR%%/hash/abc1600.xml
-%%DATADIR%%/hash/abc80.xml
%%DATADIR%%/hash/abc800.xml
%%DATADIR%%/hash/abc800_hdd.xml
%%DATADIR%%/hash/abc806.xml
+%%DATADIR%%/hash/abc80_cass.xml
+%%DATADIR%%/hash/abc80_flop.xml
%%DATADIR%%/hash/adam_cart.xml
%%DATADIR%%/hash/adam_cass.xml
%%DATADIR%%/hash/adam_flop.xml
%%DATADIR%%/hash/advantage.xml
%%DATADIR%%/hash/advision.xml
%%DATADIR%%/hash/aim65_cart.xml
+%%DATADIR%%/hash/aleste.xml
%%DATADIR%%/hash/alice32.xml
%%DATADIR%%/hash/alice90.xml
%%DATADIR%%/hash/alphatro_flop.xml
-%%DATADIR%%/hash/amiga1000_flop.xml
-%%DATADIR%%/hash/amiga1200_flop.xml
-%%DATADIR%%/hash/amiga3000_flop.xml
-%%DATADIR%%/hash/amiga500_flop.xml
-%%DATADIR%%/hash/amiga500plus_flop.xml
-%%DATADIR%%/hash/amiga600_flop.xml
+%%DATADIR%%/hash/altos5.xml
+%%DATADIR%%/hash/amiga_a1000.xml
+%%DATADIR%%/hash/amiga_a3000.xml
+%%DATADIR%%/hash/amiga_apps.xml
%%DATADIR%%/hash/amiga_flop.xml
+%%DATADIR%%/hash/amiga_hardware.xml
+%%DATADIR%%/hash/amiga_workbench.xml
%%DATADIR%%/hash/amigaaga_flop.xml
%%DATADIR%%/hash/amigaecs_flop.xml
%%DATADIR%%/hash/amigaocs_flop.xml
%%DATADIR%%/hash/ampro.xml
%%DATADIR%%/hash/apc.xml
+%%DATADIR%%/hash/apfimag_cass.xml
%%DATADIR%%/hash/apfm1000.xml
%%DATADIR%%/hash/apogee.xml
+%%DATADIR%%/hash/apollo_ctape.xml
%%DATADIR%%/hash/apple1.xml
%%DATADIR%%/hash/apple2.xml
%%DATADIR%%/hash/apple2gs.xml
+%%DATADIR%%/hash/apple3.xml
%%DATADIR%%/hash/aquarius.xml
%%DATADIR%%/hash/arcadia.xml
+%%DATADIR%%/hash/archimedes.xml
%%DATADIR%%/hash/astrocde.xml
%%DATADIR%%/hash/atom.xml
%%DATADIR%%/hash/attache.xml
@@ -94,6 +87,8 @@ libexec/mess/unidasm
%%DATADIR%%/hash/cd32.xml
%%DATADIR%%/hash/cdi.xml
%%DATADIR%%/hash/cdtv.xml
+%%DATADIR%%/hash/cgenie_cart.xml
+%%DATADIR%%/hash/cgenie_cass.xml
%%DATADIR%%/hash/channelf.xml
%%DATADIR%%/hash/coco_cart.xml
%%DATADIR%%/hash/coco_flop.xml
@@ -105,7 +100,11 @@ libexec/mess/unidasm
%%DATADIR%%/hash/cpc_cass.xml
%%DATADIR%%/hash/cpc_flop.xml
%%DATADIR%%/hash/crvision.xml
+%%DATADIR%%/hash/cx3000tc.xml
+%%DATADIR%%/hash/dai_cass.xml
+%%DATADIR%%/hash/database.xml
%%DATADIR%%/hash/dim68k.xml
+%%DATADIR%%/hash/dmv.xml
%%DATADIR%%/hash/dps1.xml
%%DATADIR%%/hash/ec1841.xml
%%DATADIR%%/hash/einstein.xml
@@ -113,20 +112,27 @@ libexec/mess/unidasm
%%DATADIR%%/hash/ep64_cart.xml
%%DATADIR%%/hash/ep64_cass.xml
%%DATADIR%%/hash/ep64_flop.xml
+%%DATADIR%%/hash/epson_cpm.xml
+%%DATADIR%%/hash/exl100.xml
%%DATADIR%%/hash/famicom_cass.xml
%%DATADIR%%/hash/famicom_flop.xml
%%DATADIR%%/hash/fm77av.xml
%%DATADIR%%/hash/fm7_cass.xml
%%DATADIR%%/hash/fm7_disk.xml
+%%DATADIR%%/hash/fmtowns_cd.xml
%%DATADIR%%/hash/g7400.xml
%%DATADIR%%/hash/galaxy.xml
+%%DATADIR%%/hash/gamate.xml
%%DATADIR%%/hash/gameboy.xml
%%DATADIR%%/hash/gamecom.xml
%%DATADIR%%/hash/gamegear.xml
+%%DATADIR%%/hash/gameking.xml
%%DATADIR%%/hash/gamepock.xml
%%DATADIR%%/hash/gba.xml
%%DATADIR%%/hash/gbcolor.xml
%%DATADIR%%/hash/genius.xml
+%%DATADIR%%/hash/gimix.xml
+%%DATADIR%%/hash/gjmovie.xml
%%DATADIR%%/hash/gl2000.xml
%%DATADIR%%/hash/gl6000sl.xml
%%DATADIR%%/hash/glcolor.xml
@@ -137,7 +143,7 @@ libexec/mess/unidasm
%%DATADIR%%/hash/hp9835a_rom.xml
%%DATADIR%%/hash/hp9845a_rom.xml
%%DATADIR%%/hash/hp9845b_rom.xml
-%%DATADIR%%/hash/hx20_flop.xml
+%%DATADIR%%/hash/ht68k.xml
%%DATADIR%%/hash/ibm5140.xml
%%DATADIR%%/hash/ibm5150.xml
%%DATADIR%%/hash/ibm5150_cass.xml
@@ -155,21 +161,27 @@ libexec/mess/unidasm
%%DATADIR%%/hash/iq151_flop.xml
%%DATADIR%%/hash/jaguar.xml
%%DATADIR%%/hash/juicebox.xml
+%%DATADIR%%/hash/jupace_cass.xml
%%DATADIR%%/hash/kayproii.xml
%%DATADIR%%/hash/kc_cart.xml
%%DATADIR%%/hash/kc_cass.xml
%%DATADIR%%/hash/kc_flop.xml
%%DATADIR%%/hash/korvet_flop.xml
+%%DATADIR%%/hash/lantutor.xml
+%%DATADIR%%/hash/leapster.xml
%%DATADIR%%/hash/lisa.xml
%%DATADIR%%/hash/lisa2.xml
%%DATADIR%%/hash/lviv.xml
%%DATADIR%%/hash/lynx.xml
%%DATADIR%%/hash/m20.xml
-%%DATADIR%%/hash/m5.xml
+%%DATADIR%%/hash/m5_cart.xml
+%%DATADIR%%/hash/m5_cass.xml
%%DATADIR%%/hash/mac_flop.xml
%%DATADIR%%/hash/mac_hdd.xml
%%DATADIR%%/hash/mbc200.xml
%%DATADIR%%/hash/mbc55x.xml
+%%DATADIR%%/hash/mc10.xml
+%%DATADIR%%/hash/mc1000_cass.xml
%%DATADIR%%/hash/mc1502_flop.xml
%%DATADIR%%/hash/megacd.xml
%%DATADIR%%/hash/megacdj.xml
@@ -178,10 +190,13 @@ libexec/mess/unidasm
%%DATADIR%%/hash/megapc.xml
%%DATADIR%%/hash/megatech.xml
%%DATADIR%%/hash/microvision.xml
-%%DATADIR%%/hash/mikrosha.xml
+%%DATADIR%%/hash/mikro80.xml
+%%DATADIR%%/hash/mikrosha_cart.xml
+%%DATADIR%%/hash/mikrosha_cass.xml
%%DATADIR%%/hash/misterx.xml
%%DATADIR%%/hash/mm1_flop.xml
%%DATADIR%%/hash/mo5_cart.xml
+%%DATADIR%%/hash/mpu1000.xml
%%DATADIR%%/hash/mpz80.xml
%%DATADIR%%/hash/msx.hsi
%%DATADIR%%/hash/msx1_cart.xml
@@ -189,7 +204,11 @@ libexec/mess/unidasm
%%DATADIR%%/hash/msx1_flop.xml
%%DATADIR%%/hash/msx2.hsi
%%DATADIR%%/hash/msx2_cart.xml
+%%DATADIR%%/hash/msx2_cass.xml
%%DATADIR%%/hash/msx2_flop.xml
+%%DATADIR%%/hash/msx2p_flop.xml
+%%DATADIR%%/hash/msxr_flop.xml
+%%DATADIR%%/hash/mtx_cass.xml
%%DATADIR%%/hash/myvision.xml
%%DATADIR%%/hash/mz2000_cass.xml
%%DATADIR%%/hash/mz2000_flop.xml
@@ -236,6 +255,8 @@ libexec/mess/unidasm
%%DATADIR%%/hash/pcw.xml
%%DATADIR%%/hash/pcw16.xml
%%DATADIR%%/hash/pecom_cass.xml
+%%DATADIR%%/hash/pegasus_cart.xml
+%%DATADIR%%/hash/pencil2.xml
%%DATADIR%%/hash/pentagon_cass.xml
%%DATADIR%%/hash/pet_cass.xml
%%DATADIR%%/hash/pet_flop.xml
@@ -247,11 +268,14 @@ libexec/mess/unidasm
%%DATADIR%%/hash/plus4_cart.xml
%%DATADIR%%/hash/plus4_cass.xml
%%DATADIR%%/hash/plus4_flop.xml
+%%DATADIR%%/hash/pmd85_cass.xml
%%DATADIR%%/hash/pokemini.xml
%%DATADIR%%/hash/prof180.xml
%%DATADIR%%/hash/prof80.xml
-%%DATADIR%%/hash/psion.xml
+%%DATADIR%%/hash/psion1.xml
+%%DATADIR%%/hash/psion2.xml
%%DATADIR%%/hash/psx.xml
+%%DATADIR%%/hash/pt68k2.xml
%%DATADIR%%/hash/pv1000.xml
%%DATADIR%%/hash/pv2000.xml
%%DATADIR%%/hash/px4_cart.xml
@@ -260,8 +284,10 @@ libexec/mess/unidasm
%%DATADIR%%/hash/ql_cass.xml
%%DATADIR%%/hash/ql_flop.xml
%%DATADIR%%/hash/qx10_flop.xml
-%%DATADIR%%/hash/radio86.xml
+%%DATADIR%%/hash/radio86_cart.xml
+%%DATADIR%%/hash/radio86_cass.xml
%%DATADIR%%/hash/rainbow.xml
+%%DATADIR%%/hash/rwtrntcs.xml
%%DATADIR%%/hash/rx78.xml
%%DATADIR%%/hash/sage2.xml
%%DATADIR%%/hash/samcoupe_cass.xml
@@ -282,17 +308,21 @@ libexec/mess/unidasm
%%DATADIR%%/hash/snes_bspack.xml
%%DATADIR%%/hash/snes_strom.xml
%%DATADIR%%/hash/snes_vkun.xml
+%%DATADIR%%/hash/snread.xml
+%%DATADIR%%/hash/snspell.xml
%%DATADIR%%/hash/socrates.xml
%%DATADIR%%/hash/softbox.xml
%%DATADIR%%/hash/softwarelist.dtd
+%%DATADIR%%/hash/sol20_cass.xml
%%DATADIR%%/hash/sorcerer_cart.xml
%%DATADIR%%/hash/sorcerer_cass.xml
%%DATADIR%%/hash/sorcerer_flop.xml
+%%DATADIR%%/hash/spc1000_cass.xml
%%DATADIR%%/hash/special_cass.xml
%%DATADIR%%/hash/special_flop.xml
-%%DATADIR%%/hash/spectrum.xml
+%%DATADIR%%/hash/specpls3_flop.xml
+%%DATADIR%%/hash/spectrum_cart.xml
%%DATADIR%%/hash/spectrum_cass.xml
-%%DATADIR%%/hash/spectrum_flop.xml
%%DATADIR%%/hash/st_cart.xml
%%DATADIR%%/hash/st_flop.xml
%%DATADIR%%/hash/studio2.xml
@@ -312,20 +342,25 @@ libexec/mess/unidasm
%%DATADIR%%/hash/tdv2324.xml
%%DATADIR%%/hash/tek4052_cart.xml
%%DATADIR%%/hash/tg16.xml
+%%DATADIR%%/hash/ti74_cart.xml
%%DATADIR%%/hash/ti99_cart.xml
%%DATADIR%%/hash/tiki100.xml
+%%DATADIR%%/hash/timex_dock.xml
%%DATADIR%%/hash/to770_cart.xml
%%DATADIR%%/hash/to7_cart.xml
%%DATADIR%%/hash/trs80m2.xml
%%DATADIR%%/hash/trsm100.xml
%%DATADIR%%/hash/tutor.xml
%%DATADIR%%/hash/tvc_cart.xml
+%%DATADIR%%/hash/tvc_cass.xml
+%%DATADIR%%/hash/tvc_flop.xml
%%DATADIR%%/hash/ut88.xml
%%DATADIR%%/hash/uzebox.xml
%%DATADIR%%/hash/v1050_flop.xml
%%DATADIR%%/hash/v1050_hdd.xml
%%DATADIR%%/hash/vboy.xml
%%DATADIR%%/hash/vc4000.xml
+%%DATADIR%%/hash/vector06_cart.xml
%%DATADIR%%/hash/vectrex.xml
%%DATADIR%%/hash/vg5k.xml
%%DATADIR%%/hash/vic10.xml
@@ -338,14 +373,17 @@ libexec/mess/unidasm
%%DATADIR%%/hash/vip.xml
%%DATADIR%%/hash/visicom.xml
%%DATADIR%%/hash/vixen.xml
+%%DATADIR%%/hash/vreader.xml
%%DATADIR%%/hash/vsmile_cart.xml
%%DATADIR%%/hash/vsmile_cd.xml
+%%DATADIR%%/hash/vz_cass.xml
%%DATADIR%%/hash/wangpc.xml
%%DATADIR%%/hash/wicat.xml
%%DATADIR%%/hash/wmbullet.xml
%%DATADIR%%/hash/wscolor.xml
%%DATADIR%%/hash/wswan.xml
%%DATADIR%%/hash/x07_card.xml
+%%DATADIR%%/hash/x07_cass.xml
%%DATADIR%%/hash/x1_cass.xml
%%DATADIR%%/hash/x1_flop.xml
%%DATADIR%%/hash/x68k_flop.xml