aboutsummaryrefslogtreecommitdiff
path: root/emulators/mess
diff options
context:
space:
mode:
authorMartin Wilke <miwi@FreeBSD.org>2009-11-26 14:26:46 +0000
committerMartin Wilke <miwi@FreeBSD.org>2009-11-26 14:26:46 +0000
commitff37b2696f4b3942eeac2d28ab9c5f733621e495 (patch)
tree8a1d6c03e0a80b7103c2a944559422f9835ef07c /emulators/mess
parent6ba09caeee74253b4a5a1b9a62babffc4f0e5bd4 (diff)
downloadports-ff37b2696f4b3942eeac2d28ab9c5f733621e495.tar.gz
ports-ff37b2696f4b3942eeac2d28ab9c5f733621e495.zip
Notes
Diffstat (limited to 'emulators/mess')
-rw-r--r--emulators/mess/Makefile7
-rw-r--r--emulators/mess/distinfo6
-rw-r--r--emulators/mess/files/patch-makefile.sdl17
-rw-r--r--emulators/mess/files/sdl.mak.patch15
-rw-r--r--emulators/mess/pkg-plist7
5 files changed, 27 insertions, 25 deletions
diff --git a/emulators/mess/Makefile b/emulators/mess/Makefile
index a965c74e6bbd..d06a031c1a29 100644
--- a/emulators/mess/Makefile
+++ b/emulators/mess/Makefile
@@ -6,7 +6,7 @@
#
PORTNAME= sdlmess
-PORTVERSION= 0.133
+PORTVERSION= 0.135
CATEGORIES= emulators
MASTER_SITES= http://rbelmont.mameworld.info/ \
ftp://ftp.arcadebsd.org/pub/ArcadeBSD/ports/distfiles/
@@ -52,11 +52,12 @@ do-install:
${INSTALL_PROGRAM} ${WRKSRC}/${PORTNAME} ${PREFIX}/bin/
${MKDIR} ${PREFIX}/libexec/sdlmess
${INSTALL_PROGRAM} ${WRKSRC}/chdman ${PREFIX}/libexec/sdlmess
+ ${INSTALL_PROGRAM} ${WRKSRC}/imgtool ${PREFIX}/libexec/sdlmess
+ ${INSTALL_PROGRAM} ${WRKSRC}/jedutil ${PREFIX}/libexec/sdlmess
${INSTALL_PROGRAM} ${WRKSRC}/ldresample ${PREFIX}/libexec/sdlmess
${INSTALL_PROGRAM} ${WRKSRC}/ldverify ${PREFIX}/libexec/sdlmess
${INSTALL_PROGRAM} ${WRKSRC}/testkeys ${PREFIX}/libexec/sdlmess
- ${INSTALL_PROGRAM} ${WRKSRC}/imgtool ${PREFIX}/libexec/sdlmess
- ${INSTALL_PROGRAM} ${WRKSRC}/jedutil ${PREFIX}/libexec/sdlmess
+ ${INSTALL_PROGRAM} ${WRKSRC}/unidasm ${PREFIX}/libexec/sdlmess
.if !defined(NOPORTDOCS)
${MKDIR} ${DOCSDIR}
${INSTALL_DATA} ${WRKSRC}/*.txt ${DOCSDIR}
diff --git a/emulators/mess/distinfo b/emulators/mess/distinfo
index 737a4d692659..8414c1eec24e 100644
--- a/emulators/mess/distinfo
+++ b/emulators/mess/distinfo
@@ -1,3 +1,3 @@
-MD5 (sdlmess0133.zip) = bd847771a11343d2efb75335b973d646
-SHA256 (sdlmess0133.zip) = db1d7e6c6cc3520e26f53b7bc5429773d9e6fe7d8ef57126486a56999281315e
-SIZE (sdlmess0133.zip) = 32501988
+MD5 (sdlmess0135.zip) = 1c46e71e4d268d5afdca1b57aba1096e
+SHA256 (sdlmess0135.zip) = c8415b6ce9b142124f2e1392d55b75d8ad96774e7f4fc231effbd8d33e45205d
+SIZE (sdlmess0135.zip) = 33723886
diff --git a/emulators/mess/files/patch-makefile.sdl b/emulators/mess/files/patch-makefile.sdl
index 1f44c8bb6885..cc14870893d9 100644
--- a/emulators/mess/files/patch-makefile.sdl
+++ b/emulators/mess/files/patch-makefile.sdl
@@ -1,5 +1,5 @@
---- makefile.sdl.orig 2009-07-23 03:54:02.000000000 +0200
-+++ makefile.sdl 2009-07-23 03:55:21.000000000 +0200
+--- makefile.sdl.orig 2009-09-17 02:49:53.000000000 +0200
++++ makefile.sdl 2009-11-24 07:25:56.000000000 +0100
@@ -59,7 +59,7 @@
ifeq ($(OSD),windows)
TARGETOS = win32
@@ -29,25 +29,24 @@
# add an EXE suffix to get the final emulator name
EMULATOR = $(FULLNAME)$(EXE)
-@@ -337,7 +337,7 @@
- # and make all errors into warnings
+@@ -338,7 +338,7 @@
ifneq ($(OPTIMIZE),0)
ifneq ($(TARGETOS),os2)
+ ifndef IA64
-CCOMFLAGS += -Werror -fno-strict-aliasing $(ARCHOPTS)
+CCOMFLAGS += -fno-strict-aliasing $(ARCHOPTS)
else
- CCOMFLAGS += -fno-strict-aliasing $(ARCHOPTS)
endif
-@@ -379,7 +379,7 @@
+ else
+@@ -382,6 +382,7 @@
-I$(SRC)/lib/util \
-I$(SRC)/osd \
-I$(SRC)/osd/$(OSD) \
--
+ -I$(LOCALBASE)/include \
- #-------------------------------------------------
-@@ -392,7 +392,7 @@
+
+@@ -395,7 +396,7 @@
ifneq ($(TARGETOS),macosx)
ifneq ($(TARGETOS),os2)
ifneq ($(TARGETOS),solaris)
diff --git a/emulators/mess/files/sdl.mak.patch b/emulators/mess/files/sdl.mak.patch
index 63a6f480c890..9623fe59ac74 100644
--- a/emulators/mess/files/sdl.mak.patch
+++ b/emulators/mess/files/sdl.mak.patch
@@ -1,15 +1,14 @@
---- src/osd/sdl/sdl.mak.orig 2009-03-19 14:09:23.000000000 +0100
-+++ src/osd/sdl/sdl.mak 2009-03-25 05:32:18.000000000 +0100
-@@ -127,7 +127,7 @@
+--- src/osd/sdl/sdl.mak.orig 2009-11-13 11:09:21.000000000 +0100
++++ src/osd/sdl/sdl.mak 2009-11-13 11:10:24.000000000 +0100
+@@ -140,6 +140,7 @@
+ endif
ifeq ($(TARGETOS),freebsd)
++DEFS += -DNO_DEBUGGER
TARGETOS = unix
--DEFS += -DNO_THREAD_COOPERATIVE
-+DEFS += -DNO_THREAD_COOPERATIVE -DNO_DEBUGGER
+ SYNC_IMPLEMENTATION = ntc
endif
-
- ifeq ($(TARGETOS),openbsd)
-@@ -269,10 +269,10 @@
+@@ -288,10 +289,10 @@
# the new debugger relies on GTK+ in addition to the base SDLMAME needs
# Non-X11 builds can not use the debugger
ifndef NO_X11
diff --git a/emulators/mess/pkg-plist b/emulators/mess/pkg-plist
index 3b4d56bc54d9..f5ee855b3d31 100644
--- a/emulators/mess/pkg-plist
+++ b/emulators/mess/pkg-plist
@@ -1,10 +1,11 @@
bin/sdlmess
libexec/sdlmess/chdman
+libexec/sdlmess/imgtool
+libexec/sdlmess/jedutil
libexec/sdlmess/ldresample
libexec/sdlmess/ldverify
libexec/sdlmess/testkeys
-libexec/sdlmess/imgtool
-libexec/sdlmess/jedutil
+libexec/sdlmess/unidasm
%%PORTDOCS%%%%DOCSDIR%%/SDLMESS.txt
%%PORTDOCS%%%%DOCSDIR%%/whatsnew.txt
%%PORTDOCS%%%%DOCSDIR%%/docs/config.txt
@@ -54,6 +55,7 @@ libexec/sdlmess/jedutil
%%PORTDOCS%%%%DOCSDIR%%/docs/windows/images/propvec.gif
%%PORTDOCS%%%%DOCSDIR%%/docs/windows/images/startup.gif
%%PORTDOCS%%%%DOCSDIR%%/docs/windows/images/tree.gif
+%%DATADIR%%/artwork/4004clk.zip
%%DATADIR%%/artwork/aim65.zip
%%DATADIR%%/artwork/amsterd.zip
%%DATADIR%%/artwork/avigo.zip
@@ -69,6 +71,7 @@ libexec/sdlmess/jedutil
%%DATADIR%%/artwork/hp48gx.zip
%%DATADIR%%/artwork/hp48s.zip
%%DATADIR%%/artwork/hp48sx.zip
+%%DATADIR%%/artwork/junior.zip
%%DATADIR%%/artwork/kim1.zip
%%DATADIR%%/artwork/ledoff.png
%%DATADIR%%/artwork/ledon.png