aboutsummaryrefslogtreecommitdiff
path: root/emulators/mgba/Makefile
diff options
context:
space:
mode:
authorTobias Kortkamp <tobik@FreeBSD.org>2017-10-05 16:35:17 +0000
committerTobias Kortkamp <tobik@FreeBSD.org>2017-10-05 16:35:17 +0000
commitbbbbee48dd5d0b60433f6daaef068ac8ed0b2f2f (patch)
tree5b4530e9537f15c184efa63e90e30b34d5309837 /emulators/mgba/Makefile
parent76ba57b76541db104898d927f005e096037f0bb2 (diff)
downloadports-bbbbee48dd5d0b60433f6daaef068ac8ed0b2f2f.tar.gz
ports-bbbbee48dd5d0b60433f6daaef068ac8ed0b2f2f.zip
Notes
Diffstat (limited to 'emulators/mgba/Makefile')
-rw-r--r--emulators/mgba/Makefile65
1 files changed, 65 insertions, 0 deletions
diff --git a/emulators/mgba/Makefile b/emulators/mgba/Makefile
new file mode 100644
index 000000000000..6c554441816f
--- /dev/null
+++ b/emulators/mgba/Makefile
@@ -0,0 +1,65 @@
+# $FreeBSD$
+
+PORTNAME= mgba
+DISTVERSION= 0.6.1
+CATEGORIES= emulators
+
+MAINTAINER= greg@unrelenting.technology
+COMMENT= Game Boy Advance (GBA) emulator/debugger
+
+LICENSE= MPL20 BSD3CLAUSE LGPL21+
+LICENSE_COMB= multi
+LICENSE_FILE_BSD3CLAUSE= ${WRKSRC}/src/third-party/inih/LICENSE.txt
+LICENSE_FILE_LGPL21+= ${WRKSRC}/src/third-party/blip_buf/license.txt
+LICENSE_FILE_MPL20= ${WRKSRC}/LICENSE
+
+LIB_DEPENDS= libepoxy.so:graphics/libepoxy \
+ libpng16.so:graphics/png
+
+USES= cmake:outsource compiler:c++11-lang localbase:ldflags pkgconfig sqlite:3
+
+USE_GITHUB= yes
+GH_ACCOUNT= mgba-emu
+
+USE_GL= gl glu
+USE_SDL= sdl2
+
+CMAKE_ARGS= -DCMAKE_INSTALL_DOCDIR:STRING="${DOCSDIR}" \
+ -DUSE_MINIZIP:BOOL=OFF \
+ -DUSE_LIBZIP:BOOL=OFF \
+ -DUSE_ZLIB:BOOL=ON \
+ -DUSE_LZMA:BOOL=ON \
+ -DUSE_SQLITE3:BOOL=ON \
+ -DBUILD_GL:BOOL=ON \
+ -DBUILD_GLES2:BOOL=OFF
+LDFLAGS+= -Wl,--as-needed # glu
+
+OPTIONS_DEFINE= DEBUGGERS FFMPEG MAGICK QT5
+OPTIONS_DEFAULT= DEBUGGERS FFMPEG MAGICK QT5
+OPTIONS_SUB= yes
+
+DEBUGGERS_DESC= Debugging infrastructure (CLI debugger, GDB remote stub)
+FFMPEG_DESC= FFmpeg video recording support
+MAGICK_DESC= ImageMagick GIF recording support
+QT5_DESC= Qt 5 frontend
+
+DEBUGGERS_CMAKE_BOOL= USE_DEBUGGERS USE_EDITLINE USE_GDB_STUB
+DEBUGGERS_USES= libedit
+
+FFMPEG_CMAKE_BOOL= USE_FFMPEG
+FFMPEG_LIB_DEPENDS= libavcodec.so:multimedia/ffmpeg \
+ libavformat.so:multimedia/ffmpeg \
+ libavresample.so:multimedia/ffmpeg \
+ libavutil.so:multimedia/ffmpeg \
+ libswscale.so:multimedia/ffmpeg
+
+MAGICK_CMAKE_BOOL= USE_MAGICK
+MAGICK_LIB_DEPENDS= libMagickWand-6.so:graphics/ImageMagick \
+ libMagickCore-6.so:graphics/ImageMagick
+
+QT5_CMAKE_BOOL= BUILD_QT
+QT5_USE= qt5=qmake_build,buildtools_build,core,gui,widgets,network,opengl,multimedia
+QT5_USES= desktop-file-utils
+QT5_VARS= installs_icons=yes
+
+.include <bsd.port.mk>