aboutsummaryrefslogtreecommitdiff
path: root/emulators/mupen64-input
diff options
context:
space:
mode:
authorDirk Meyer <dinoex@FreeBSD.org>2004-10-12 05:02:20 +0000
committerDirk Meyer <dinoex@FreeBSD.org>2004-10-12 05:02:20 +0000
commite77eb1a8bd2969918921bc54e7df55133366d458 (patch)
treeeea38ed52b5cf8d8086ee94068ae1e3a9ae520a5 /emulators/mupen64-input
parent5ae1e528e0fb84ebdd8c5d4544b4035edfddd6dc (diff)
downloadports-e77eb1a8bd2969918921bc54e7df55133366d458.tar.gz
ports-e77eb1a8bd2969918921bc54e7df55133366d458.zip
Notes
Diffstat (limited to 'emulators/mupen64-input')
-rw-r--r--emulators/mupen64-input/Makefile57
-rw-r--r--emulators/mupen64-input/distinfo2
-rw-r--r--emulators/mupen64-input/files/patch-Makefile11
-rw-r--r--emulators/mupen64-input/pkg-descr15
-rw-r--r--emulators/mupen64-input/pkg-message9
5 files changed, 94 insertions, 0 deletions
diff --git a/emulators/mupen64-input/Makefile b/emulators/mupen64-input/Makefile
new file mode 100644
index 000000000000..021f3b19a0b2
--- /dev/null
+++ b/emulators/mupen64-input/Makefile
@@ -0,0 +1,57 @@
+# New ports collection makefile for: mupen64-input
+# Date created: 11.Aug 2004
+# Whom: dirk.meyer@dinoex.sub.org
+#
+# $FreeBSD$
+#
+
+PORTNAME= mupen64
+PORTVERSION= 0.4
+CATEGORIES+= emulators
+MASTER_SITES= http://mupen64.emulation64.com/files/${PORTVERSION}/
+PKGNAMESUFFIX= -input
+DISTNAME= mupen64_input
+
+MAINTAINER?= tlp@LiquidX.org
+COMMENT= Input plugin for Mupen64
+
+USE_BZIP2= yes
+USE_REINPLACE= yes
+USE_GMAKE= yes
+USE_SDL= sdl
+USE_GNOME= gtk12
+USE_GCC= 3.4
+ONLY_FOR_ARCHS= i386
+
+PLUGIN_NAME= mupen64_input
+PLIST_FILES= share/mupen64/plugins/${PLUGIN_NAME}.so
+PLIST_DIRS= share/mupen64/plugins
+PLIST_DIRS+= share/mupen64
+
+FIXME2= main.c
+
+do-configure:
+.for i in ${FIXME2}
+ ${REINPLACE_CMD} -e 's|SDL/SDL.h|SDL.h|' ${WRKSRC}/${i}
+.endfor
+ ${REINPLACE_CMD} -e 's|-lSDL|`${SDL_CONFIG} --libs`|' \
+ ${WRKSRC}/Makefile
+
+do-install:
+ @${MKDIR} ${PREFIX}/share/mupen64/plugins
+ ${INSTALL_SCRIPT} ${WRKSRC}/${PLUGIN_NAME}.so \
+ ${PREFIX}/share/mupen64/plugins/
+
+.include <bsd.port.pre.mk>
+
+CFLAGS+= `${SDL_CONFIG} --cflags`
+CFLAGS+= -DUSE_GTK `${GTK_CONFIG} --cflags` -fPIC
+CFLAGS+= -O3 -fomit-frame-pointer -funroll-loops -ffast-math -Wall -pipe
+CFLAGS+= -DX86 -mcpu=athlon
+
+MAKE_ARGS+= CFLAGS="${CFLAGS}" LDFLAGS="${LDFLAGS}"
+
+post-install:
+ @${CAT} ${PKGMESSAGE}
+
+.include <bsd.port.post.mk>
diff --git a/emulators/mupen64-input/distinfo b/emulators/mupen64-input/distinfo
new file mode 100644
index 000000000000..2cb46056c564
--- /dev/null
+++ b/emulators/mupen64-input/distinfo
@@ -0,0 +1,2 @@
+MD5 (mupen64_input.tar.bz2) = 14fc6075a19bb567afebedd5ab2ea6c1
+SIZE (mupen64_input.tar.bz2) = 4438
diff --git a/emulators/mupen64-input/files/patch-Makefile b/emulators/mupen64-input/files/patch-Makefile
new file mode 100644
index 000000000000..215e1a9da134
--- /dev/null
+++ b/emulators/mupen64-input/files/patch-Makefile
@@ -0,0 +1,11 @@
+--- Makefile.orig Sat Sep 6 00:55:57 2003
++++ Makefile Thu Aug 12 14:35:59 2004
+@@ -2,7 +2,7 @@
+ #CXX =g++ -O3 -mpentium -Wall -DEMU64_DEBUG
+ #CC =gcc -O3 -I/usr/X11R6/include -fPIC -fomit-frame-pointer -funroll-loops -ffast-math -mcpu=pentium -pipe
+ #CC =gcc -O3 -mpentium -Wall -g -pg
+-CC =gcc -O3 -fomit-frame-pointer -funroll-loops -ffast-math -mcpu=athlon -Wall -DUSE_GTK `gtk-config --cflags` -I/usr/X11R6/include -pipe
++#CC =gcc -O3 -fomit-frame-pointer -funroll-loops -ffast-math -mcpu=athlon -Wall -DUSE_GTK `gtk-config --cflags` -I/usr/X11R6/include -pipe
+
+ OBJ =main.o
+
diff --git a/emulators/mupen64-input/pkg-descr b/emulators/mupen64-input/pkg-descr
new file mode 100644
index 000000000000..223bed971b72
--- /dev/null
+++ b/emulators/mupen64-input/pkg-descr
@@ -0,0 +1,15 @@
+Input plugin for Mupen64
+-
+Mupen64 is a highly portable Nintendo 64 emulator. It has been developed
+on/for Linux originally but has already been ported successfully to other
+operating systems. The program can easily be ported to all operating systems
+supported by the SDL library.
+
+In its current state, the emulator is highly compatible and uses a plugin
+system. With the correct plugins ("correct" can be computer dependent), it
+can achieve nearly perfect graphics and sound in many games.
+
+WWW: http://mupen64.emulation64.com/
+
+- Travis Poppe
+tlp@liquidx.org
diff --git a/emulators/mupen64-input/pkg-message b/emulators/mupen64-input/pkg-message
new file mode 100644
index 000000000000..d53470396a22
--- /dev/null
+++ b/emulators/mupen64-input/pkg-message
@@ -0,0 +1,9 @@
+-------------------------------------------------------------------------------
+If you have installed/upgraded any new plugins or are upgrading from a previous
+version of Mupen64, please note that in order for these changes to take effect,
+you -must- backup and then remove ~/.mupen64 first. After you have removed the
+directory, run 'mupen64' to re-create it. Then, manually copy back your save
+files/other data you need from the backup if necessary.
+
+Enjoy!
+-------------------------------------------------------------------------------