aboutsummaryrefslogtreecommitdiff
path: root/emulators/mupen64-rsp/Makefile
diff options
context:
space:
mode:
authorDirk Meyer <dinoex@FreeBSD.org>2004-10-12 05:04:27 +0000
committerDirk Meyer <dinoex@FreeBSD.org>2004-10-12 05:04:27 +0000
commitc080ea4c276170a2d9870ab70e9a2bfd792a3d3c (patch)
tree7a7fa73d210bbb697441e8a7ca467fafeedb886e /emulators/mupen64-rsp/Makefile
parentedee770d1d7f642af2be9af8b40a12f71b5e5a37 (diff)
downloadports-c080ea4c276170a2d9870ab70e9a2bfd792a3d3c.tar.gz
ports-c080ea4c276170a2d9870ab70e9a2bfd792a3d3c.zip
Notes
Diffstat (limited to 'emulators/mupen64-rsp/Makefile')
-rw-r--r--emulators/mupen64-rsp/Makefile46
1 files changed, 46 insertions, 0 deletions
diff --git a/emulators/mupen64-rsp/Makefile b/emulators/mupen64-rsp/Makefile
new file mode 100644
index 000000000000..84e0f61959f3
--- /dev/null
+++ b/emulators/mupen64-rsp/Makefile
@@ -0,0 +1,46 @@
+# New ports collection makefile for: mupen64-rsp
+# Date created: 10.Aug 2004
+# Whom: dirk.meyer@dinoex.sub.org
+#
+# $FreeBSD$
+#
+
+PORTNAME= mupen64
+PORTVERSION= 0.4
+CATEGORIES+= emulators
+MASTER_SITES= http://mupen64.emulation64.com/files/${PORTVERSION}/
+PKGNAMESUFFIX= -rsp
+DISTNAME= hack_azi_rsp_hle
+
+MAINTAINER?= tlp@LiquidX.org
+COMMENT= RSP plugin for Mupen64
+
+USE_BZIP2= yes
+USE_GMAKE= yes
+USE_GNOME= gtk12
+USE_GCC= 3.4
+ONLY_FOR_ARCHS= i386
+
+PLUGIN_NAME= mupen64_hle_rsp_azimer
+PLIST_FILES= share/mupen64/plugins/${PLUGIN_NAME}.so
+PLIST_DIRS= share/mupen64/plugins
+PLIST_DIRS+= share/mupen64
+
+do-install:
+ @${MKDIR} ${PREFIX}/share/mupen64/plugins
+ ${INSTALL_SCRIPT} ${WRKSRC}/${PLUGIN_NAME}.so \
+ ${PREFIX}/share/mupen64/plugins/
+
+.include <bsd.port.pre.mk>
+
+CFLAGS+= -DUSE_GTK `${GTK_CONFIG} --cflags` -fPIC
+CFLAGS+= -O3 -fomit-frame-pointer -funroll-loops -ffast-math -Wall -pipe
+CFLAGS+= -DX86 -mcpu=athlon
+LDFLAGS+= -lc
+
+MAKE_ARGS+= CFLAGS="${CFLAGS}" LDFLAGS="${LDFLAGS}" LD="${CXX}"
+
+post-install:
+ @${CAT} ${PKGMESSAGE}
+
+.include <bsd.port.post.mk>