aboutsummaryrefslogtreecommitdiff
path: root/emulators/mupen64
diff options
context:
space:
mode:
authorDirk Meyer <dinoex@FreeBSD.org>2004-10-12 05:08:52 +0000
committerDirk Meyer <dinoex@FreeBSD.org>2004-10-12 05:08:52 +0000
commite7db579139fb4b26705d5c51b45ef434ddd0440c (patch)
treece43d2adfc8559c7075ec747dcd0aad0dc37c7f3 /emulators/mupen64
parent8b6b4b9ed1e09e5edda3139ac894ee22aaea0f3e (diff)
downloadports-e7db579139fb4b26705d5c51b45ef434ddd0440c.tar.gz
ports-e7db579139fb4b26705d5c51b45ef434ddd0440c.zip
Notes
Diffstat (limited to 'emulators/mupen64')
-rw-r--r--emulators/mupen64/Makefile39
-rw-r--r--emulators/mupen64/pkg-descr13
-rw-r--r--emulators/mupen64/pkg-message9
3 files changed, 61 insertions, 0 deletions
diff --git a/emulators/mupen64/Makefile b/emulators/mupen64/Makefile
new file mode 100644
index 000000000000..68bbc22cca98
--- /dev/null
+++ b/emulators/mupen64/Makefile
@@ -0,0 +1,39 @@
+# New ports collection makefile for: mupen64
+# Date created: 17.Sep 2004
+# Whom: dirk.meyer@dinoex.sub.org
+#
+# $FreeBSD$
+#
+
+PORTNAME= mupen64
+PORTVERSION= 0.4
+CATEGORIES+= emulators
+MASTER_SITES= # empty
+DISTFILES= # empty
+EXTRACT_ONLY= # empty
+
+MAINTAINER?= tlp@LiquidX.org
+COMMENT= Mupen64 is a Nintendo 64 emulator with plugins
+
+RUN_DEPENDS+= ${LOCALBASE}/bin/mupen64:${PORTSDIR}/${PKGCATEGORY}/mupen64-base
+RUN_DEPENDS+= ${PLUGINDIR}/dummyaudio.so:${PORTSDIR}/${PKGCATEGORY}/mupen64-dummyaudio
+RUN_DEPENDS+= ${PLUGINDIR}/mupen64_audio.so:${PORTSDIR}/${PKGCATEGORY}/mupen64-sound
+RUN_DEPENDS+= ${PLUGINDIR}/jttl_audio.so:${PORTSDIR}/${PKGCATEGORY}/mupen64-sdlaudio
+RUN_DEPENDS+= ${PLUGINDIR}/mupen64_input.so:${PORTSDIR}/${PKGCATEGORY}/mupen64-input
+RUN_DEPENDS+= ${PLUGINDIR}/blight_input.so:${PORTSDIR}/${PKGCATEGORY}/mupen64-sdlinput
+RUN_DEPENDS+= ${PLUGINDIR}/ricedaedalus.so:${PORTSDIR}/${PKGCATEGORY}/mupen64-rice
+RUN_DEPENDS+= ${PLUGINDIR}/mupen64_hle_rsp_azimer.so:${PORTSDIR}/${PKGCATEGORY}/mupen64-rsp
+RUN_DEPENDS+= ${PLUGINDIR}/Glide64.so:${PORTSDIR}/${PKGCATEGORY}/mupen64-glide
+RUN_DEPENDS+= ${PLUGINDIR}/glN64-0.4.1.so:${PORTSDIR}/${PKGCATEGORY}/mupen64-gln64
+
+NO_MTREE= yes
+NO_BUILD= yes
+
+do-install: # empty
+
+PLUGINDIR= ${LOCALBASE}/share/mupen64/plugins
+
+post-install:
+ @${CAT} ${PKGMESSAGE}
+
+.include <bsd.port.mk>
diff --git a/emulators/mupen64/pkg-descr b/emulators/mupen64/pkg-descr
new file mode 100644
index 000000000000..648185b5638a
--- /dev/null
+++ b/emulators/mupen64/pkg-descr
@@ -0,0 +1,13 @@
+Mupen64 is a highly portable Nintendo 64 emulator. It has been developed
+on/for Linux originally but has already been ported successfully to other
+operating systems. The program can easily be ported to all operating systems
+supported by the SDL library.
+
+In its current state, the emulator is highly compatible and uses a plugin
+system. With the correct plugins ("correct" can be computer dependent), it
+can achieve nearly perfect graphics and sound in many games.
+
+WWW: http://mupen64.emulation64.com/
+
+- Travis Poppe
+tlp@liquidx.org
diff --git a/emulators/mupen64/pkg-message b/emulators/mupen64/pkg-message
new file mode 100644
index 000000000000..d53470396a22
--- /dev/null
+++ b/emulators/mupen64/pkg-message
@@ -0,0 +1,9 @@
+-------------------------------------------------------------------------------
+If you have installed/upgraded any new plugins or are upgrading from a previous
+version of Mupen64, please note that in order for these changes to take effect,
+you -must- backup and then remove ~/.mupen64 first. After you have removed the
+directory, run 'mupen64' to re-create it. Then, manually copy back your save
+files/other data you need from the backup if necessary.
+
+Enjoy!
+-------------------------------------------------------------------------------