aboutsummaryrefslogtreecommitdiff
path: root/emulators/mupen64plus-core
diff options
context:
space:
mode:
authorJose Alonso Cardenas Marquez <acm@FreeBSD.org>2010-12-17 05:47:55 +0000
committerJose Alonso Cardenas Marquez <acm@FreeBSD.org>2010-12-17 05:47:55 +0000
commitbf98a86fddba1ead0ea4b3f2562684ed813fe7a2 (patch)
treedbe53423f553fe90c3727a0c61197824ae787894 /emulators/mupen64plus-core
parent5f71d29bc526ec6748761685fcdda576372b6e61 (diff)
downloadports-bf98a86fddba1ead0ea4b3f2562684ed813fe7a2.tar.gz
ports-bf98a86fddba1ead0ea4b3f2562684ed813fe7a2.zip
Notes
Diffstat (limited to 'emulators/mupen64plus-core')
-rw-r--r--emulators/mupen64plus-core/Makefile4
-rw-r--r--emulators/mupen64plus-core/Makefile.common6
2 files changed, 5 insertions, 5 deletions
diff --git a/emulators/mupen64plus-core/Makefile b/emulators/mupen64plus-core/Makefile
index 166ef65997bd..31274c2259a9 100644
--- a/emulators/mupen64plus-core/Makefile
+++ b/emulators/mupen64plus-core/Makefile
@@ -7,7 +7,7 @@
PORTNAME= mupen64plus
PORTVERSION?= 1.99.4
-PORTREVISION?= 0
+PORTREVISION?= 1
CATEGORIES= emulators
MASTER_SITES= ${MASTER_SITE_GOOGLE_CODE}
PKGNAMESUFFIX?= -core
@@ -17,7 +17,7 @@ MAINTAINER?= acm@FreeBSD.org
COMMENT?= A fork of Mupen64 Nintendo 64 emulator
USE_GL?= yes
-USE_SDL?= #
+USE_SDL?= yes
USE_GMAKE= yes
USE_LDCONFIG?= yes
ONLY_FOR_ARCHS= i386 amd64
diff --git a/emulators/mupen64plus-core/Makefile.common b/emulators/mupen64plus-core/Makefile.common
index 232a816eaf60..36ad55645a42 100644
--- a/emulators/mupen64plus-core/Makefile.common
+++ b/emulators/mupen64plus-core/Makefile.common
@@ -9,8 +9,6 @@ EXTRACT_AFTER_ARGS= | ${TAR} -xf - "${DISTNAME}/source/${PORTNAME}-core/*" \
"${DISTNAME}/source/${PORTNAME}${PKGNAMESUFFIX}/*"
.if ${PKGNAMESUFFIX} == "-core"
-USE_SDL= sdl
-
LIB_DEPENDS+= freetype.9:${PORTSDIR}/print/freetype2 \
png.6:${PORTSDIR}/graphics/png
.else
@@ -42,7 +40,8 @@ pre-install:
. endif
. if ${PKGNAMESUFFIX} != "-ui-console"
- @${ECHO_CMD} "lib/${PORTNAME}${PKGNAMESUFFIX}.so" >> ${PLIST}
+ @${ECHO_CMD} "lib/${PORTNAME}/${PORTNAME}${PKGNAMESUFFIX}.so" >> ${PLIST}
+ @${ECHO_CMD} "@dirrmtry lib/${PORTNAME}" >> ${PLIST}
@${ECHO_CMD} "@dirrmtry %%DATADIR%%" >> ${PLIST}
. else
@${ECHO_CMD} "bin/${PORTNAME}" >> ${PLIST}
@@ -84,6 +83,7 @@ do-install:
. endif
. if ${PKGNAMESUFFIX} != "-ui-console"
+ @${MKDIR} ${PREFIX}/lib/${PORTNAME}
${INSTALL_PROGRAM} ${BUILD_WRKSRC}/${PORTNAME}${PKGNAMESUFFIX}.so ${PREFIX}/lib
. else
${INSTALL_PROGRAM} ${BUILD_WRKSRC}/${PORTNAME} ${PREFIX}/bin