aboutsummaryrefslogtreecommitdiff
path: root/emulators/mupen64plus-core
diff options
context:
space:
mode:
authorJose Alonso Cardenas Marquez <acm@FreeBSD.org>2011-12-18 02:54:41 +0000
committerJose Alonso Cardenas Marquez <acm@FreeBSD.org>2011-12-18 02:54:41 +0000
commit3a04e009c1bb7e6a661fdea457b38c0b69a00cfa (patch)
tree8b67f1b8cd04af785edd82786f958385bed85c18 /emulators/mupen64plus-core
parent34cb5d2ac775d0aac379f160015d8266fc77d152 (diff)
downloadports-3a04e009c1bb7e6a661fdea457b38c0b69a00cfa.tar.gz
ports-3a04e009c1bb7e6a661fdea457b38c0b69a00cfa.zip
Notes
Diffstat (limited to 'emulators/mupen64plus-core')
-rw-r--r--emulators/mupen64plus-core/Makefile6
-rw-r--r--emulators/mupen64plus-core/distinfo4
-rw-r--r--emulators/mupen64plus-core/files/patch-source_mupen64plus-core_projects_unix_Makefile30
-rw-r--r--emulators/mupen64plus-core/files/patch-source_mupen64plus-core_src_main_zip_ioapi.h15
4 files changed, 51 insertions, 4 deletions
diff --git a/emulators/mupen64plus-core/Makefile b/emulators/mupen64plus-core/Makefile
index 31274c2259a9..3c4dcb8a7cbe 100644
--- a/emulators/mupen64plus-core/Makefile
+++ b/emulators/mupen64plus-core/Makefile
@@ -7,15 +7,17 @@
PORTNAME= mupen64plus
PORTVERSION?= 1.99.4
-PORTREVISION?= 1
+PORTREVISION?= 2
CATEGORIES= emulators
-MASTER_SITES= ${MASTER_SITE_GOOGLE_CODE}
+MASTER_SITES= ${MASTER_SITE_GOOGLE_CODE} \
+ ${MASTER_SITE_LOCAL:S,$,acm/${PORTNAME}/,}
PKGNAMESUFFIX?= -core
DIST_SUBDIR= ${PORTNAME}
MAINTAINER?= acm@FreeBSD.org
COMMENT?= A fork of Mupen64 Nintendo 64 emulator
+PROJECTHOST= bsdistfiles
USE_GL?= yes
USE_SDL?= yes
USE_GMAKE= yes
diff --git a/emulators/mupen64plus-core/distinfo b/emulators/mupen64plus-core/distinfo
index 2098c76d7eaf..943dc7475ce8 100644
--- a/emulators/mupen64plus-core/distinfo
+++ b/emulators/mupen64plus-core/distinfo
@@ -1,2 +1,2 @@
-SHA256 (mupen64plus/mupen64plus-bundle-src-1.99.4.tar.gz) = 28868b299372a7b6a1628ee7340656748ed6316fd210d52b82f27518cec7ab8e
-SIZE (mupen64plus/mupen64plus-bundle-src-1.99.4.tar.gz) = 1703878
+SHA256 (mupen64plus/mupen64plus-bundle-src-1.99.4.tar.gz) = 07f69ccefdf7224cb29a39c0525daa87807b44846ca14fcad97728d6a22f4da2
+SIZE (mupen64plus/mupen64plus-bundle-src-1.99.4.tar.gz) = 1699177
diff --git a/emulators/mupen64plus-core/files/patch-source_mupen64plus-core_projects_unix_Makefile b/emulators/mupen64plus-core/files/patch-source_mupen64plus-core_projects_unix_Makefile
new file mode 100644
index 000000000000..f6ef06d6942e
--- /dev/null
+++ b/emulators/mupen64plus-core/files/patch-source_mupen64plus-core_projects_unix_Makefile
@@ -0,0 +1,30 @@
+--- source/mupen64plus-core/projects/unix/Makefile 2011-12-17 20:37:23.000000000 -0500
++++ source/mupen64plus-core/projects/unix/Makefile 2011-12-17 20:39:06.000000000 -0500
+@@ -170,8 +170,10 @@
+ ifeq ($(shell pkg-config --modversion libpng 2>/dev/null),)
+ $(error No libpng development libraries found!)
+ endif
+-ifeq ($(shell pkg-config --modversion zlib 2>/dev/null),)
+- $(error No zlib development libraries found!)
++ifneq ($(OS), FREEBSD)
++ ifeq ($(shell pkg-config --modversion zlib 2>/dev/null),)
++ $(error No zlib development libraries found!)
++ endif
+ endif
+ ifeq ($(shell pkg-config --modversion freetype2 2>/dev/null),)
+ $(error No FreeType 2 development libraries found!)
+@@ -182,8 +184,14 @@
+ ifeq ($(shell pkg-config --modversion glu 2>/dev/null),)
+ $(error No OpenGL utility development libraries found!)
+ endif
++
++ifeq ($(OS), FREEBSD)
++CFLAGS += $(shell pkg-config --cflags libpng freetype2 gl glu)
++LDLIBS += $(shell pkg-config --libs libpng freetype2 gl glu)
++else
+ CFLAGS += $(shell pkg-config --cflags libpng zlib freetype2 gl glu)
+ LDLIBS += $(shell pkg-config --libs libpng zlib freetype2 gl glu)
++endif
+
+ # test for presence of SDL
+ ifeq ($(shell which sdl-config 2>/dev/null),)
diff --git a/emulators/mupen64plus-core/files/patch-source_mupen64plus-core_src_main_zip_ioapi.h b/emulators/mupen64plus-core/files/patch-source_mupen64plus-core_src_main_zip_ioapi.h
new file mode 100644
index 000000000000..801d20e1a864
--- /dev/null
+++ b/emulators/mupen64plus-core/files/patch-source_mupen64plus-core_src_main_zip_ioapi.h
@@ -0,0 +1,15 @@
+--- source/mupen64plus-core/src/main/zip/ioapi.h 2011-12-17 21:07:15.000000000 -0500
++++ source/mupen64plus-core/src/main/zip/ioapi.h 2011-12-17 21:08:43.000000000 -0500
+@@ -61,6 +61,12 @@
+ #endif
+ #endif
+
++#if defined(__FreeBSD__)
++#define fopen64 fopen
++#define ftello64 ftello
++#define fseeko64 fseeko
++#endif
++
+ /*
+ #ifndef ZPOS64_T
+ #ifdef _WIN32