aboutsummaryrefslogtreecommitdiff
path: root/emulators/mupen64plus-glide
diff options
context:
space:
mode:
authorJose Alonso Cardenas Marquez <acm@FreeBSD.org>2009-01-06 21:54:58 +0000
committerJose Alonso Cardenas Marquez <acm@FreeBSD.org>2009-01-06 21:54:58 +0000
commitd4df837ed4f11b5a53b294eb67dd400026171029 (patch)
tree2181388c388719941b8d4ab905454dc3a6b6691b /emulators/mupen64plus-glide
parent7b665df4506770414852a7be71fdab6b6edb0484 (diff)
downloadports-d4df837ed4f11b5a53b294eb67dd400026171029.tar.gz
ports-d4df837ed4f11b5a53b294eb67dd400026171029.zip
Notes
Diffstat (limited to 'emulators/mupen64plus-glide')
-rw-r--r--emulators/mupen64plus-glide/files/patch-glide64_Makefile38
1 files changed, 22 insertions, 16 deletions
diff --git a/emulators/mupen64plus-glide/files/patch-glide64_Makefile b/emulators/mupen64plus-glide/files/patch-glide64_Makefile
index e73d1e8526c7..6937a95debca 100644
--- a/emulators/mupen64plus-glide/files/patch-glide64_Makefile
+++ b/emulators/mupen64plus-glide/files/patch-glide64_Makefile
@@ -1,5 +1,5 @@
---- glide64/Makefile 2008-03-29 14:41:03.000000000 -0500
-+++ glide64/Makefile 2008-05-20 11:01:10.000000000 -0500
+--- glide64/Makefile 2008-10-13 21:31:47.000000000 -0500
++++ glide64/Makefile 2008-12-15 01:10:56.000000000 -0500
@@ -4,7 +4,7 @@
include ../pre.mk
@@ -9,15 +9,14 @@
BITS=64
MOPT=-m amd64
else
-@@ -13,15 +13,16 @@
+@@ -13,15 +13,15 @@
endif
# local CFLAGS, LIBS, and LDFLAGS
--CFLAGS = -O2 -Wall -g -DGCC -DUSE_GTK $(SDL_CFLAGS) $(GTK_FLAGS) -Iwrapper/ -ffast-math -funroll-loops
+-CFLAGS = -O3 -Wall -g -DGCC -DUSE_GTK $(SDL_CFLAGS) $(GTK_FLAGS) -Iwrapper/ -ffast-math -funroll-loops
-LDFLAGS = -shared -Wl,-Bsymbolic -lGL -lGLU -L/usr/X11R6/lib $(SDL_LIBS)
+CFLAGS += -DGCC -DUSE_GTK $(SDL_CFLAGS) $(GTK_FLAGS) -Iwrapper/ -ffast-math -funroll-loops
+LDFLAGS += -shared -Wl,-Bsymbolic -lGL -lGLU -L${LOCALBASE}/lib $(SDL_LIBS)
-+LD = $(CXX)
# set special flags per-system
ifeq ($(CPU), X86)
@@ -27,11 +26,11 @@
+ CFLAGS += -fPIC
else
- CFLAGS += -march=i686 -mtune=pentium-m -mmmx -msse
-+ CFLAGS +=
++ CFLAGS += -mmmx -msse
ifneq ($(PROFILE), 1)
ifneq ($(VPDEBUG), 1)
CFLAGS += -fomit-frame-pointer
-@@ -29,9 +30,9 @@
+@@ -29,9 +29,9 @@
endif
endif
# tweak flags for 32-bit build on 64-bit system
@@ -44,14 +43,21 @@
endif
endif
ifeq ($(CPU), PPC)
-@@ -129,9 +130,7 @@
- cursor.h: compiletex
- ./compiletex cursor.tex cursor.h cursor
+@@ -122,7 +122,7 @@
+ all: $(TARGET)
+
+ $(TARGET): $(OBJECTS)
+- $(LD) $(OBJECTS) $(GTK_LIBS) $(LDFLAGS) -o $@
++ $(CC) $(OBJECTS) $(LDFLAGS) $(GTK_LIBS) -o $@
+ $(STRIP) --strip-all $@
+
+ Main.o: font.h cursor.h
+@@ -135,7 +135,7 @@
+ compiletex: compiletex.c
+ @rm -f compiletex compiletex.o
+ $(CC) -o compiletex.o -c $<
+- $(LD) -o $@ compiletex.o
++ $(CC) -o $@ compiletex.o
--compiletex: compiletex.c
-- @rm -f compiletex compiletex.o
-- $(CC) -o compiletex.o -c $<
-+compiletex: compiletex.o
- $(LD) -o $@ compiletex.o
+ rdp.o: ucode06.h
- Tmem_nasm.o: Tmem_nasm.asm