aboutsummaryrefslogtreecommitdiff
path: root/emulators/mupen64plus-video-rice
diff options
context:
space:
mode:
authorJose Alonso Cardenas Marquez <acm@FreeBSD.org>2008-05-20 18:56:21 +0000
committerJose Alonso Cardenas Marquez <acm@FreeBSD.org>2008-05-20 18:56:21 +0000
commit3575d1bccfbac6a78f640f73906d586fbf42ccc8 (patch)
tree41214b60a137419e32804ae6b356b8b112d65489 /emulators/mupen64plus-video-rice
parentdc2933db2b1b20667602dd8bd46a3ad8afd849c6 (diff)
downloadports-3575d1bccfbac6a78f640f73906d586fbf42ccc8.tar.gz
ports-3575d1bccfbac6a78f640f73906d586fbf42ccc8.zip
Notes
Diffstat (limited to 'emulators/mupen64plus-video-rice')
-rw-r--r--emulators/mupen64plus-video-rice/Makefile25
-rw-r--r--emulators/mupen64plus-video-rice/files/patch-rice_video_Makefile22
2 files changed, 47 insertions, 0 deletions
diff --git a/emulators/mupen64plus-video-rice/Makefile b/emulators/mupen64plus-video-rice/Makefile
new file mode 100644
index 000000000000..8fee40047d36
--- /dev/null
+++ b/emulators/mupen64plus-video-rice/Makefile
@@ -0,0 +1,25 @@
+# New ports collection makefile for: mupen64plus-rice
+# Date created: 2008-05-16
+# Whom: Jose Alonso Cardenas Marquez <acm@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PKGNAMESUFFIX= -rice
+
+COMMENT= The rice graphics plugin for Mupen64plus
+
+USE_GL= yes
+USE_SDL= sdl
+
+#USE_GCC= 4.1+
+
+FIXFILES= rice_video/liblinux/BMGImage.c rice_video/liblinux/BMGUtils.c
+
+PLUGIN_NAME= ricevideo
+
+MASTERDIR= ${.CURDIR}/../mupen64plus-base
+
+OPTIONS= #
+
+.include "${MASTERDIR}/Makefile"
diff --git a/emulators/mupen64plus-video-rice/files/patch-rice_video_Makefile b/emulators/mupen64plus-video-rice/files/patch-rice_video_Makefile
new file mode 100644
index 000000000000..c637a3f04771
--- /dev/null
+++ b/emulators/mupen64plus-video-rice/files/patch-rice_video_Makefile
@@ -0,0 +1,22 @@
+--- rice_video/Makefile 2008-03-29 14:41:03.000000000 -0500
++++ rice_video/Makefile 2008-05-17 09:40:34.000000000 -0500
+@@ -4,8 +4,8 @@
+ include ../pre.mk
+
+ # local CFLAGS, LIBS, and LDFLAGS
+-CFLAGS += -DUSE_GTK `sdl-config --cflags` $(GTK_FLAGS) -fpic -DPIC
+-LDFLAGS += -L/usr/X11R6/lib `sdl-config --libs` -lGL -shared -Wl,-Bsymbolic
++CFLAGS += -DUSE_GTK $(SDL_FLAGS) $(GTK_FLAGS) -fpic -DPIC
++LDFLAGS += -L$(LOCALBASE)/lib $(SDL_LIBS) -lGL -shared -Wl,-Bsymbolic
+
+ # set options
+
+@@ -101,7 +101,7 @@
+ all: ricevideo.so
+
+ ricevideo.so: $(OBJECTS)
+- $(LD) $(OBJECTS) $(GTK_LIBS) $(LDFLAGS) -o $@
++ $(CXX) $(OBJECTS) $(GTK_LIBS) $(LDFLAGS) -o $@
+ $(STRIP) $@
+
+ clean: