aboutsummaryrefslogtreecommitdiff
path: root/emulators/mupen64plus-video-rice
diff options
context:
space:
mode:
authorJose Alonso Cardenas Marquez <acm@FreeBSD.org>2010-12-17 05:47:55 +0000
committerJose Alonso Cardenas Marquez <acm@FreeBSD.org>2010-12-17 05:47:55 +0000
commitbf98a86fddba1ead0ea4b3f2562684ed813fe7a2 (patch)
treedbe53423f553fe90c3727a0c61197824ae787894 /emulators/mupen64plus-video-rice
parent5f71d29bc526ec6748761685fcdda576372b6e61 (diff)
downloadports-bf98a86fddba1ead0ea4b3f2562684ed813fe7a2.tar.gz
ports-bf98a86fddba1ead0ea4b3f2562684ed813fe7a2.zip
- Fix build on i386
- Install plugins to ${LOCALBASE}/lib/mupen64plus directory. This is default directory used by emulator - Bump PORTREVISION Reported by: David Demelier <demelier.david@ at gmail.com>
Notes
Notes: svn path=/head/; revision=266480
Diffstat (limited to 'emulators/mupen64plus-video-rice')
-rw-r--r--emulators/mupen64plus-video-rice/Makefile2
-rw-r--r--emulators/mupen64plus-video-rice/files/patch-source_mupen64plus-video-rice_projects_unix_Makefile14
2 files changed, 16 insertions, 0 deletions
diff --git a/emulators/mupen64plus-video-rice/Makefile b/emulators/mupen64plus-video-rice/Makefile
index 30c3a277b005..5805644e3e01 100644
--- a/emulators/mupen64plus-video-rice/Makefile
+++ b/emulators/mupen64plus-video-rice/Makefile
@@ -5,6 +5,8 @@
# $FreeBSD$
#
+PORTREVISION= 1
+
PKGNAMESUFFIX= -video-rice
COMMENT= The rice graphics plugin for Mupen64plus
diff --git a/emulators/mupen64plus-video-rice/files/patch-source_mupen64plus-video-rice_projects_unix_Makefile b/emulators/mupen64plus-video-rice/files/patch-source_mupen64plus-video-rice_projects_unix_Makefile
new file mode 100644
index 000000000000..942bcf807051
--- /dev/null
+++ b/emulators/mupen64plus-video-rice/files/patch-source_mupen64plus-video-rice_projects_unix_Makefile
@@ -0,0 +1,14 @@
+--- source/mupen64plus-video-rice/projects/unix/Makefile 2010-12-17 00:32:33.000000000 -0500
++++ source/mupen64plus-video-rice/projects/unix/Makefile 2010-12-17 00:34:09.000000000 -0500
+@@ -111,6 +111,11 @@
+ ifeq ($(OS),FREEBSD)
+ LDFLAGS += -lGL $(shell pkg-config --libs libpng)
+ CFLAGS += $(shell pkg-config --cflags libpng)
++ ifeq ($(CPU), X86)
++ ifeq ($(ARCH_DETECTED), 32BITS)
++ CFLAGS += -pipe -mmmx -msse -fomit-frame-pointer
++ endif
++ endif
+ endif
+ ifeq ($(OS), LINUX)
+ LDFLAGS += -ldl -lGL