aboutsummaryrefslogtreecommitdiff
path: root/emulators/mupen64plus-video-z64
diff options
context:
space:
mode:
authorJose Alonso Cardenas Marquez <acm@FreeBSD.org>2011-12-20 23:51:31 +0000
committerJose Alonso Cardenas Marquez <acm@FreeBSD.org>2011-12-20 23:51:31 +0000
commite03a41e4f553d483d7ba644cdf7bf59e22fe1631 (patch)
treeb43110a213cd5363881d6a062c7bf319739a7384 /emulators/mupen64plus-video-z64
parent8db9e8462c31cd440023321041c5717be75175ec (diff)
downloadports-e03a41e4f553d483d7ba644cdf7bf59e22fe1631.tar.gz
ports-e03a41e4f553d483d7ba644cdf7bf59e22fe1631.zip
Notes
Diffstat (limited to 'emulators/mupen64plus-video-z64')
-rw-r--r--emulators/mupen64plus-video-z64/Makefile30
1 files changed, 30 insertions, 0 deletions
diff --git a/emulators/mupen64plus-video-z64/Makefile b/emulators/mupen64plus-video-z64/Makefile
new file mode 100644
index 000000000000..2a2523a5a2ea
--- /dev/null
+++ b/emulators/mupen64plus-video-z64/Makefile
@@ -0,0 +1,30 @@
+# New ports collection makefile for: mupen64plus-video-z64
+# Date created: 2011-12-20
+# Whom: Jose Alonso Cardenas Marquez <acm@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTREVISION= 0
+PKGNAMESUFFIX= -video-z64
+DISTFILES= ${PORTNAME}${PKGNAMESUFFIX}-src-${PORTVERSION}${EXTRACT_SUFX}:plugin
+
+COMMENT= Low-level RDP plugin for the Mupen64Plus
+
+LIB_DEPENDS= mupen64plus.2:${PORTSDIR}/emulators/mupen64plus-core
+
+USE_GL= gl glu glew
+USE_SDL= yes
+
+MASTERDIR= ${.CURDIR}/../mupen64plus-core
+
+OPTIONS= #
+
+CFLAGS+= -I${LOCALBASE}/include -I${LOCALBASE}/include/${PORTNAME}
+LDFLAGS+= -L${LOCALBASE}/lib
+
+EXTRACT_AFTER_ARGS= | ${TAR} -xf -
+BUILD_WRKSRC= ${WRKSRC}/${PORTNAME}${PKGNAMESUFFIX}/projects/unix
+WRKSRC= ${WRKDIR}
+
+.include "${MASTERDIR}/Makefile"