aboutsummaryrefslogtreecommitdiff
path: root/emulators/nestopia
diff options
context:
space:
mode:
authorVanilla I. Shu <vanilla@FreeBSD.org>2016-01-19 05:52:58 +0000
committerVanilla I. Shu <vanilla@FreeBSD.org>2016-01-19 05:52:58 +0000
commite020c956129a4cb935d6827efce708c7c06d2fe4 (patch)
tree938ee5ab1f39fba5bfc3d39dc00141057accec9c /emulators/nestopia
parente8435a00ce461be1495a4a3bf7259e23f1c6539f (diff)
downloadports-e020c956129a4cb935d6827efce708c7c06d2fe4.tar.gz
ports-e020c956129a4cb935d6827efce708c7c06d2fe4.zip
Notes
Diffstat (limited to 'emulators/nestopia')
-rw-r--r--emulators/nestopia/Makefile25
-rw-r--r--emulators/nestopia/distinfo2
-rw-r--r--emulators/nestopia/files/patch-Makefile29
-rw-r--r--emulators/nestopia/files/patch-source_unix_gtkui_gtkui.h10
-rw-r--r--emulators/nestopia/pkg-descr7
-rw-r--r--emulators/nestopia/pkg-plist12
6 files changed, 85 insertions, 0 deletions
diff --git a/emulators/nestopia/Makefile b/emulators/nestopia/Makefile
new file mode 100644
index 000000000000..71e30918343e
--- /dev/null
+++ b/emulators/nestopia/Makefile
@@ -0,0 +1,25 @@
+# $FreeBSD$
+
+PORTNAME= nestopia
+PORTVERSION= 1.47
+CATEGORIES= emulators
+
+MAINTAINER= neel@neelc.org
+COMMENT= Portable NES/Famicom emulator
+
+LICENSE= GPLv2
+
+LIB_DEPENDS= libao.so:${PORTSDIR}/audio/libao
+
+USES= gmake libarchive pkgconfig
+USE_GL= glu
+USE_GNOME= gtk30
+USE_SDL= sdl2
+
+USE_GITHUB= yes
+GH_ACCOUNT= rdanbrook
+
+post-install:
+ ${STRIP_CMD} ${STAGEDIR}${PREFIX}/bin/${PORTNAME}
+
+.include <bsd.port.mk>
diff --git a/emulators/nestopia/distinfo b/emulators/nestopia/distinfo
new file mode 100644
index 000000000000..e0a6c31ccc06
--- /dev/null
+++ b/emulators/nestopia/distinfo
@@ -0,0 +1,2 @@
+SHA256 (rdanbrook-nestopia-1.47_GH0.tar.gz) = 915db5aeeda5c9e800a96dac229766d82c0990a7ee165a30317a62bfabccf9b7
+SIZE (rdanbrook-nestopia-1.47_GH0.tar.gz) = 1271675
diff --git a/emulators/nestopia/files/patch-Makefile b/emulators/nestopia/files/patch-Makefile
new file mode 100644
index 000000000000..9e6874dc225a
--- /dev/null
+++ b/emulators/nestopia/files/patch-Makefile
@@ -0,0 +1,29 @@
+--- Makefile.orig 2016-01-15 15:25:05.060978417 -0500
++++ Makefile 2016-01-15 19:19:38.773106245 -0500
+@@ -395,16 +395,16 @@
+ $(CC) $(LDFLAGS) $^ $(LIBS) -o $(BIN)
+
+ install:
+- mkdir -p $(BINDIR)
+- mkdir -p $(DATADIR)/icons
+- mkdir -p $(PREFIX)/share/pixmaps
+- install -m 0755 $(BIN) $(BINDIR)
+- install -m 0644 source/unix/icons/nestopia.desktop $(DATADIR)
+- install -m 0644 NstDatabase.xml $(DATADIR)
+- install -m 0644 source/unix/icons/*.png $(DATADIR)/icons
+- install -m 0644 source/unix/icons/*.svg $(DATADIR)/icons
+- install -m 0644 source/unix/icons/nestopia.svg $(PREFIX)/share/pixmaps
+- xdg-desktop-menu install --novendor $(DATADIR)/nestopia.desktop
++ mkdir -p $(DESTDIR)$(BINDIR)
++ mkdir -p $(DESTDIR)$(DATADIR)/icons
++ mkdir -p $(DESTDIR)$(PREFIX)/share/pixmaps
++ install -m 0755 $(BIN) $(DESTDIR)$(BINDIR)
++ install -m 0644 source/unix/icons/nestopia.desktop $(DESTDIR)$(DATADIR)
++ install -m 0644 NstDatabase.xml $(DESTDIR)$(DATADIR)
++ install -m 0644 source/unix/icons/*.png $(DESTDIR)$(DATADIR)/icons
++ install -m 0644 source/unix/icons/*.svg $(DESTDIR)$(DATADIR)/icons
++ install -m 0644 source/unix/icons/nestopia.svg $(DESTDIR)$(PREFIX)/share/pixmaps
++ install -m 0644 source/unix/icons/nestopia.desktop $(DESTDIR)$(PREFIX)/share/applications/nestopia.desktop
+
+ uninstall:
+ xdg-desktop-menu uninstall $(DATADIR)/nestopia.desktop
diff --git a/emulators/nestopia/files/patch-source_unix_gtkui_gtkui.h b/emulators/nestopia/files/patch-source_unix_gtkui_gtkui.h
new file mode 100644
index 000000000000..886909deb20a
--- /dev/null
+++ b/emulators/nestopia/files/patch-source_unix_gtkui_gtkui.h
@@ -0,0 +1,10 @@
+--- ./source/unix/gtkui/gtkui.h.orig 2016-01-09 18:34:38 -0500
++++ ./source/unix/gtkui/gtkui.h 2016-01-15 11:34:58 -0500
+@@ -8,7 +8,6 @@
+ #elif _APPLE
+ #else
+ #include <gdk/gdkx.h>
+-#include <gdk/gdkwayland.h>
+ #endif
+
+ void gtkui_init(int argc, char *argv[]);
diff --git a/emulators/nestopia/pkg-descr b/emulators/nestopia/pkg-descr
new file mode 100644
index 000000000000..1909f00a4c65
--- /dev/null
+++ b/emulators/nestopia/pkg-descr
@@ -0,0 +1,7 @@
+Nestopia is a portable NES/Famicom emulator written in C++.
+
+Nestopia UE (Undead Edition) is a fork of the original source code, with
+enhancements from members of the emulation community. This includes
+support for new platforms, and bug fixes in the emulator core.
+
+WWW: http://0ldsk00l.ca/nestopia/
diff --git a/emulators/nestopia/pkg-plist b/emulators/nestopia/pkg-plist
new file mode 100644
index 000000000000..b9a6cd1bc3f2
--- /dev/null
+++ b/emulators/nestopia/pkg-plist
@@ -0,0 +1,12 @@
+bin/nestopia
+share/pixmaps/nestopia.svg
+share/applications/nestopia.desktop
+%%DATADIR%%/icons/nestopia.svg
+%%DATADIR%%/icons/nespad.svg
+%%DATADIR%%/icons/nestopia48.png
+%%DATADIR%%/icons/nestopia96.png
+%%DATADIR%%/icons/nestopia32.png
+%%DATADIR%%/icons/nestopia128.png
+%%DATADIR%%/icons/nestopia64.png
+%%DATADIR%%/NstDatabase.xml
+%%DATADIR%%/nestopia.desktop