aboutsummaryrefslogtreecommitdiff
path: root/emulators/open-vm-tools
diff options
context:
space:
mode:
authorMartin Blapp <mbr@FreeBSD.org>2009-04-14 07:32:46 +0000
committerMartin Blapp <mbr@FreeBSD.org>2009-04-14 07:32:46 +0000
commit7a31c1b3357eeb90a4f44da93ec0a3ca8105ffc8 (patch)
treeb811e19b11121c48ad0bd5dc04b4527fa6bbe466 /emulators/open-vm-tools
parente00b07c86f218ddee983dedf68cc3d9e308408f5 (diff)
downloadports-7a31c1b3357eeb90a4f44da93ec0a3ca8105ffc8.tar.gz
ports-7a31c1b3357eeb90a4f44da93ec0a3ca8105ffc8.zip
Notes
Diffstat (limited to 'emulators/open-vm-tools')
-rw-r--r--emulators/open-vm-tools/Makefile2
-rw-r--r--emulators/open-vm-tools/files/patch-util_misc.c20
2 files changed, 21 insertions, 1 deletions
diff --git a/emulators/open-vm-tools/Makefile b/emulators/open-vm-tools/Makefile
index a1618e17a42f..f30970b4c28d 100644
--- a/emulators/open-vm-tools/Makefile
+++ b/emulators/open-vm-tools/Makefile
@@ -7,7 +7,7 @@
PORTNAME= open-vm-tools
PORTVERSION= ${BUILD_VER}
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= emulators kld
MASTER_SITES= SF
DISTNAME= open-vm-tools-${RELEASE_DATE}-${BUILD_VER}
diff --git a/emulators/open-vm-tools/files/patch-util_misc.c b/emulators/open-vm-tools/files/patch-util_misc.c
new file mode 100644
index 000000000000..287b9451f94e
--- /dev/null
+++ b/emulators/open-vm-tools/files/patch-util_misc.c
@@ -0,0 +1,20 @@
+--- lib/misc/util_misc.c.orig 2009-04-14 02:38:09.000000000 +0200
++++ lib/misc/util_misc.c 2009-04-14 02:39:00.000000000 +0200
+@@ -289,7 +289,7 @@
+ return (strcmp(path1, path2) == 0);
+ #elif defined(_WIN32)
+ return (_stricmp(path1, path2) == 0);
+-#elif defined(__APPLE__)
++#elif defined(__APPLE__) || defined(__FreeBSD__)
+ return (strcasecmp(path1, path2) == 0);
+ #else
+ NOT_IMPLEMENTED();
+@@ -316,7 +316,7 @@
+ Bool
+ Util_IsAbsolutePath(const char *path) // IN: path to check
+ {
+-#if defined(__linux__) || defined(__APPLE__)
++#if defined(__linux__) || defined(__APPLE__) || defined(__FreeBSD__)
+ // path[0] is valid even for the empty string.
+ return path && path[0] == DIRSEPC;
+ #elif defined(_WIN32)