aboutsummaryrefslogtreecommitdiff
path: root/emulators/open-vm-tools
diff options
context:
space:
mode:
authorJosh Paetzel <jpaetzel@FreeBSD.org>2018-05-23 22:37:05 +0000
committerJosh Paetzel <jpaetzel@FreeBSD.org>2018-05-23 22:37:05 +0000
commit25959fc5006c52b7ca5548fd8e53372aeb0314e2 (patch)
tree9fd0805e296c3eb84712653a6eda96cc4d9b5a3c /emulators/open-vm-tools
parent1fdef73cf3c6a3ec01a648dc64b8bc77ee33e1ff (diff)
Notes
Diffstat (limited to 'emulators/open-vm-tools')
-rw-r--r--emulators/open-vm-tools/Makefile6
-rw-r--r--emulators/open-vm-tools/files/extra-patch-modules_freebsd_vmxnet_net__compat.h13
2 files changed, 18 insertions, 1 deletions
diff --git a/emulators/open-vm-tools/Makefile b/emulators/open-vm-tools/Makefile
index 0c25bc0995c6..2db822f9ccc8 100644
--- a/emulators/open-vm-tools/Makefile
+++ b/emulators/open-vm-tools/Makefile
@@ -4,7 +4,7 @@
PORTNAME= open-vm-tools
PORTVERSION= ${RELEASE_VER}
DISTVERSIONPREFIX= stable-
-PORTREVISION= 5
+PORTREVISION= 6
PORTEPOCH= 2
CATEGORIES= emulators
@@ -65,6 +65,10 @@ INSTALL_TARGET= install-strip
.include <bsd.port.options.mk>
+.if ${OPSYS} == FreeBSD && ${OSVERSION} > 1200063
+EXTRA_PATCHES= ${PATCHDIR}/extra-patch-modules_freebsd_vmxnet_net__compat.h
+.endif
+
.if ${PORT_OPTIONS:MX11}
CONFLICTS= open-vm-tools-nox11-[0-9]*
.else
diff --git a/emulators/open-vm-tools/files/extra-patch-modules_freebsd_vmxnet_net__compat.h b/emulators/open-vm-tools/files/extra-patch-modules_freebsd_vmxnet_net__compat.h
new file mode 100644
index 000000000000..bcb2b969c792
--- /dev/null
+++ b/emulators/open-vm-tools/files/extra-patch-modules_freebsd_vmxnet_net__compat.h
@@ -0,0 +1,13 @@
+--- modules/freebsd/vmxnet/net_compat.h.orig 2018-05-23 22:11:09 UTC
++++ modules/freebsd/vmxnet/net_compat.h
+@@ -38,8 +38,8 @@
+ #define VXN_IFMULTI_FIRST LIST_FIRST
+ #define VXN_IFMULTI_NEXT LIST_NEXT
+ #else /* >= 500016 */
+- #define VXN_IFMULTI_FIRST TAILQ_FIRST
+- #define VXN_IFMULTI_NEXT TAILQ_NEXT
++ #define VXN_IFMULTI_FIRST CK_STAILQ_FIRST
++ #define VXN_IFMULTI_NEXT CK_STAILQ_NEXT
+ #endif /* 500016 */
+
+ #if __FreeBSD_version < 500043