aboutsummaryrefslogtreecommitdiff
path: root/emulators/open-vm-tools
diff options
context:
space:
mode:
authorDima Panov <fluffy@FreeBSD.org>2020-12-31 19:17:51 +0000
committerDima Panov <fluffy@FreeBSD.org>2020-12-31 19:17:51 +0000
commita78580410782e5dafd3dea2e31738c0acf5ea42c (patch)
tree971e162090df1b7e01603c554460b8bf8bc74853 /emulators/open-vm-tools
parent275295b8750fd6c680ca214f64458932e9cd38a7 (diff)
emulators/open-vm-tools: update to 11.2.0 release
PR: 250550 Submitted by: fluffy Approved by: jpaetzel
Notes
Notes: svn path=/head/; revision=559767
Diffstat (limited to 'emulators/open-vm-tools')
-rw-r--r--emulators/open-vm-tools/Makefile4
-rw-r--r--emulators/open-vm-tools/distinfo6
-rw-r--r--emulators/open-vm-tools/files/patch-lib_misc_util__misc.c4
-rw-r--r--emulators/open-vm-tools/files/patch-lib_vmCheck_vmcheck.c4
-rw-r--r--emulators/open-vm-tools/files/patch-modules_Makefile.am4
-rw-r--r--emulators/open-vm-tools/files/patch-modules_freebsd_vmblock_Makefile4
-rw-r--r--emulators/open-vm-tools/files/patch-pam_generic (renamed from emulators/open-vm-tools/files/patch-scripts_linux_pam.d_vmtoolsd)10
-rw-r--r--emulators/open-vm-tools/files/patch-services_vmtoolsd_Makefile.am6
8 files changed, 22 insertions, 20 deletions
diff --git a/emulators/open-vm-tools/Makefile b/emulators/open-vm-tools/Makefile
index 333061433ce3..409edf4d3807 100644
--- a/emulators/open-vm-tools/Makefile
+++ b/emulators/open-vm-tools/Makefile
@@ -19,8 +19,8 @@ ONLY_FOR_ARCHS= amd64 i386
LIB_DEPENDS= libmspack.so:archivers/libmspack \
libdnet.so:net/libdnet
-RELEASE_VER= 11.1.5
-BUILD_VER= 16724464
+RELEASE_VER= 11.2.0
+BUILD_VER= 16938113
OPTIONS_DEFINE= DOCS LIBNOTIFY OPENSSL X11
OPTIONS_DEFAULT= DOCS LIBNOTIFY OPENSSL X11
diff --git a/emulators/open-vm-tools/distinfo b/emulators/open-vm-tools/distinfo
index 017cdbc7d380..02b46bba10ad 100644
--- a/emulators/open-vm-tools/distinfo
+++ b/emulators/open-vm-tools/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1599247749
-SHA256 (vmware-open-vm-tools-stable-11.1.5_GH0.tar.gz) = 0bbc20d725cb2e15db5bd5e6a9cbab7fc98c2e3208f19a233a2308468cb2dc04
-SIZE (vmware-open-vm-tools-stable-11.1.5_GH0.tar.gz) = 2668828
+TIMESTAMP = 1606400181
+SHA256 (vmware-open-vm-tools-stable-11.2.0_GH0.tar.gz) = 280970a15dd8210b89e68df5fce64fa8bfb3ff7ca3737ce5ebf8634d8c1a2494
+SIZE (vmware-open-vm-tools-stable-11.2.0_GH0.tar.gz) = 2710170
diff --git a/emulators/open-vm-tools/files/patch-lib_misc_util__misc.c b/emulators/open-vm-tools/files/patch-lib_misc_util__misc.c
index 83dafd00666b..bffa9ea16acf 100644
--- a/emulators/open-vm-tools/files/patch-lib_misc_util__misc.c
+++ b/emulators/open-vm-tools/files/patch-lib_misc_util__misc.c
@@ -1,6 +1,6 @@
---- lib/misc/util_misc.c.orig 2018-03-30 18:44:35 UTC
+--- lib/misc/util_misc.c.orig 2020-10-16 23:15:58 UTC
+++ lib/misc/util_misc.c
-@@ -303,7 +303,7 @@ Util_CanonicalPathsIdentical(const char *path1, // IN
+@@ -304,7 +304,7 @@ Util_CanonicalPathsIdentical(const char *path1, // IN
return (strcmp(path1, path2) == 0);
#elif defined(_WIN32)
return (_stricmp(path1, path2) == 0);
diff --git a/emulators/open-vm-tools/files/patch-lib_vmCheck_vmcheck.c b/emulators/open-vm-tools/files/patch-lib_vmCheck_vmcheck.c
index d3366c71909b..1d9a52e7c78f 100644
--- a/emulators/open-vm-tools/files/patch-lib_vmCheck_vmcheck.c
+++ b/emulators/open-vm-tools/files/patch-lib_vmCheck_vmcheck.c
@@ -1,6 +1,6 @@
---- lib/vmCheck/vmcheck.c.orig 2018-07-13 18:54:23 UTC
+--- lib/vmCheck/vmcheck.c.orig 2020-10-16 23:15:58 UTC
+++ lib/vmCheck/vmcheck.c
-@@ -153,6 +153,7 @@ VmCheckSafe(SafeCheckFn checkFn)
+@@ -144,6 +144,7 @@ VmCheckSafe(SafeCheckFn checkFn)
#else
do {
int signals[] = {
diff --git a/emulators/open-vm-tools/files/patch-modules_Makefile.am b/emulators/open-vm-tools/files/patch-modules_Makefile.am
index 53442013569e..b53fda2dc938 100644
--- a/emulators/open-vm-tools/files/patch-modules_Makefile.am
+++ b/emulators/open-vm-tools/files/patch-modules_Makefile.am
@@ -6,12 +6,12 @@
if FREEBSD
- for MOD in $(MODULES); do \
- $(INSTALL) -d $(DESTDIR)$(MODULES_DIR); \
-- $(INSTALL) -m644 $(modulesrc)/$(MODULES_OS)/$$MOD.ko \
+- $(INSTALL) -m 644 $(modulesrc)/$(MODULES_OS)/$$MOD.ko \
- $(DESTDIR)$(MODULES_DIR); \
- done
+# for MOD in $(MODULES); do \
+# $(INSTALL) -d $(DESTDIR)$(MODULES_DIR); \
-+# $(INSTALL) -m644 $(modulesrc)/$(MODULES_OS)/$$MOD.ko \
++# $(INSTALL) -m 644 $(modulesrc)/$(MODULES_OS)/$$MOD.ko \
+# $(DESTDIR)$(MODULES_DIR); \
+# done
endif
diff --git a/emulators/open-vm-tools/files/patch-modules_freebsd_vmblock_Makefile b/emulators/open-vm-tools/files/patch-modules_freebsd_vmblock_Makefile
index 963776a59f50..55ea64323dd5 100644
--- a/emulators/open-vm-tools/files/patch-modules_freebsd_vmblock_Makefile
+++ b/emulators/open-vm-tools/files/patch-modules_freebsd_vmblock_Makefile
@@ -1,6 +1,6 @@
---- modules/freebsd/vmblock/Makefile.orig
+--- modules/freebsd/vmblock/Makefile.orig 2020-10-16 23:15:58 UTC
+++ modules/freebsd/vmblock/Makefile
-@@ -46,8 +46,6 @@
+@@ -46,8 +46,6 @@ SRCS := $(HEADERS) $(CSRCS)
KMOD = vmblock
PROG = ../$(KMOD).ko
diff --git a/emulators/open-vm-tools/files/patch-scripts_linux_pam.d_vmtoolsd b/emulators/open-vm-tools/files/patch-pam_generic
index 4b9f2860d7e4..1954cc6cf818 100644
--- a/emulators/open-vm-tools/files/patch-scripts_linux_pam.d_vmtoolsd
+++ b/emulators/open-vm-tools/files/patch-pam_generic
@@ -1,7 +1,9 @@
---- scripts/linux/pam.d/vmtoolsd.orig 2013-09-23 15:51:10 UTC
-+++ scripts/linux/pam.d/vmtoolsd
-@@ -1,7 +1,3 @@
- #%PAM-1.0
+--- pam/generic.orig 2020-10-16 23:15:58 UTC
++++ pam/generic
+@@ -1,9 +1,5 @@
+ # This is a generic pam config file for open-vm-tools
+ # See https://kb.vmware.com/s/article/78251 for advice to use
+ # common authentication mechanisms.
-auth required pam_shells.so
-auth sufficient pam_unix.so shadow
-auth required pam_unix_auth.so shadow
diff --git a/emulators/open-vm-tools/files/patch-services_vmtoolsd_Makefile.am b/emulators/open-vm-tools/files/patch-services_vmtoolsd_Makefile.am
index 0cb245c1784c..a617eea05ad0 100644
--- a/emulators/open-vm-tools/files/patch-services_vmtoolsd_Makefile.am
+++ b/emulators/open-vm-tools/files/patch-services_vmtoolsd_Makefile.am
@@ -1,11 +1,11 @@
--- services/vmtoolsd/Makefile.am.orig 2017-04-25 03:59:07 UTC
+++ services/vmtoolsd/Makefile.am
-@@ -83,7 +83,7 @@ install-data-hook:
+@@ -76,7 +76,7 @@ install-data-hook:
@INSTVMSG@ vmtoolsd $(srcdir)/l10n $(DESTDIR)$(datadir)
install-exec-hook:
- $(INSTALL) -d $(DESTDIR)/etc/vmware-tools
+# $(INSTALL) -d $(DESTDIR)/etc/vmware-tools
+ $(INSTALL) -d $(DESTDIR)/$(PAM_PREFIX)/pam.d/
+ $(INSTALL) $(top_srcdir)/pam/generic $(DESTDIR)/$(PAM_PREFIX)/pam.d/vmtoolsd
- uninstall-hook:
- rm -rf $(DESTDIR)/etc/vmware-tools