aboutsummaryrefslogtreecommitdiff
path: root/emulators/openmsx
diff options
context:
space:
mode:
authorHiroki Tagato <tagattie@FreeBSD.org>2020-05-04 03:53:22 +0000
committerHiroki Tagato <tagattie@FreeBSD.org>2020-05-04 03:53:22 +0000
commit4f3b15e0bb2246e1a0a91ef57dacfc6422acfae2 (patch)
treeaf3888b52acf228ea770056543a13b75d7399f0d /emulators/openmsx
parent8cfb859234a59fdc6941c4b8e83ab934ef8ab705 (diff)
- Resurrect port and undeprecate
- Pass maintainership to submitter - Add LICENSE_FILE - Drop dependency on python2 PR: 245731 Submitted by: Daniel Menelkir <menelkir@itroll.org> Approved by: ehaupt (mentor)
Notes
Notes: svn path=/head/; revision=533890
Diffstat (limited to 'emulators/openmsx')
-rw-r--r--emulators/openmsx/Makefile56
-rw-r--r--emulators/openmsx/distinfo3
-rw-r--r--emulators/openmsx/pkg-descr4
3 files changed, 63 insertions, 0 deletions
diff --git a/emulators/openmsx/Makefile b/emulators/openmsx/Makefile
new file mode 100644
index 000000000000..6b12545eaec0
--- /dev/null
+++ b/emulators/openmsx/Makefile
@@ -0,0 +1,56 @@
+# $FreeBSD$
+
+PORTNAME= openmsx
+PORTVERSION= 0.15.0
+PORTREVISION= 2
+CATEGORIES= emulators
+
+MAINTAINER= menelkir@itroll.org
+COMMENT= Open source MSX emulator
+
+LICENSE= GPLv2
+LICENSE_FILE= ${WRKSRC}/doc/GPL.txt
+
+LIB_DEPENDS= libpng.so:graphics/png \
+ libogg.so:audio/libogg \
+ libvorbis.so:audio/libvorbis \
+ libtheora.so:multimedia/libtheora \
+ libao.so:audio/libao \
+ libfreetype.so:print/freetype2 \
+ libasound.so:audio/alsa-lib
+
+USES= gl gmake python sdl tcl
+USE_GCC= yes
+USE_GL= gl glew
+USE_SDL= sdl2 ttf2
+
+USE_GITHUB= yes
+GH_ACCOUNT= openMSX
+GH_PROJECT= openMSX
+GH_TAGNAME= 0f2b558
+
+BINARY_ALIAS= python3=${PYTHON_CMD}
+
+MAKEFILE= GNUmakefile
+MAKE_ARGS= INSTALL_BINARY_DIR=${PREFIX}/bin \
+ INSTALL_SHARE_DIR=${DATADIR} \
+ INSTALL_DOC_DIR=${DOCSDIR} \
+ OPENMSX_CXX=${CXX} \
+ CXXFLAGS="${CXXFLAGS}"
+
+PLIST_FILES= bin/openmsx
+PORTDATA= *
+PORTDOCS= *
+
+OPTIONS_DEFINE= DOCS
+
+post-patch:
+ @${REINPLACE_CMD} -e 's/{TCL_LIB_SPEC}/& $${TCL_LD_FLAGS}/' \
+ ${WRKSRC}/build/libraries.py
+ @${REINPLACE_CMD} -e '/^SYMLINK_FOR_BINARY/s/true/false/' \
+ ${WRKSRC}/build/custom.mk
+
+post-install-DOCS-off:
+ ${RM} -r ${STAGEDIR}${DOCSDIR}
+
+.include <bsd.port.mk>
diff --git a/emulators/openmsx/distinfo b/emulators/openmsx/distinfo
new file mode 100644
index 000000000000..d478d4908c7d
--- /dev/null
+++ b/emulators/openmsx/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1588351340
+SHA256 (openMSX-openMSX-0.15.0-0f2b558_GH0.tar.gz) = 4be0852c3eed442771dc450ad5385a5b30c97927be543da91bd685e5484d560d
+SIZE (openMSX-openMSX-0.15.0-0f2b558_GH0.tar.gz) = 5589585
diff --git a/emulators/openmsx/pkg-descr b/emulators/openmsx/pkg-descr
new file mode 100644
index 000000000000..462a095eca43
--- /dev/null
+++ b/emulators/openmsx/pkg-descr
@@ -0,0 +1,4 @@
+OpenMSX, the open source MSX emulator that tries to achieve
+near-perfect emulation by using a novel emulation model.
+
+WWW: http://openmsx.org