aboutsummaryrefslogtreecommitdiff
path: root/emulators/osmose
diff options
context:
space:
mode:
authorRenato Botelho <garga@FreeBSD.org>2005-07-28 11:14:51 +0000
committerRenato Botelho <garga@FreeBSD.org>2005-07-28 11:14:51 +0000
commitb8330a16cfed8b64b21a9c4c8ceddd5ffc61e149 (patch)
tree120679ea186810890219b865cbb3bc2c29b57a87 /emulators/osmose
parent5e3cc60a87f61d37f708179eb50795107a69fc4c (diff)
downloadports-b8330a16cfed8b64b21a9c4c8ceddd5ffc61e149.tar.gz
ports-b8330a16cfed8b64b21a9c4c8ceddd5ffc61e149.zip
Notes
Diffstat (limited to 'emulators/osmose')
-rw-r--r--emulators/osmose/Makefile63
-rw-r--r--emulators/osmose/distinfo2
-rw-r--r--emulators/osmose/files/extra-patch-freebsd4110
-rw-r--r--emulators/osmose/files/patch-Makefile29
-rw-r--r--emulators/osmose/files/patch-unzip-Makefile8
-rw-r--r--emulators/osmose/files/patch-zlib-Makefile12
-rw-r--r--emulators/osmose/pkg-descr12
7 files changed, 236 insertions, 0 deletions
diff --git a/emulators/osmose/Makefile b/emulators/osmose/Makefile
new file mode 100644
index 000000000000..3842da9b9689
--- /dev/null
+++ b/emulators/osmose/Makefile
@@ -0,0 +1,63 @@
+# New ports collection makefile for: osmose
+# Date created: 27 Jul 2005
+# Whom: Alejandro Pulver <alejandro@varnet.biz>
+#
+# $FreeBSD$
+#
+
+PORTNAME= osmose
+PORTVERSION= 0.6.30
+CATEGORIES= emulators
+MASTER_SITES= http://bcz.emu-france.com/osmose/
+DISTNAME= ${PORTNAME}-final-src
+
+MAINTAINER= alejandro@varnet.biz
+COMMENT= Sega Master System emulator
+
+ONLY_FOR_ARCHS= i386
+
+USE_ZIP= yes
+USE_GMAKE= yes
+USE_SDL= sdl
+USE_REINPLACE= yes
+
+NO_WRKSUBDIR= yes
+
+OPTIONS= OPTIMIZED_CFLAGS "Enable compilation optimizations" on
+
+PLIST_FILES= bin/osmose
+
+.if !defined(NOPORTDOCS)
+PLIST_FILES+= %%DOCSDIR%%/readme.txt
+PLIST_DIRS= %%DOCSDIR%%
+.endif
+
+do-install:
+ @${INSTALL_PROGRAM} ${WRKSRC}/${PORTNAME} ${PREFIX}/bin
+.if !defined(NOPORTDOCS)
+ @${MKDIR} ${DOCSDIR}
+ @${INSTALL_DATA} ${WRKSRC}/readme.txt ${DOCSDIR}
+.endif
+
+.include <bsd.port.pre.mk>
+
+.if ${OSVERSION} < 500000
+EXTRA_PATCHES= ${FILESDIR}/extra-patch-freebsd4
+.endif
+
+post-patch:
+# Fix Makefile
+ @${REINPLACE_CMD} -e 's|\(-Dlinux\)|${CFLAGS} \1| ; \
+ s|sdl-config|${SDL_CONFIG}|' \
+ ${WRKSRC}/${MAKEFILE}
+
+# Fix SDL include statement
+ @${REINPLACE_CMD} -e 's|\(#include.*\)SDL/\(SDL.*\)|\1\2|' \
+ ${WRKSRC}/*.h
+
+# Enable/disable compilation optimizations
+.if defined(WITHOUT_OPTIMIZED_CFLAGS)
+ @${REINPLACE_CMD} -e 's|-O3||g' ${WRKSRC}/${MAKEFILE}
+.endif
+
+.include <bsd.port.post.mk>
diff --git a/emulators/osmose/distinfo b/emulators/osmose/distinfo
new file mode 100644
index 000000000000..f7f21c3bdebb
--- /dev/null
+++ b/emulators/osmose/distinfo
@@ -0,0 +1,2 @@
+MD5 (osmose-final-src.zip) = 4607029f0b9332d9e0bc0555f542dc88
+SIZE (osmose-final-src.zip) = 297235
diff --git a/emulators/osmose/files/extra-patch-freebsd4 b/emulators/osmose/files/extra-patch-freebsd4
new file mode 100644
index 000000000000..4757bc6008ae
--- /dev/null
+++ b/emulators/osmose/files/extra-patch-freebsd4
@@ -0,0 +1,110 @@
+--- InputDevice.h.orig Wed Jul 27 23:08:41 2005
++++ InputDevice.h Wed Jul 27 23:09:05 2005
+@@ -17,6 +17,7 @@
+ #ifndef INPUT_DEVICE_H
+ #define INPUT_DEVICE_H
+
++#include <string>
+ #include <SDL/SDL.h>
+ #include <iostream>
+
+--- Options.h.orig Wed Jul 27 22:33:50 2005
++++ Options.h Wed Jul 27 22:34:08 2005
+@@ -14,6 +14,7 @@
+ #ifndef OPTIONS_H
+ #define OPTIONS_H
+
++#include <string.h>
+ #include <iostream>
+ #include <iomanip>
+ #include "Bits.h"
+--- OsmoseCore.cpp.orig Wed Jul 27 03:33:44 2005
++++ OsmoseCore.cpp Wed Jul 27 03:34:13 2005
+@@ -12,6 +12,7 @@
+ *
+ * URL: http://bcz.emu-france.com/
+ *****************************************************************************/
++#include <string>
+ #include "OsmoseCore.h"
+
+ #define TIME_LIMITE 7*60
+--- SN76489.h.orig Wed Jul 27 22:26:47 2005
++++ SN76489.h Wed Jul 27 22:31:08 2005
+@@ -13,6 +13,7 @@
+ *****************************************************************************/
+ #ifndef SN76489_H
+ #define SN76489_H
++#include <string.h>
+ #include <iomanip>
+ #include <iostream>
+ #include <SDL/SDL.h>
+--- TextWriter.h.orig Wed Jul 27 23:06:45 2005
++++ TextWriter.h Wed Jul 27 23:06:53 2005
+@@ -15,6 +15,7 @@
+ #ifndef TEXT_WRITER_H
+ #define TEXT_WRITER_H
+
++#include <string>
+ #include <iomanip>
+ #include <SDL/SDL.h>
+
+--- VDP.h.orig Wed Jul 27 21:55:01 2005
++++ VDP.h Wed Jul 27 21:55:33 2005
+@@ -13,6 +13,7 @@
+ *****************************************************************************/
+ #ifndef VDP_H
+ #define VDP_H
++#include <string.h>
+ #include <SDL/SDL.h>
+ #include <iomanip>
+ #include <iostream>
+--- VideoFilter.h.orig Wed Jul 27 23:04:17 2005
++++ VideoFilter.h Wed Jul 27 23:04:36 2005
+@@ -35,6 +35,7 @@
+ #ifndef VIDEO_FILTER_H
+ #define VIDEO_FILTER_H
+
++#include <string>
+ #include <SDL/SDL.h>
+ #include <iostream>
+
+--- main.cpp.orig Sun May 22 19:43:10 2005
++++ main.cpp Wed Jul 27 03:20:22 2005
+@@ -31,6 +31,7 @@
+ * URL: http://bcz.emu-france.com/
+ *****************************************************************************/
+
++#include <string>
+ #include <iostream>
+ #include <iomanip>
+ #include "OsmoseCore.h"
+@@ -155,7 +156,7 @@
+ // If actual argument nbr < argument number eg is there any args ?
+ if (i < a-1)
+ {
+- opt.acceleration = atof( rv[i+1]);
++ opt.acceleration = strtod(rv[i+1], (char **)NULL);
+ if (opt.acceleration == 0)
+ {
+ cerr << "No valid acceleration parameter was given. Using default " << (float)DEFAULT_ACCELERATION << " value." << endl;
+--- MemoryMapper.h.orig Mon Apr 11 20:07:36 2005
++++ MemoryMapper.h Thu Jul 28 07:57:32 2005
+@@ -14,6 +14,8 @@
+ *****************************************************************************/
+ #ifndef MEMORY_MAPPER_H
+ #define MEMORY_MAPPER_H
++#include <stdlib.h>
++#include <string>
+ #include <iostream>
+ #include <fstream>
+ #include <iomanip>
+--- OsmoseConfiguration.h.orig Mon Jan 24 11:28:46 2005
++++ OsmoseConfiguration.h Thu Jul 28 07:59:39 2005
+@@ -15,6 +15,7 @@
+ #ifndef OSMOSE_CONFIGURATION_H
+ #define OSMOSE_CONFIGURATION_H
+
++#include <string>
+ #include <SDL/SDL.h>
+ #include <iostream>
+ #include <iomanip>
diff --git a/emulators/osmose/files/patch-Makefile b/emulators/osmose/files/patch-Makefile
new file mode 100644
index 000000000000..dee66ea1e78b
--- /dev/null
+++ b/emulators/osmose/files/patch-Makefile
@@ -0,0 +1,29 @@
+--- Makefile.orig Thu Jul 28 07:51:45 2005
++++ Makefile Thu Jul 28 07:53:34 2005
+@@ -43,11 +43,11 @@
+
+ # Compiler/Linker Flags
+ # add -O3 to CFLAGS for speedup -pg on LFLAGS and CFLAGS for gprof
+-CFLAGS = -Wall -O3
+-LFLAGS = -lSDL
++CFLAGS = -Dlinux `sdl-config --cflags` -O3
++LFLAGS = `sdl-config --libs`
+ AFLAGS = -f elf
+-CC = g++
+-C_COMP = gcc
++CC = ${CXX}
++C_COMP = ${CC}
+ ASM = nasm
+
+ # Our needed rules. $* is current file, without suffix.
+@@ -84,8 +84,8 @@
+ rm -f *.o core $(OSM_EXE)
+
+ libs:
+- cd $(Z_LIB_DIR) && make libz.a
+- cd $(UNZIP_DIR) && make unzip.a
++ cd $(Z_LIB_DIR) && ${MAKE} libz.a
++ cd $(UNZIP_DIR) && ${MAKE} unzip.a
+
+
+
diff --git a/emulators/osmose/files/patch-unzip-Makefile b/emulators/osmose/files/patch-unzip-Makefile
new file mode 100644
index 000000000000..7b3094da8317
--- /dev/null
+++ b/emulators/osmose/files/patch-unzip-Makefile
@@ -0,0 +1,8 @@
+--- unzip/Makefile.orig Fri Dec 17 13:21:30 2004
++++ unzip/Makefile Tue Jul 26 21:15:04 2005
+@@ -1,5 +1,3 @@
+-CC=cc
+-CFLAGS=-O
+
+ UNZ_OBJS = unzip.o ioapi.o
+
diff --git a/emulators/osmose/files/patch-zlib-Makefile b/emulators/osmose/files/patch-zlib-Makefile
new file mode 100644
index 000000000000..77da14966812
--- /dev/null
+++ b/emulators/osmose/files/patch-zlib-Makefile
@@ -0,0 +1,12 @@
+--- zlib/Makefile.orig Fri Dec 17 11:04:40 2004
++++ zlib/Makefile Tue Jul 26 21:16:20 2005
+@@ -16,9 +16,7 @@
+ # To install in $HOME instead of /usr/local, use:
+ # make install prefix=$HOME
+
+-CC=cc
+
+-CFLAGS=-O
+ #CFLAGS=-O -DMAX_WBITS=14 -DMAX_MEM_LEVEL=7
+ #CFLAGS=-g -DDEBUG
+ #CFLAGS=-O3 -Wall -Wwrite-strings -Wpointer-arith -Wconversion \
diff --git a/emulators/osmose/pkg-descr b/emulators/osmose/pkg-descr
new file mode 100644
index 000000000000..851aac9f5e0f
--- /dev/null
+++ b/emulators/osmose/pkg-descr
@@ -0,0 +1,12 @@
+Osmose is another Sega Master System emulator. The emulator is released as
+open source project, under GPL license.
+
+The emulator relies on SDL library, zlib, and uses Alessandro Scotti z80 cpu
+core. Alessandro, is the author of the nice multi machine emulator 'Tickle'.
+Rom decompression relies on Zlib and Gilles Vollant unzip package. Scale2x
+video Filter is based on Andrea Mazzoleni's algorithm.
+
+WWW: http://bcz.emu-france.com/
+
+- Alejandro Pulver
+alejandro@varnet.biz