aboutsummaryrefslogtreecommitdiff
path: root/emulators/pearpc/Makefile
diff options
context:
space:
mode:
authorVolker Stolz <vs@FreeBSD.org>2004-08-19 19:52:57 +0000
committerVolker Stolz <vs@FreeBSD.org>2004-08-19 19:52:57 +0000
commit404de5fcd5d34a38f967c388152824fa837dbb68 (patch)
tree2d0490f4ce7c00540646a67eb2c31df85a50f66b /emulators/pearpc/Makefile
parent1842ddffa81e74089fb9dd39100a51e713fc373f (diff)
downloadports-404de5fcd5d34a38f967c388152824fa837dbb68.tar.gz
ports-404de5fcd5d34a38f967c388152824fa837dbb68.zip
Notes
Diffstat (limited to 'emulators/pearpc/Makefile')
-rw-r--r--emulators/pearpc/Makefile25
1 files changed, 15 insertions, 10 deletions
diff --git a/emulators/pearpc/Makefile b/emulators/pearpc/Makefile
index bb4d5708e89d..03dafcba9d0a 100644
--- a/emulators/pearpc/Makefile
+++ b/emulators/pearpc/Makefile
@@ -6,7 +6,7 @@
#
PORTNAME= pearpc
-PORTVERSION= 0.2.0
+PORTVERSION= 0.3.0
CATEGORIES= emulators
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
MASTER_SITE_SUBDIR= ${PORTNAME}
@@ -22,20 +22,25 @@ PKGMESSAGE= ${WRKDIR}/pkg-message
MAN1= ppc.1
+PLIST_FILES= bin/ppc etc/ppccfg.example %%DATADIR%%/video.x
+PLIST_DIRS= %%DATADIR%%
+
.if defined(WITH_OPTIMIZED_CFLAGS)
CFLAGS+= -O3 -ffast-math
.else
CONFIGURE_ARGS+= --disable-fpo
.endif
-.if defined(WITH_QT)
-CONFIGURE_ARGS+= --enable-gui=qt
-USE_QT_VER= 3
-QTDIR?= ${X11BASE}
-CONFIGURE_ENV+= QTDIR="${QTDIR}"
-.else
-CONFIGURE_ARGS+= --enable-gui=nogui
-.endif
+# GTK and QT ui are broken in this version
+#
+#.if defined(WITH_QT)
+#CONFIGURE_ARGS+= --enable-ui=qt
+#USE_QT_VER= 3
+#QTDIR?= ${X11BASE}
+#CONFIGURE_ENV+= QTDIR="${QTDIR}"
+#.else
+#CONFIGURE_ARGS+= --enable-ui=nogui
+#.endif
.include <bsd.port.pre.mk>
@@ -64,7 +69,7 @@ pre-everything::
post-patch:
.if ${OSVERSION} < 500000
- @${REINPLACE_CMD} -e 's|stdint.h|inttypes.h|' ${WRKSRC}/src/system/posix/types.h
+ @${REINPLACE_CMD} -e 's|stdint.h|inttypes.h|' ${WRKSRC}/src/system/osapi/posix/types.h
.endif
post-configure: