aboutsummaryrefslogtreecommitdiff
path: root/emulators/pearpc
diff options
context:
space:
mode:
authorClement Laforet <clement@FreeBSD.org>2004-05-23 21:28:46 +0000
committerClement Laforet <clement@FreeBSD.org>2004-05-23 21:28:46 +0000
commit11f605664244c4c425a16530b762f038968632ce (patch)
tree2292dd7cdc7b8ceced7506e6f192ab93c165a26e /emulators/pearpc
parent39593341083d5377255ae67ab6f7f91b365b7697 (diff)
downloadports-11f605664244c4c425a16530b762f038968632ce.tar.gz
ports-11f605664244c4c425a16530b762f038968632ce.zip
Notes
Diffstat (limited to 'emulators/pearpc')
-rw-r--r--emulators/pearpc/Makefile36
-rw-r--r--emulators/pearpc/distinfo2
-rw-r--r--emulators/pearpc/files/patch-configure23
-rw-r--r--emulators/pearpc/files/patch-src::io::3c90x::3c90x.cc11
-rw-r--r--emulators/pearpc/files/patch-src::io::3c90x::if_posix.cc12
-rw-r--r--emulators/pearpc/files/pkg-message.in3
-rw-r--r--emulators/pearpc/pkg-descr7
-rw-r--r--emulators/pearpc/pkg-plist4
8 files changed, 98 insertions, 0 deletions
diff --git a/emulators/pearpc/Makefile b/emulators/pearpc/Makefile
new file mode 100644
index 000000000000..6b2838376d3b
--- /dev/null
+++ b/emulators/pearpc/Makefile
@@ -0,0 +1,36 @@
+# New ports collection makefile for: pearpc
+# Date created: 22 May 2004
+# Whom: Roman Bogorodskiy
+#
+# $FreeBSD$
+#
+
+PORTNAME= pearpc
+PORTVERSION= 0.1.2
+CATEGORIES= emulators
+MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
+MASTER_SITE_SUBDIR= ${PORTNAME}
+
+MAINTAINER= bogorodskiy@inbox.ru
+COMMENT= PowerPC emulator
+
+USE_XLIB= yes
+USE_REINPLACE= yes
+GNU_CONFIGURE= yes
+CONFIGURE_ENV= CPPFLAGS="-I${X11BASE}/include" \
+ LDFLAGS="-L${X11BASE}/lib"
+CONFIGURE_ARGS= --disable-fpo
+PKGMESSAGE= ${WRKDIR}/pkg-message
+
+post-configure:
+ @${REINPLACE_CMD} -e 's|-lpthread|${PTHREAD_LIBS}|g' ${WRKSRC}/Makefile
+ @${REINPLACE_CMD} -e 's|-lpthread|${PTHREAD_LIBS}|g' ${WRKSRC}/src/Makefile
+
+post-install:
+ @${MKDIR} ${DATADIR}
+ @${INSTALL_DATA} ${WRKSRC}/video.x ${DATADIR}/video.x
+ @${SED} -e 's,PREFIX,${PREFIX},g' ${FILESDIR}/pkg-message.in > ${PKGMESSAGE}
+ @${CAT} ${PKGMESSAGE}
+ @${INSTALL_DATA} ${WRKSRC}/ppccfg.example ${PREFIX}/etc/ppccfg.example
+
+.include <bsd.port.mk>
diff --git a/emulators/pearpc/distinfo b/emulators/pearpc/distinfo
new file mode 100644
index 000000000000..103515118cc1
--- /dev/null
+++ b/emulators/pearpc/distinfo
@@ -0,0 +1,2 @@
+MD5 (pearpc-0.1.2.tar.gz) = b65835ba666faaa426a069eb250ea38b
+SIZE (pearpc-0.1.2.tar.gz) = 675804
diff --git a/emulators/pearpc/files/patch-configure b/emulators/pearpc/files/patch-configure
new file mode 100644
index 000000000000..2c12c0fd62fd
--- /dev/null
+++ b/emulators/pearpc/files/patch-configure
@@ -0,0 +1,23 @@
+--- configure.orig Sun May 23 23:18:16 2004
++++ configure Sun May 23 23:18:55 2004
+@@ -697,9 +697,9 @@
+ fi
+
+ if test "x$enable_release" = "xyes"; then
+- FLAGS_ALL="-g -O2 -Wall -fsigned-char"
++ FLAGS_ALL="-Wall -fsigned-char"
+ else
+- FLAGS_ALL="-g -O0 -Wall -fsigned-char"
++ FLAGS_ALL="-Wall -fsigned-char"
+ fi
+
+ if test "x$enable_fpo" = "xyes"; then
+@@ -1007,7 +1007,7 @@
+ USE_CPU_JITC_X86_FALSE=
+ fi
+
+-FLAGS_ALL="-D_FILE_OFFSET_BITS=64 -pipe $FLAGS_ALL";
++FLAGS_ALL="-D_FILE_OFFSET_BITS=64 $CFLAGS $FLAGS_ALL";
+
+ CXXFLAGS="$FLAGS_ALL"
+ CFLAGS="$FLAGS_ALL"
diff --git a/emulators/pearpc/files/patch-src::io::3c90x::3c90x.cc b/emulators/pearpc/files/patch-src::io::3c90x::3c90x.cc
new file mode 100644
index 000000000000..2ef3d6116269
--- /dev/null
+++ b/emulators/pearpc/files/patch-src::io::3c90x::3c90x.cc
@@ -0,0 +1,11 @@
+--- /usr/ports/emulators/pearpc/work/pearpc-0.1.2/src/io/3c90x/3c90x.cc Thu May 20 18:00:21 2004
++++ src/io/3c90x/3c90x.cc Sat May 22 13:56:19 2004
+@@ -47,6 +47,8 @@
+ #include "config.h"
+ #endif
+
++#define WIN32
++
+ #if defined(WIN32) || defined(__WIN32__)
+ #else
+
diff --git a/emulators/pearpc/files/patch-src::io::3c90x::if_posix.cc b/emulators/pearpc/files/patch-src::io::3c90x::if_posix.cc
new file mode 100644
index 000000000000..e66c37773489
--- /dev/null
+++ b/emulators/pearpc/files/patch-src::io::3c90x::if_posix.cc
@@ -0,0 +1,12 @@
+--- src/io/3c90x/if_posix.cc.orig Sat May 8 03:27:32 2004
++++ src/io/3c90x/if_posix.cc Sat May 22 13:12:17 2004
+@@ -20,6 +20,9 @@
+ * along with this program; if not, write to the Free Software
+ * Foundation, Inc., 675 Mass Ave, Cambridge, MA 02139, USA.
+ */
++
++#define WIN32 /* Dirty hack :-) */
++
+ #if defined(WIN32) || defined(__WIN32__)
+ #else
+
diff --git a/emulators/pearpc/files/pkg-message.in b/emulators/pearpc/files/pkg-message.in
new file mode 100644
index 000000000000..ea59d137d75f
--- /dev/null
+++ b/emulators/pearpc/files/pkg-message.in
@@ -0,0 +1,3 @@
+
+Sample config file can be found at /usr/local/etc/ppccfg.example
+
diff --git a/emulators/pearpc/pkg-descr b/emulators/pearpc/pkg-descr
new file mode 100644
index 000000000000..427485913c37
--- /dev/null
+++ b/emulators/pearpc/pkg-descr
@@ -0,0 +1,7 @@
+PearPC is an architecture-independent PowerPC platform emulator capable of
+running most PowerPC operating systems.
+
+WWW: http://pearpc.sourceforge.net/
+
+-Roman Bogorodskiy
+<bogorodskiy@inbox.ru>
diff --git a/emulators/pearpc/pkg-plist b/emulators/pearpc/pkg-plist
new file mode 100644
index 000000000000..8f8bbe97daf8
--- /dev/null
+++ b/emulators/pearpc/pkg-plist
@@ -0,0 +1,4 @@
+bin/ppc
+etc/ppccfg.example
+%%DATADIR%%/video.x
+@dirrm %%DATADIR%%