aboutsummaryrefslogtreecommitdiff
path: root/emulators/pearpc
diff options
context:
space:
mode:
authorRoman Bogorodskiy <novel@FreeBSD.org>2011-04-26 00:45:04 +0000
committerRoman Bogorodskiy <novel@FreeBSD.org>2011-04-26 00:45:04 +0000
commit072fce92f5aa56856368cdff63f9b094e39be72d (patch)
tree838d709bd45d5ff34b0373e59cd1120ec437dc2d /emulators/pearpc
parent2fb1466094d1f8dd2575989356521c564d377019 (diff)
downloadports-072fce92f5aa56856368cdff63f9b094e39be72d.tar.gz
ports-072fce92f5aa56856368cdff63f9b094e39be72d.zip
Notes
Diffstat (limited to 'emulators/pearpc')
-rw-r--r--emulators/pearpc/Makefile9
-rw-r--r--emulators/pearpc/distinfo1
-rw-r--r--emulators/pearpc/files/patch-src-system-osapi-posix-types.h18
3 files changed, 21 insertions, 7 deletions
diff --git a/emulators/pearpc/Makefile b/emulators/pearpc/Makefile
index 9b7bace14287..45d12ba49c99 100644
--- a/emulators/pearpc/Makefile
+++ b/emulators/pearpc/Makefile
@@ -14,9 +14,7 @@ MASTER_SITES= SF/${PORTNAME}/${PORTNAME}/${PORTVERSION}.0
MAINTAINER= novel@FreeBSD.org
COMMENT= PowerPC architecture emulator
-BROKEN= does not build
-DEPRECATED= has been broken for over a half year
-EXPIRATION_DATE=2011-04-17
+LICENSE= GPLv2
GNU_CONFIGURE= yes
USE_XORG= x11
@@ -28,8 +26,7 @@ PLIST_DIRS= %%DATADIR%%
OPTIONS= SDL "Use SDL for user interface" off \
OPTIMIZED_CFLAGS "Make an optimized build" off \
- DEBUG "Make debug+profiled build" off \
- JITC "Enable JITC support (x86 only)" off
+ DEBUG "Make debug+profiled build" off
.include <bsd.port.pre.mk>
@@ -65,7 +62,7 @@ CONFIGURE_ARGS+= --disable-fpo
CONFIGURE_ARGS+= --enable-profiling # implies --enable-debug
.endif
-.if defined(WITH_JITC) && ${ARCH} == "i386"
+.if ${ARCH} == "i386"
BUILD_DEPENDS= nasm:${PORTSDIR}/devel/nasm
CONFIGURE_ARGS+= --enable-cpu=jitc_x86
.else
diff --git a/emulators/pearpc/distinfo b/emulators/pearpc/distinfo
index 3c104244e214..8cb16cb0c960 100644
--- a/emulators/pearpc/distinfo
+++ b/emulators/pearpc/distinfo
@@ -1,3 +1,2 @@
-MD5 (pearpc-0.4.tar.gz) = c0eaeb588da2d6cd0ccfd62ea426e35f
SHA256 (pearpc-0.4.tar.gz) = cf9501dc95b418dc9632e57c75d59e78ec5204db0ed6b41abced2cea30021cce
SIZE (pearpc-0.4.tar.gz) = 910621
diff --git a/emulators/pearpc/files/patch-src-system-osapi-posix-types.h b/emulators/pearpc/files/patch-src-system-osapi-posix-types.h
new file mode 100644
index 000000000000..b530df3415f5
--- /dev/null
+++ b/emulators/pearpc/files/patch-src-system-osapi-posix-types.h
@@ -0,0 +1,18 @@
+--- src/system/osapi/posix/types.h.orig 2011-04-25 13:24:02.000000000 +0400
++++ src/system/osapi/posix/types.h 2011-04-25 13:24:05.000000000 +0400
+@@ -46,13 +46,13 @@
+ /* FreeBSD versions after importing gcc34 has broken offsetof() */
+ #ifdef __FreeBSD__
+ #include <sys/param.h>
+-#if __FreeBSD_version >= 502126
++#if (__FreeBSD_version >= 502126) && (__FreeBSD_version < 700042)
+ #undef offsetof
+ #define offsetof(TYPE, MEMBER) \
+ (__offsetof__ (reinterpret_cast <size_t> \
+ (&reinterpret_cast <const volatile char &> \
+ (static_cast<TYPE *> (0)->MEMBER))))
+-#endif /* __FreeBSD_version >= 502126 */
++#endif /* (__FreeBSD_version >= 502126) && (__FreeBSD_version < 700042) */
+ #endif /* __FreeBSD__ */
+
+ #endif