aboutsummaryrefslogtreecommitdiff
path: root/emulators/pearpc
diff options
context:
space:
mode:
authorAlexey Dokuchaev <danfe@FreeBSD.org>2010-06-14 06:17:21 +0000
committerAlexey Dokuchaev <danfe@FreeBSD.org>2010-06-14 06:17:21 +0000
commit0614d355ab7ea56910c1bab07cbe74ae9a0b9e11 (patch)
tree7005cb07e24c0b62dca103b842247123fcbf8bfe /emulators/pearpc
parent2bb492f2f1f1896384afa66f8ebac382a1642f6e (diff)
downloadports-0614d355ab7ea56910c1bab07cbe74ae9a0b9e11.tar.gz
ports-0614d355ab7ea56910c1bab07cbe74ae9a0b9e11.zip
Notes
Diffstat (limited to 'emulators/pearpc')
-rw-r--r--emulators/pearpc/Makefile73
-rw-r--r--emulators/pearpc/files/pkg-message.in4
2 files changed, 30 insertions, 47 deletions
diff --git a/emulators/pearpc/Makefile b/emulators/pearpc/Makefile
index 07d4ed412259..5b6aa4158683 100644
--- a/emulators/pearpc/Makefile
+++ b/emulators/pearpc/Makefile
@@ -1,6 +1,6 @@
-# New ports collection makefile for: pearpc
+# New ports collection makefile for: PearPC
# Date created: 22 May 2004
-# Whom: Roman Bogorodskiy
+# Whom: Roman Bogorodskiy <novel@FreeBSD.org>
#
# $FreeBSD$
#
@@ -12,26 +12,28 @@ CATEGORIES= emulators
MASTER_SITES= SF/${PORTNAME}/${PORTNAME}/${PORTVERSION}.0
MAINTAINER= novel@FreeBSD.org
-COMMENT= PowerPC emulator
+COMMENT= PowerPC architecture emulator
GNU_CONFIGURE= yes
-PKGMESSAGE= ${WRKDIR}/pkg-message
-
USE_XORG= x11
MAN1= ppc.1
+SUB_FILES= pkg-message
PLIST_FILES= bin/ppc etc/ppccfg.example %%DATADIR%%/video.x
PLIST_DIRS= %%DATADIR%%
-.if defined(WITH_OPTIMIZED_CFLAGS)
-CFLAGS+= -O3 -ffast-math
-.else
-CONFIGURE_ARGS+= --disable-fpo
-.endif
+OPTIONS= SDL "Use SDL for user interface" off \
+ OPTIMIZED_CFLAGS "Make an optimized build" off \
+ DEBUG "Make debug+profiled build" off \
+ JITC "Enable JITC support (x86 only)" off
-SUB_FILES= pkg-message
+.include <bsd.port.pre.mk>
-# GTK and QT ui are broken in this version
+.if ${ARCH} == "ia64"
+BROKEN= Internal compiler error on ia64
+.endif
+
+# GTK and QT interfaces are broken in this version
#
#.if defined(WITH_QT)
#CONFIGURE_ARGS+= --enable-ui=qt
@@ -49,53 +51,36 @@ USE_SDL= sdl
CONFIGURE_ARGS+= --enable-ui=x11
.endif
-.if defined(WITH_DEBUG)
-CONFIGURE_ARGS+= --enable-debug
+.if defined(WITH_OPTIMIZED_CFLAGS)
+CFLAGS+= -O3 -ffast-math
.else
-CONFIGURE_ARGS+= --disable-debug
+CONFIGURE_ARGS+= --disable-fpo
.endif
-.include <bsd.port.pre.mk>
-
-.if ${ARCH} == "ia64"
-BROKEN= Internal compiler error on ia64
+.if defined(WITH_DEBUG)
+CONFIGURE_ARGS+= --enable-profiling # implies --enable-debug
.endif
-# jitc_x86 is avaible only on x86
-.if ${ARCH} == "i386"
-BUILD_DEPENDS+= nasm:${PORTSDIR}/devel/nasm
-.if !defined(WITH_JITC)
-CONFIGURE_ARGS+= --enable-cpu=generic
-.else
+.if defined(WITH_JITC) && ${ARCH} == "i386"
+BUILD_DEPENDS= nasm:${PORTSDIR}/devel/nasm
CONFIGURE_ARGS+= --enable-cpu=jitc_x86
-.endif # WITH_JITC
.else
CONFIGURE_ARGS+= --enable-cpu=generic
.endif
-pre-everything::
-.if !defined(WITH_OPTIMIZED_CFLAGS)
- @${ECHO_MSG} ""
- @${ECHO_MSG} "You can do optimized build defining WITH_OPTIMIZED_CFLAGS=yes."
- @${ECHO_MSG} ""
-.endif
-
post-extract:
@${REINPLACE_CMD} -e 's|-g -O2||;s|-O2||' ${WRKSRC}/configure
-
-pre-configure:
-.if ${OSVERSION} > 700000
- @${REINPLACE_CMD} -e 's|clock_settime\ ()|foobar()|' ${WRKSRC}/configure
-.endif
-
-post-configure:
- @${REINPLACE_CMD} -e 's|-lpthread|${PTHREAD_LIBS}|g' ${WRKSRC}/Makefile
- @${REINPLACE_CMD} -e 's|-lpthread|${PTHREAD_LIBS}|g' ${WRKSRC}/src/Makefile
+ @${REINPLACE_CMD} -e 's|PROCESS_CPUTIME|THREAD_CPUTIME|' \
+ ${WRKSRC}/src/system/osapi/posix/systimer.cc
+ @${REINPLACE_CMD} -e 's|video\.x"|${DATADIR}/&|' \
+ ${WRKSRC}/ppccfg.example
post-install:
@${MKDIR} ${DATADIR}
- @${INSTALL_DATA} ${WRKSRC}/video.x ${DATADIR}/video.x
+ ${INSTALL_DATA} ${WRKSRC}/video.x ${DATADIR}
+ ${INSTALL_DATA} ${WRKSRC}/ppccfg.example ${PREFIX}/etc
+ @${ECHO_CMD}
@${CAT} ${PKGMESSAGE}
- @${INSTALL_DATA} ${WRKSRC}/ppccfg.example ${PREFIX}/etc/ppccfg.example
+ @${ECHO_CMD}
.include <bsd.port.post.mk>
diff --git a/emulators/pearpc/files/pkg-message.in b/emulators/pearpc/files/pkg-message.in
index 289c514d67ae..858e210434af 100644
--- a/emulators/pearpc/files/pkg-message.in
+++ b/emulators/pearpc/files/pkg-message.in
@@ -1,3 +1 @@
-
-Sample config file can be found at %%PREFIX%%/etc/ppccfg.example
-
+Sample configuration file is installed as %%PREFIX%%/etc/ppccfg.example