aboutsummaryrefslogtreecommitdiff
path: root/emulators/pipelight
diff options
context:
space:
mode:
authorKris Moore <kmoore@FreeBSD.org>2014-07-24 21:13:31 +0000
committerKris Moore <kmoore@FreeBSD.org>2014-07-24 21:13:31 +0000
commit14f1f1dedf6b1bda363d2ff21581bb438c3958ef (patch)
treec50474204d935142190b6b34b4cbad8cd42fa77c /emulators/pipelight
parentdeff4ba4c785691afa91b27a74d3711bca333fad (diff)
Notes
Diffstat (limited to 'emulators/pipelight')
-rw-r--r--emulators/pipelight/Makefile17
-rw-r--r--emulators/pipelight/distinfo8
-rw-r--r--emulators/pipelight/files/patch-src_windows_Makefile18
-rw-r--r--emulators/pipelight/files/patch-src_winecheck_Makefile18
4 files changed, 16 insertions, 45 deletions
diff --git a/emulators/pipelight/Makefile b/emulators/pipelight/Makefile
index cbe416294806..06910946e118 100644
--- a/emulators/pipelight/Makefile
+++ b/emulators/pipelight/Makefile
@@ -2,11 +2,14 @@
# $FreeBSD$
PORTNAME= pipelight
-DISTVERSION= 0.2.7.1
-PORTREVISION= 1
+DISTVERSION= 0.2.7.3
CATEGORIES= emulators
-MASTER_SITES= https://bitbucket.org/mmueller2012/pipelight/get/
+MASTER_SITES= https://bitbucket.org/mmueller2012/pipelight/get/ \
+ http://repos.fds-team.de/pluginloader/v${DISTVERSION}/:plg
DISTNAME= v${DISTVERSION}
+DISTFILES= ${DISTNAME}${EXTRACT_SUFX} pluginloader.tar.gz:plg pluginloader.tar.gz.sig:plg
+DIST_SUBDIR= pipelight
+EXTRACT_ONLY= ${DISTNAME}${EXTRACT_SUFX}
MAINTAINER= kmoore@FreeBSD.org
COMMENT= Wrapper for using windows plugins in web browsers
@@ -24,7 +27,7 @@ RUN_DEPENDS= ${LOCALBASE}/bin/bash:${PORTSDIR}/shells/bash \
${LOCALBASE}/bin/flock:${PORTSDIR}/sysutils/flock \
${LOCALBASE}/bin/gpg2:${PORTSDIR}/security/gnupg
-WRKSRC= ${WRKDIR}/mmueller2012-pipelight-e2362eb15df6
+WRKSRC= ${WRKDIR}/mmueller2012-pipelight-79b1b7ba0032
USE_GCC= 4.7+
USE_LDCONFIG= yes
CPPFLAGS+= -I${LOCALBASE}/include
@@ -33,6 +36,7 @@ GNU_CONFIGURE= yes
CONFIGURE_ARGS+=--verbose --wine-path=${LOCALBASE}/bin/wine --win32-prebuilt \
--win64-prebuilt --moz-plugin-path=${LOCALBASE}/lib/browser_plugins \
--cxx=${CXX}
+USE_XORG= x11
USES= compiler:gcc-c++11-lib gmake
MAKE_JOBS_UNSAFE=yes
@@ -47,8 +51,7 @@ RUN_DEPENDS+= ${LOCALBASE}/bin/wine:${PORTSDIR}/emulators/i386-wine-devel
.endif
pre-configure:
- ${REINPLACE_CMD} "s|DISTVERSION|v${DISTVERSION}|g" ${WRKSRC}/src/windows/Makefile
- ${REINPLACE_CMD} "s|DISTVERSION|v${DISTVERSION}|g" ${WRKSRC}/src/winecheck/Makefile
- ${REINPLACE_CMD} "s|/share/man/man1|/man/man1|g" ${WRKSRC}/Makefile
+ @${LN} -s ${DISTDIR}/pluginloader.tar.gz ${WRKSRC}/pluginloader-v${DISTVERSION}.tar.gz
+ @${LN} -s ${DISTDIR}/pluginloader.tar.gz.sig ${WRKSRC}/pluginloader-v${DISTVERSION}.tar.gz.sig
.include <bsd.port.post.mk>
diff --git a/emulators/pipelight/distinfo b/emulators/pipelight/distinfo
index 223496e315cc..b8ea1365b497 100644
--- a/emulators/pipelight/distinfo
+++ b/emulators/pipelight/distinfo
@@ -1,2 +1,6 @@
-SHA256 (v0.2.7.1.tar.gz) = 48d0a245d53e045bc9e45dee0e124b3ec4dd9ebd30b3fbac2f787cbe0a46b9b2
-SIZE (v0.2.7.1.tar.gz) = 145063
+SHA256 (pipelight/v0.2.7.3.tar.gz) = db4585f44874c0b647e7cf611b5bf8efe308fe11573891cd74dd4fa5867e2e52
+SIZE (pipelight/v0.2.7.3.tar.gz) = 161967
+SHA256 (pipelight/pluginloader.tar.gz) = 015c6b73accb5319b5006b208dfea9b7c768f84faf40bb80676312a650967e6a
+SIZE (pipelight/pluginloader.tar.gz) = 423396
+SHA256 (pipelight/pluginloader.tar.gz.sig) = 66c08ab5b6105e8fe2fb1f604d0958e264e2796ac2310dd19827736c1aa8e816
+SIZE (pipelight/pluginloader.tar.gz.sig) = 543
diff --git a/emulators/pipelight/files/patch-src_windows_Makefile b/emulators/pipelight/files/patch-src_windows_Makefile
deleted file mode 100644
index 0a2d358732fb..000000000000
--- a/emulators/pipelight/files/patch-src_windows_Makefile
+++ /dev/null
@@ -1,18 +0,0 @@
---- src/windows/Makefile.orig 2014-07-08 12:59:29.874833483 -0400
-+++ src/windows/Makefile 2014-07-08 12:59:41.826832843 -0400
-@@ -11,7 +11,7 @@
- all: pluginloader$(suffix).exe
-
- ifeq ($(wildcard pluginloader$(suffix).exe),)
--commit=$(shell git log --pretty=format:'%H' -n 1 || echo "prebuilt")
-+commit=DISTVERSION
-
- ../../pluginloader-$(commit).tar.gz:
- $(downloader) "../../pluginloader-$(commit).tar.gz" "http://repos.fds-team.de/pluginloader/$(commit)/pluginloader.tar.gz"
-@@ -67,4 +67,4 @@
- clean:
- rm -f *.exe *.exe.so *.o
-
--endif
-\ No newline at end of file
-+endif
diff --git a/emulators/pipelight/files/patch-src_winecheck_Makefile b/emulators/pipelight/files/patch-src_winecheck_Makefile
deleted file mode 100644
index 2da386d6e534..000000000000
--- a/emulators/pipelight/files/patch-src_winecheck_Makefile
+++ /dev/null
@@ -1,18 +0,0 @@
---- src/winecheck/Makefile.orig 2014-07-08 13:07:29.409800544 -0400
-+++ src/winecheck/Makefile 2014-07-08 13:07:37.139799764 -0400
-@@ -10,7 +10,7 @@
- all: winecheck$(suffix).exe
-
- ifeq ($(wildcard winecheck$(suffix).exe),)
--commit=$(shell git log --pretty=format:'%H' -n 1 || echo "prebuilt")
-+commit=DISTVERSION
-
- ../../pluginloader-$(commit).tar.gz:
- $(downloader) "../../pluginloader-$(commit).tar.gz" "http://repos.fds-team.de/pluginloader/$(commit)/pluginloader.tar.gz"
-@@ -52,4 +52,4 @@
- clean:
- rm -f *.exe *.exe.so *.o
-
--endif
-\ No newline at end of file
-+endif