aboutsummaryrefslogtreecommitdiff
path: root/emulators/psim-freebsd/Makefile
diff options
context:
space:
mode:
authorDavid E. O'Brien <obrien@FreeBSD.org>2001-10-12 21:42:54 +0000
committerDavid E. O'Brien <obrien@FreeBSD.org>2001-10-12 21:42:54 +0000
commit7f3526b91897d9b4cb79c2ad540ff7b2fcf5db69 (patch)
tree87a5341607b07161415b288cec64d81098865f78 /emulators/psim-freebsd/Makefile
parent10b84eefce333975503e01b4fae082af1c5c3ff2 (diff)
downloadports-7f3526b91897d9b4cb79c2ad540ff7b2fcf5db69.tar.gz
ports-7f3526b91897d9b4cb79c2ad540ff7b2fcf5db69.zip
Notes
Diffstat (limited to 'emulators/psim-freebsd/Makefile')
-rw-r--r--emulators/psim-freebsd/Makefile43
1 files changed, 43 insertions, 0 deletions
diff --git a/emulators/psim-freebsd/Makefile b/emulators/psim-freebsd/Makefile
new file mode 100644
index 000000000000..d6f36485ba20
--- /dev/null
+++ b/emulators/psim-freebsd/Makefile
@@ -0,0 +1,43 @@
+# ex:ts=8
+# Ports collection makefile for: GDB 5.1 PowerPC simulator
+# Date created: 12 October 2001
+# Whom: Mark Peek <mp@FreeBSD.org>
+# David O'Brien <obrien@NUXI.com>
+# $FreeBSD$
+#
+
+SNAPDATE= 2001-10-12
+SNAPVER= ${SNAPDATE:S/-//g}
+
+PORTNAME= psim-freebsd
+PORTVERSION= ${SNAPVER}
+CATEGORIES= emulators
+MASTER_SITES= ${MASTER_SITE_SOURCEWARE}
+MASTER_SITE_SUBDIR= gdb/snapshots
+DISTNAME= gdb+dejagnu-${SNAPVER}
+
+MAINTAINER= mp@FreeBSD.org
+
+USE_BZIP2= yes
+
+.include <bsd.port.pre.mk>
+
+USE_GMAKE= yes
+GNU_CONFIGURE= yes
+CONFIGURE_TARGET= ${ARCH}-portbld-freebsd${OSREL}
+CONFIGURE_ARGS= --enable-psim --target=powerpc-freebsd-elf --program-suffix=psim
+
+pre-configure:
+ cd ${WRKSRC} ; ${RM} -rf dejagnu expect tcl texinfo
+
+do-install:
+ ${INSTALL_PROGRAM} ${WRKSRC}/gdb/gdb ${PREFIX}/bin/${PORTNAME}
+ ${MKDIR} ${PREFIX}/share/examples/${PORTNAME}
+ ${INSTALL_DATA} ${FILESDIR}/dot.gdbinit \
+ ${PREFIX}/share/examples/${PORTNAME}
+.if !defined(NOPORTDOCS)
+ @${MKDIR} ${DOCSDIR}
+ ${INSTALL_DATA} ${FILESDIR}/HOW-TO ${DOCSDIR}
+.endif
+
+.include <bsd.port.post.mk>