aboutsummaryrefslogtreecommitdiff
path: root/emulators/qemu-devel/Makefile
diff options
context:
space:
mode:
authorNorikatsu Shigemura <nork@FreeBSD.org>2005-05-01 07:39:11 +0000
committerNorikatsu Shigemura <nork@FreeBSD.org>2005-05-01 07:39:11 +0000
commit12b9c1f2e37d240a7e6efa6085bd868893063753 (patch)
tree9aade102f3af81161e22c7dba39ab8d4c3abcdf5 /emulators/qemu-devel/Makefile
parent3a7a219d74e851b676e5088b4d3093bf084082e2 (diff)
downloadports-12b9c1f2e37d240a7e6efa6085bd868893063753.tar.gz
ports-12b9c1f2e37d240a7e6efa6085bd868893063753.zip
Notes
Diffstat (limited to 'emulators/qemu-devel/Makefile')
-rw-r--r--emulators/qemu-devel/Makefile37
1 files changed, 26 insertions, 11 deletions
diff --git a/emulators/qemu-devel/Makefile b/emulators/qemu-devel/Makefile
index 4d27ba82553b..8d31b2da7e38 100644
--- a/emulators/qemu-devel/Makefile
+++ b/emulators/qemu-devel/Makefile
@@ -6,42 +6,57 @@
#
PORTNAME= qemu
-PORTVERSION= 0.6.2s.20050305
+PORTVERSION= 0.7.0
CATEGORIES= emulators
-MASTER_SITES= http://people.fruitsalad.org/nox/qemu/ \
- http://dad-answers.com/qemu/
-DISTNAME= ${PORTNAME}-snapshot-2005-03-05_23
+MASTER_SITES= http://www.qemu.org/
MAINTAINER= nox@jelal.kn-bremen.de
COMMENT= QEMU CPU Emulator
BUILD_DEPENDS+= texi2html:${PORTSDIR}/textproc/texi2html
+.if defined(WITH_SAMBA)
RUN_DEPENDS+= ${LOCALBASE}/sbin/smbd:${PORTSDIR}/net/samba
+.endif
HAS_CONFIGURE= yes
-USE_BZIP2= yes
USE_GMAKE= yes
USE_GETOPT_LONG= yes
USE_SDL= sdl
USE_PERL5= yes
PATCH_STRIP= -p1
-CONFIGURE_ARGS+= --prefix=${PREFIX} --cc=${CC}\ -I${PREFIX}/include
+CONFIGURE_ARGS+= --prefix=${PREFIX} --cc=${CC}
+MAKE_ENV+= BSD_MAKE=${MAKE}
MAN1= qemu.1 qemu-img.1
-ONLY_FOR_ARCHS= i386 amd64 powerpc
+ONLY_FOR_ARCHS= amd64 i386
# gcc34 (system cc on 5.x now) has problems with qemu on amd64
# (doesnt build target-i386/op.c), try the one in ports which is newer
.include <bsd.port.pre.mk>
-.if ${ARCH} == "amd64" && ${OSVERSION} >= 502126
-BROKEN= Does not compile
-CC= gcc34
-CXX= g++34
+.if ${ARCH} == "amd64"
+ARCH= x86_64
+.if ${OSVERSION} >= 502126
BUILD_DEPENDS+= gcc34:${PORTSDIR}/lang/gcc34
GCCVERSION= 030402
+CC= gcc34
.else
USE_GCC= 3.4
.endif
+.else
+USE_GCC= 3.4
+.endif
+
+pre-everything::
+.if !defined(WITH_SAMBA) && !exists(${LOCALBASE}/sbin/smbd)
+ @${ECHO_MSG} "Notice: if you need qemu's -smb option (smb-export local dir to guest)"
+ @${ECHO_MSG} "then you also need samba, you can have this port install it by defining"
+ @${ECHO_MSG} "WITH_SAMBA."
+.endif
+
+pre-patch:
+ @for A in ${ONLY_FOR_ARCHS}; do \
+ ${MKDIR} ${WRKSRC}/bsd/$$A; \
+ done
post-install:
@${CAT} ${PKGMESSAGE}