aboutsummaryrefslogtreecommitdiff
path: root/emulators/qemu-devel
diff options
context:
space:
mode:
authorJuergen Lock <nox@FreeBSD.org>2010-04-11 11:42:38 +0000
committerJuergen Lock <nox@FreeBSD.org>2010-04-11 11:42:38 +0000
commit7052bc7d68fe9056e0372a6f918e4b1ef7cfa5af (patch)
treec888f37f7377b46c9e011cfb6d56645ecb68d9fd /emulators/qemu-devel
parentfaa8117bee53c62bf7773d862963a411988e4b3c (diff)
downloadports-7052bc7d68fe9056e0372a6f918e4b1ef7cfa5af.tar.gz
ports-7052bc7d68fe9056e0372a6f918e4b1ef7cfa5af.zip
Notes
Diffstat (limited to 'emulators/qemu-devel')
-rw-r--r--emulators/qemu-devel/Makefile8
1 files changed, 8 insertions, 0 deletions
diff --git a/emulators/qemu-devel/Makefile b/emulators/qemu-devel/Makefile
index 68aa7e8ec82f..4b525220f59d 100644
--- a/emulators/qemu-devel/Makefile
+++ b/emulators/qemu-devel/Makefile
@@ -7,6 +7,7 @@
PORTNAME= qemu
PORTVERSION= 0.12.3
+PORTREVISION= 1
CATEGORIES= emulators
MASTER_SITES= ${MASTER_SITE_SAVANNAH}:release \
${MASTER_SITE_LOCAL}:snapshot \
@@ -33,6 +34,7 @@ OPTIONS= RTL8139_TIMER "allow use of re(4) nic with FreeBSD guests" Off \
SAMBA "samba dependency (for -smb)" Off \
SDL "SDL/X dependency (graphical output)" On \
GNUTLS "gnutls dependency (vnc encryption)" On \
+ CURL "libcurl dependency (remote images)" On \
PCAP "pcap dependency (networking with bpf)" On \
CDROM_DMA "IDE CDROM DMA" On \
ADD_AUDIO "Emulate more audio hardware (experimental!)" Off \
@@ -63,6 +65,12 @@ CONFIGURE_ARGS+= --disable-vnc-tls
LIB_DEPENDS+= gnutls:${PORTSDIR}/security/gnutls
.endif
+.if defined(WITHOUT_CURL)
+CONFIGURE_ARGS+= --disable-curl
+.else
+LIB_DEPENDS+= curl:${PORTSDIR}/ftp/curl
+.endif
+
.if defined(WITH_PCAP)
CONFIGURE_ARGS+= --enable-pcap
.endif