aboutsummaryrefslogtreecommitdiff
path: root/emulators/qemu-devel
diff options
context:
space:
mode:
authorSam Lawrance <lawrance@FreeBSD.org>2005-12-03 03:18:40 +0000
committerSam Lawrance <lawrance@FreeBSD.org>2005-12-03 03:18:40 +0000
commit53d4bbec5b7cd0e79c925fa552901a710de6f099 (patch)
tree6062998e436b4601c4450e6d34286fccaad4d4f3 /emulators/qemu-devel
parent77b40c7d245a05260d3e6526746399d94bfe1fe7 (diff)
downloadports-53d4bbec5b7cd0e79c925fa552901a710de6f099.tar.gz
ports-53d4bbec5b7cd0e79c925fa552901a710de6f099.zip
Notes
Diffstat (limited to 'emulators/qemu-devel')
-rw-r--r--emulators/qemu-devel/Makefile5
-rw-r--r--emulators/qemu-devel/distinfo4
-rw-r--r--emulators/qemu-devel/files/patch-qemu-img.c10
-rw-r--r--emulators/qemu-devel/files/patch-qemu-img.texi19
-rw-r--r--emulators/qemu-devel/files/patch-vl.c11
-rw-r--r--emulators/qemu-devel/pkg-message2
-rw-r--r--emulators/qemu-devel/pkg-plist1
7 files changed, 35 insertions, 17 deletions
diff --git a/emulators/qemu-devel/Makefile b/emulators/qemu-devel/Makefile
index 5d3aa818f63c..80883177eb4c 100644
--- a/emulators/qemu-devel/Makefile
+++ b/emulators/qemu-devel/Makefile
@@ -6,14 +6,13 @@
#
PORTNAME= qemu
-PORTVERSION= 0.7.2s.20051112
-PORTREVISION= 0
+PORTVERSION= 0.7.2s.20051130
CATEGORIES= emulators
MASTER_SITES= http://www.qemu.org/:release \
http://people.fruitsalad.org/nox/qemu/:snapshot \
http://www.volny.cz/xnavara/qemu/:snapshot \
http://qemu.dad-answers.com/download/qemu/:snapshot
-DISTNAME= ${PORTNAME}-snapshot-2005-11-12_23
+DISTNAME= ${PORTNAME}-snapshot-2005-11-30_23
DISTFILES= ${DISTNAME}${EXTRACT_SUFX}:snapshot
MAINTAINER= nox@jelal.kn-bremen.de
diff --git a/emulators/qemu-devel/distinfo b/emulators/qemu-devel/distinfo
index 67275c763f8b..79f4d019bf5e 100644
--- a/emulators/qemu-devel/distinfo
+++ b/emulators/qemu-devel/distinfo
@@ -1,2 +1,2 @@
-MD5 (qemu-snapshot-2005-11-12_23.tar.bz2) = 27673ed3a6bc78b4be2933ddc63f8276
-SIZE (qemu-snapshot-2005-11-12_23.tar.bz2) = 1219984
+MD5 (qemu-snapshot-2005-11-30_23.tar.bz2) = 40b6eca5be9c491aafa6c1edea750835
+SIZE (qemu-snapshot-2005-11-30_23.tar.bz2) = 1241259
diff --git a/emulators/qemu-devel/files/patch-qemu-img.c b/emulators/qemu-devel/files/patch-qemu-img.c
new file mode 100644
index 000000000000..b525b50a3bcb
--- /dev/null
+++ b/emulators/qemu-devel/files/patch-qemu-img.c
@@ -0,0 +1,10 @@
+Index: qemu/qemu-img.c
+@@ -134,7 +134,7 @@
+ "Command syntax:\n"
+ " create [-e] [-b base_image] [-f fmt] filename [size]\n"
+ " commit [-f fmt] filename\n"
+- " convert [-c] [-e] [-f fmt] filename [-O output_fmt] output_filename\n"
++ " convert [-c] [-e] [-f fmt] [-O output_fmt] filename output_filename\n"
+ " info [-f fmt] filename\n"
+ "\n"
+ "Command parameters:\n"
diff --git a/emulators/qemu-devel/files/patch-qemu-img.texi b/emulators/qemu-devel/files/patch-qemu-img.texi
new file mode 100644
index 000000000000..79693026dd2d
--- /dev/null
+++ b/emulators/qemu-devel/files/patch-qemu-img.texi
@@ -0,0 +1,19 @@
+Index: qemu/qemu-img.texi
+@@ -10,7 +10,7 @@
+ @table @option
+ @item create [-e] [-b @var{base_image}] [-f @var{fmt}] @var{filename} [@var{size}]
+ @item commit [-f @var{fmt}] @var{filename}
+-@item convert [-c] [-e] [-f @var{fmt}] @var{filename} [-O @var{output_fmt}] @var{output_filename}
++@item convert [-c] [-e] [-f @var{fmt}] [-O @var{output_fmt}] @var{filename} @var{output_filename}
+ @item info [-f @var{fmt}] @var{filename}
+ @end table
+
+@@ -83,7 +83,7 @@
+
+ Commit the changes recorded in @var{filename} in its base image.
+
+-@item convert [-c] [-e] [-f @var{fmt}] @var{filename} [-O @var{output_fmt}] @var{output_filename}
++@item convert [-c] [-e] [-f @var{fmt}] [-O @var{output_fmt}] @var{filename} @var{output_filename}
+
+ Convert the disk image @var{filename} to disk image @var{output_filename}
+ using format @var{output_fmt}. It can be optionnaly encrypted
diff --git a/emulators/qemu-devel/files/patch-vl.c b/emulators/qemu-devel/files/patch-vl.c
index 5eff6568373b..adf052460e28 100644
--- a/emulators/qemu-devel/files/patch-vl.c
+++ b/emulators/qemu-devel/files/patch-vl.c
@@ -1,16 +1,5 @@
--- vl.c.orig Mon Nov 14 15:55:56 2005
+++ vl.c Mon Nov 14 15:57:25 2005
-@@ -40,6 +40,10 @@
- #include <sys/socket.h>
- #include <netinet/in.h>
- #include <dirent.h>
-+#ifdef __FreeBSD__
-+#include <sys/types.h>
-+#include <libutil.h>
-+#endif
- #ifdef _BSD
- #include <sys/stat.h>
- #ifndef __APPLE__
@@ -1363,7 +1367,7 @@
return chr;
}
diff --git a/emulators/qemu-devel/pkg-message b/emulators/qemu-devel/pkg-message
index 6def407a9fa1..4728b9171ccb 100644
--- a/emulators/qemu-devel/pkg-message
+++ b/emulators/qemu-devel/pkg-message
@@ -25,7 +25,7 @@ port/package installed in addition to qemu.
(see kern/84102, http://www.freebsd.org/cgi/query-pr.cgi?pr=kern/84102),
using a kernel without PREEMPTION has been reported to fix this problem.
(or do an ftp install instead of installing from the emulated cdrom, and
-then make a new kernel.) [now fixed in cvs.]
+then make a new kernel.) [fixed since 6.0-R.]
- 6.0-RC1 was released with an ed driver that doesn't like qemu's emulated
RTL8029 nic, this has been fixed in the meantime but if for some reason
you need to use that version as a guest you can temporarily add the patch
diff --git a/emulators/qemu-devel/pkg-plist b/emulators/qemu-devel/pkg-plist
index 791a15c2cd13..8a97a757277b 100644
--- a/emulators/qemu-devel/pkg-plist
+++ b/emulators/qemu-devel/pkg-plist
@@ -1,5 +1,6 @@
bin/qemu
bin/qemu-img
+bin/qemu-system-arm
bin/qemu-system-mips
bin/qemu-system-ppc
bin/qemu-system-sparc