aboutsummaryrefslogtreecommitdiff
path: root/emulators/qemu-devel
diff options
context:
space:
mode:
authorJuergen Lock <nox@FreeBSD.org>2013-12-30 22:24:45 +0000
committerJuergen Lock <nox@FreeBSD.org>2013-12-30 22:24:45 +0000
commit150b789f3251eef3d123d2679de50c9ab79f626b (patch)
treedcb9c7cd78bb1383f5496f95183e43ba5de45b75 /emulators/qemu-devel
parentcd80c7bb533b7954e16baf5683e72a44ea3934de (diff)
downloadports-150b789f3251eef3d123d2679de50c9ab79f626b.tar.gz
ports-150b789f3251eef3d123d2679de50c9ab79f626b.zip
Notes
Diffstat (limited to 'emulators/qemu-devel')
-rw-r--r--emulators/qemu-devel/Makefile43
-rw-r--r--emulators/qemu-devel/distinfo40
-rw-r--r--emulators/qemu-devel/files/patch-Makefile16
-rw-r--r--emulators/qemu-devel/files/patch-configure36
-rw-r--r--emulators/qemu-devel/files/patch-cpu-exec.c13
-rw-r--r--emulators/qemu-devel/files/pcap-patch16
-rw-r--r--emulators/qemu-devel/files/prepatch-configure10
-rw-r--r--emulators/qemu-devel/pkg-plist3
8 files changed, 119 insertions, 58 deletions
diff --git a/emulators/qemu-devel/Makefile b/emulators/qemu-devel/Makefile
index ad7dad7c9e5c..583c1c499609 100644
--- a/emulators/qemu-devel/Makefile
+++ b/emulators/qemu-devel/Makefile
@@ -2,8 +2,7 @@
# $FreeBSD$
PORTNAME= qemu
-PORTVERSION= 1.6.1
-PORTREVISION= 1
+PORTVERSION= 1.7.0
CATEGORIES= emulators
MASTER_SITES= http://wiki.qemu.org/download/:release \
LOCAL/nox:snapshot
@@ -29,7 +28,7 @@ ONLY_FOR_ARCHS= amd64 i386 powerpc powerpc64 # XXX someone wants to debug sparc6
CONFLICTS_INSTALL= qemu-[0-9]*
OPTIONS_DEFINE= SAMBA X11 GTK2 OPENGL GNUTLS SASL JPEG PNG CURL \
- CDROM_DMA PCAP USBREDIR GNS3 X86_TARGETS \
+ CDROM_DMA PCAP USBREDIR GNS3 X86_TARGETS BSD_USER \
STATIC_LINK DOCS
SAMBA_DESC= samba dependency (for -smb)
GNUTLS_DESC= gnutls dependency (vnc encryption)
@@ -50,16 +49,40 @@ NO_STAGE= yes
.include <bsd.port.options.mk>
+.if ${PORT_OPTIONS:MBSD_USER}
+PATCH_SITES= http://people.freebsd.org/~sson/qemu/qemu-bsd-user/
+PATCHFILES= \
+ 0001-bsd-user-refresh-freebsd-system-call-numbers.patch \
+ 0002-bsd-user-add-HOST_VARIANT_DIR-for-various-BSD-depend.patch \
+ 0003-bsd-user-move-strace-OS-arch-dependent-code-to-host-.patch \
+ 0004-bsd-user-move-arch-OS-dependent-code-out-of-main.c.patch \
+ 0005-bsd-user-move-arch-OS-dependent-code-out-of-syscall..patch \
+ 0006-bsd-user-add-support-for-freebsd-time-related-system.patch \
+ 0007-bsd-user-add-support-for-freebsd-signal-related-syst.patch \
+ 0008-bsd-user-move-arch-OS-dependent-code-out-of-elfload..patch \
+ 0009-bsd-user-add-support-for-freebsd-process-related-sys.patch \
+ 0010-bsd-user-add-support-for-file-system-related-system-.patch \
+ 0011-bsd-user-add-support-for-stat-dir-and-fcntl-related-.patch \
+ 0012-bsd-user-add-support-for-memory-management-related-s.patch \
+ 0013-bsd-user-add-support-for-socket-related-system-calls.patch \
+ 0014-bsd-user-add-support-for-thread-related-system-calls.patch \
+ 0015-bsd-user-add-support-for-the-ioctl-system-call.patch \
+ 0016-bsd-user-add-support-for-extattr-and-ACL-related-sys.patch \
+ 0017-bsd-user-add-support-for-miscellaneous-system-calls.patch \
+ 0018-bsd-user-add-arm-mips-and-mips64-options-to-configur.patch
+PATCH_DIST_STRIP= -p1
+.endif
+
CONFIGURE_ARGS+= --extra-ldflags=-L${LOCALBASE}/lib
-CONFIGURE_ARGS+= --disable-smartcard-nss
+CONFIGURE_ARGS+= --disable-smartcard-nss --disable-libssh2
PORTDOCS= docs qemu-doc.html qemu-tech.html qmp-commands.txt
.if ${PORT_OPTIONS:MX86_TARGETS}
.if ${PORT_OPTIONS:MBSD_USER}
.if ${ARCH} != "amd64"
-CONFIGURE_ARGS+= --enable-nptl --target-list=i386-softmmu,x86_64-softmmu,i386-bsd-user,sparc-bsd-user,arm-bsd-user,armeb-bsd-user,mips-bsd-user,mipsel-bsd-user
+CONFIGURE_ARGS+= --target-list=i386-softmmu,x86_64-softmmu,i386-bsd-user,sparc-bsd-user,arm-bsd-user,mips-bsd-user,mipsel-bsd-user
.else
-CONFIGURE_ARGS+= --enable-nptl --target-list=i386-softmmu,x86_64-softmmu,i386-bsd-user,x86_64-bsd-user,sparc-bsd-user,sparc64-bsd-user,arm-bsd-user,armeb-bsd-user,mips-bsd-user,mipsel-bsd-user,mips64-bsd-user
+CONFIGURE_ARGS+= --target-list=i386-softmmu,x86_64-softmmu,i386-bsd-user,x86_64-bsd-user,sparc-bsd-user,sparc64-bsd-user,arm-bsd-user,mips-bsd-user,mipsel-bsd-user,mips64-bsd-user,mips64el-bsd-user
.endif
.else
CONFIGURE_ARGS+= --target-list=i386-softmmu,x86_64-softmmu
@@ -68,9 +91,8 @@ CONFIGURE_ARGS+= --target-list=i386-softmmu,x86_64-softmmu
.if empty(PORT_OPTIONS:MBSD_USER)
CONFIGURE_ARGS+= --disable-bsd-user
.else
-CONFIGURE_ARGS+= --enable-nptl
.if ${ARCH} != "amd64"
-CONFIGURE_ARGS+= --target-list=i386-softmmu,x86_64-softmmu,alpha-softmmu,arm-softmmu,cris-softmmu,lm32-softmmu,m68k-softmmu,microblaze-softmmu,microblazeel-softmmu,mips-softmmu,mipsel-softmmu,mips64-softmmu,mips64el-softmmu,or32-softmmu,ppc-softmmu,ppcemb-softmmu,ppc64-softmmu,sh4-softmmu,sh4eb-softmmu,sparc-softmmu,sparc64-softmmu,s390x-softmmu,xtensa-softmmu,xtensaeb-softmmu,unicore32-softmmu,moxie-softmmu,i386-bsd-user,sparc-bsd-user,arm-bsd-user,armeb-bsd-user,mips-bsd-user,mipsel-bsd-user
+CONFIGURE_ARGS+= --target-list=i386-softmmu,x86_64-softmmu,alpha-softmmu,arm-softmmu,cris-softmmu,lm32-softmmu,m68k-softmmu,microblaze-softmmu,microblazeel-softmmu,mips-softmmu,mipsel-softmmu,mips64-softmmu,mips64el-softmmu,or32-softmmu,ppc-softmmu,ppcemb-softmmu,ppc64-softmmu,sh4-softmmu,sh4eb-softmmu,sparc-softmmu,sparc64-softmmu,s390x-softmmu,xtensa-softmmu,xtensaeb-softmmu,unicore32-softmmu,moxie-softmmu,i386-bsd-user,sparc-bsd-user,arm-bsd-user,mips-bsd-user,mipsel-bsd-user
.endif
.endif
.endif
@@ -218,6 +240,11 @@ MAKE_ENV+= COMPILER_PATH=${LOCALBASE}/bin
CONFIGURE_ARGS+= --python=${PYTHON_CMD}
+.if ${PORT_OPTIONS:MBSD_USER}
+pre-patch:
+ @cd ${WRKSRC} && ${PATCH} --quiet < ${FILESDIR}/prepatch-configure
+.endif
+
# -lprocstat actually only _needs_ -lelf after r249666 or r250870 (MFC)
# but it shouldn't matter much
post-patch:
diff --git a/emulators/qemu-devel/distinfo b/emulators/qemu-devel/distinfo
index 79e4d3716b59..c2dae7aa36b5 100644
--- a/emulators/qemu-devel/distinfo
+++ b/emulators/qemu-devel/distinfo
@@ -1,2 +1,38 @@
-SHA256 (qemu/1.6.1/qemu-1.6.1.tar.bz2) = fc736f44aa10478223c881310a7e40fc8386547e9cadf7d01ca4685951605294
-SIZE (qemu/1.6.1/qemu-1.6.1.tar.bz2) = 12041317
+SHA256 (qemu/1.7.0/qemu-1.7.0.tar.bz2) = 31f333a85f2d14c605a77679904a9668eaeb1b6dc7da53a1665230f46bc21314
+SIZE (qemu/1.7.0/qemu-1.7.0.tar.bz2) = 12248954
+SHA256 (qemu/1.7.0/0001-bsd-user-refresh-freebsd-system-call-numbers.patch) = 15fa3f286ae03636c9340de0b44ec4fc47e428025f103382a578029db45ec252
+SIZE (qemu/1.7.0/0001-bsd-user-refresh-freebsd-system-call-numbers.patch) = 36542
+SHA256 (qemu/1.7.0/0002-bsd-user-add-HOST_VARIANT_DIR-for-various-BSD-depend.patch) = 021f8c1fdba448c8eeb7a9f8035b8a47b1f463a59ee7da60d733bd63c2924b13
+SIZE (qemu/1.7.0/0002-bsd-user-add-HOST_VARIANT_DIR-for-various-BSD-depend.patch) = 2730
+SHA256 (qemu/1.7.0/0003-bsd-user-move-strace-OS-arch-dependent-code-to-host-.patch) = b0b08af1a4d6e7e660290c9f0293d7ad486c51df8fce29abed9db76143317d8a
+SIZE (qemu/1.7.0/0003-bsd-user-move-strace-OS-arch-dependent-code-to-host-.patch) = 50756
+SHA256 (qemu/1.7.0/0004-bsd-user-move-arch-OS-dependent-code-out-of-main.c.patch) = 184336d1e8a6fabfa4fc6043603ab4f373d1ae80aefd7c57ba23cc36038b81da
+SIZE (qemu/1.7.0/0004-bsd-user-move-arch-OS-dependent-code-out-of-main.c.patch) = 143116
+SHA256 (qemu/1.7.0/0005-bsd-user-move-arch-OS-dependent-code-out-of-syscall..patch) = 352b624cb09223a2c2df6281211719e20964829b5d776a18a8a0b5fe405ac9e3
+SIZE (qemu/1.7.0/0005-bsd-user-move-arch-OS-dependent-code-out-of-syscall..patch) = 44814
+SHA256 (qemu/1.7.0/0006-bsd-user-add-support-for-freebsd-time-related-system.patch) = fa6a24c90f451ba087964c3089b887cc97ef4aec66a251dd0b67279f66134737
+SIZE (qemu/1.7.0/0006-bsd-user-add-support-for-freebsd-time-related-system.patch) = 75063
+SHA256 (qemu/1.7.0/0007-bsd-user-add-support-for-freebsd-signal-related-syst.patch) = e4d78570ab787be5131a9336d06c51309a684a02b612099929f0bea728c99225
+SIZE (qemu/1.7.0/0007-bsd-user-add-support-for-freebsd-signal-related-syst.patch) = 100195
+SHA256 (qemu/1.7.0/0008-bsd-user-move-arch-OS-dependent-code-out-of-elfload..patch) = 6a5083c5257aea2da050cdf47a261b4e883a7b4e8a1410dd7dae4b1499f600c8
+SIZE (qemu/1.7.0/0008-bsd-user-move-arch-OS-dependent-code-out-of-elfload..patch) = 93309
+SHA256 (qemu/1.7.0/0009-bsd-user-add-support-for-freebsd-process-related-sys.patch) = 7e5e99ef2279c3023d21b9540eb9ad9355cd0010dd402cd60ab3abe6c40cb36f
+SIZE (qemu/1.7.0/0009-bsd-user-add-support-for-freebsd-process-related-sys.patch) = 60141
+SHA256 (qemu/1.7.0/0010-bsd-user-add-support-for-file-system-related-system-.patch) = 52f97f394b5c75778e4f003de1033896fdc07c235289a9e91a8771e75bb9fd18
+SIZE (qemu/1.7.0/0010-bsd-user-add-support-for-file-system-related-system-.patch) = 43516
+SHA256 (qemu/1.7.0/0011-bsd-user-add-support-for-stat-dir-and-fcntl-related-.patch) = 5d25f3363080806a939cc985c9866c409006b35840a81f8d3c74f2cb9451ed31
+SIZE (qemu/1.7.0/0011-bsd-user-add-support-for-stat-dir-and-fcntl-related-.patch) = 31292
+SHA256 (qemu/1.7.0/0012-bsd-user-add-support-for-memory-management-related-s.patch) = f9e39e7138ad8c995255a4300b6887fce468296f61467445d3d2438cb6e1a761
+SIZE (qemu/1.7.0/0012-bsd-user-add-support-for-memory-management-related-s.patch) = 37395
+SHA256 (qemu/1.7.0/0013-bsd-user-add-support-for-socket-related-system-calls.patch) = 3e9f586a7327424d449c5a7c9cd7a589d8b14091bbe860cfe00a518bd1f6800c
+SIZE (qemu/1.7.0/0013-bsd-user-add-support-for-socket-related-system-calls.patch) = 46894
+SHA256 (qemu/1.7.0/0014-bsd-user-add-support-for-thread-related-system-calls.patch) = f33d86896466ba39484715253ba9284d6c335b4e0e635150507bad63ef19e113
+SIZE (qemu/1.7.0/0014-bsd-user-add-support-for-thread-related-system-calls.patch) = 67546
+SHA256 (qemu/1.7.0/0015-bsd-user-add-support-for-the-ioctl-system-call.patch) = 90407a8e312ac5f4b3524cd5f65274baea49c4addf04a4614ce356e069983ab3
+SIZE (qemu/1.7.0/0015-bsd-user-add-support-for-the-ioctl-system-call.patch) = 77683
+SHA256 (qemu/1.7.0/0016-bsd-user-add-support-for-extattr-and-ACL-related-sys.patch) = b74903bfa42718edf4db21a2d746ab2c9548694c6dd6a270ea7c6885405505ec
+SIZE (qemu/1.7.0/0016-bsd-user-add-support-for-extattr-and-ACL-related-sys.patch) = 43940
+SHA256 (qemu/1.7.0/0017-bsd-user-add-support-for-miscellaneous-system-calls.patch) = 6238ab7325c95b64544e7e72e7c45e44d4625a2e64851248dbb621b86ac7ed0d
+SIZE (qemu/1.7.0/0017-bsd-user-add-support-for-miscellaneous-system-calls.patch) = 58081
+SHA256 (qemu/1.7.0/0018-bsd-user-add-arm-mips-and-mips64-options-to-configur.patch) = 694159e25187159709d449741446cc3218d31ea7eee47dde4946e8505d48a798
+SIZE (qemu/1.7.0/0018-bsd-user-add-arm-mips-and-mips64-options-to-configur.patch) = 2341
diff --git a/emulators/qemu-devel/files/patch-Makefile b/emulators/qemu-devel/files/patch-Makefile
index 87a365001ffc..3eba14264cf3 100644
--- a/emulators/qemu-devel/files/patch-Makefile
+++ b/emulators/qemu-devel/files/patch-Makefile
@@ -1,28 +1,28 @@
Index: qemu/Makefile
-@@ -53,7 +53,11 @@ LIBS+=-lz $(LIBS_TOOLS)
+@@ -65,7 +65,11 @@ LIBS+=-lz $(LIBS_TOOLS)
HELPERS-$(CONFIG_LINUX) = qemu-bridge-helper$(EXESUF)
ifdef BUILD_DOCS
+ifdef NOPORTDOCS
+DOCS=qemu.1 qemu-img.1 qemu-nbd.8
+else
- DOCS=qemu-doc.html qemu-tech.html qemu.1 qemu-img.1 qemu-nbd.8 QMP/qmp-commands.txt
+ DOCS=qemu-doc.html qemu-tech.html qemu.1 qemu-img.1 qemu-nbd.8 qmp-commands.txt
+endif
ifdef CONFIG_VIRTFS
DOCS+=fsdev/virtfs-proxy-helper.1
endif
-@@ -311,8 +315,10 @@ endif
+@@ -304,8 +308,10 @@ endif
install-doc: $(DOCS)
$(INSTALL_DIR) "$(DESTDIR)$(qemu_docdir)"
+ifndef NOPORTDOCS
$(INSTALL_DATA) qemu-doc.html qemu-tech.html "$(DESTDIR)$(qemu_docdir)"
- $(INSTALL_DATA) QMP/qmp-commands.txt "$(DESTDIR)$(qemu_docdir)"
+ $(INSTALL_DATA) qmp-commands.txt "$(DESTDIR)$(qemu_docdir)"
+endif
ifdef CONFIG_POSIX
$(INSTALL_DIR) "$(DESTDIR)$(mandir)/man1"
- $(INSTALL_DATA) qemu.1 qemu-img.1 "$(DESTDIR)$(mandir)/man1"
-@@ -331,7 +337,10 @@ install-confdir:
+ $(INSTALL_DATA) qemu.1 "$(DESTDIR)$(mandir)/man1"
+@@ -334,7 +340,10 @@ install-confdir:
$(INSTALL_DIR) "$(DESTDIR)$(qemu_confdir)"
install-sysconfig: install-datadir install-confdir
@@ -32,5 +32,5 @@ Index: qemu/Makefile
+ $(INSTALL_DATA) $(SRC_PATH)/sysconfigs/target/target-x86_64.conf "$(qemu_confdir)"; \
+ fi
- install: all $(if $(BUILD_DOCS),install-doc) install-sysconfig install-datadir
- $(INSTALL_DIR) "$(DESTDIR)$(bindir)"
+ install: all $(if $(BUILD_DOCS),install-doc) install-sysconfig \
+ install-datadir install-localstatedir
diff --git a/emulators/qemu-devel/files/patch-configure b/emulators/qemu-devel/files/patch-configure
index 45c561b4be4a..49b7e000a62d 100644
--- a/emulators/qemu-devel/files/patch-configure
+++ b/emulators/qemu-devel/files/patch-configure
@@ -1,7 +1,7 @@
--- a/configure
+++ a/configure
-@@ -154,7 +154,7 @@ bigendian="no"
- mingw32="no"
+@@ -192,7 +192,7 @@ gcov="no"
+ gcov_tool="gcov"
EXESUF=""
prefix="/usr/local"
-mandir="\${prefix}/share/man"
@@ -9,16 +9,16 @@
datadir="\${prefix}/share"
qemu_docdir="\${prefix}/share/doc/qemu"
bindir="\${prefix}/bin"
-@@ -1756,7 +1756,7 @@ if test "$gtk" != "no"; then
- gtk_libs=`$pkg_config --libs $gtkpackage 2>/dev/null`
- vte_cflags=`$pkg_config --cflags $vtepackage 2>/dev/null`
- vte_libs=`$pkg_config --libs $vtepackage 2>/dev/null`
+@@ -1749,7 +1749,7 @@ if test "$gtk" != "no"; then
+ gtk_libs=`$pkg_config --libs $gtkpackage`
+ vte_cflags=`$pkg_config --cflags $vtepackage`
+ vte_libs=`$pkg_config --libs $vtepackage`
- libs_softmmu="$gtk_libs $vte_libs $libs_softmmu"
+ libs_softmmu="$gtk_libs -lintl $vte_libs $libs_softmmu"
gtk="yes"
- else
- if test "$gtk" = "yes" ; then
-@@ -2511,15 +2511,18 @@ if compile_prog "" "" ; then
+ fi
+ fi
+@@ -2956,15 +2956,18 @@ if compile_prog "" "" ; then
fi
# Check if tools are available to build documentation.
@@ -45,33 +45,33 @@
fi
# Search for bswap_32 function
-@@ -3134,18 +3134,29 @@ fi
+@@ -3121,17 +3124,30 @@ fi
# check for libusb
if test "$libusb" != "no" ; then
-- if $pkg_config --atleast-version=1.0.13 libusb-1.0 >/dev/null 2>&1 ; then
+- if $pkg_config --atleast-version=1.0.13 libusb-1.0; then
- libusb="yes"
-- usb="libusb"
-- libusb_cflags=$($pkg_config --cflags libusb-1.0 2>/dev/null)
-- libusb_libs=$($pkg_config --libs libusb-1.0 2>/dev/null)
+- libusb_cflags=$($pkg_config --cflags libusb-1.0)
+- libusb_libs=$($pkg_config --libs libusb-1.0)
- QEMU_CFLAGS="$QEMU_CFLAGS $libusb_cflags"
+ cat > $TMPC << EOF
+#include <libusb.h>
+
+int main(void) { return libusb_get_port_path(NULL, NULL, NULL, 0); }
+EOF
-+ if compile_prog "-Werror" "-lusb" ; then
++ if compile_prog "-Werror" "-lusb -pthread" ; then
++ libusb="yes"
+ libusb_cflags=""
+ libusb_libs=-lusb
libs_softmmu="$libs_softmmu $libusb_libs"
else
- if test "$libusb" = "yes"; then
- feature_not_found "libusb"
-+ if $pkg_config --atleast-version=1.0.13 libusb-1.0 >/dev/null 2>&1 ; then
++ if $pkg_config --atleast-version=1.0.13 libusb-1.0; then
+ libusb="yes"
+ usb="libusb"
-+ libusb_cflags=$($pkg_config --cflags libusb-1.0 2>/dev/null)
-+ libusb_libs=$($pkg_config --libs libusb-1.0 2>/dev/null)
++ libusb_cflags=$($pkg_config --cflags libusb-1.0)
++ libusb_libs=$($pkg_config --libs libusb-1.0)
+ QEMU_CFLAGS="$QEMU_CFLAGS $libusb_cflags"
+ libs_softmmu="$libs_softmmu $libusb_libs"
+ else
diff --git a/emulators/qemu-devel/files/patch-cpu-exec.c b/emulators/qemu-devel/files/patch-cpu-exec.c
deleted file mode 100644
index 57229ab351db..000000000000
--- a/emulators/qemu-devel/files/patch-cpu-exec.c
+++ /dev/null
@@ -1,13 +0,0 @@
---- a/cpu-exec.c
-+++ b/cpu-exec.c
-@@ -681,6 +681,10 @@ int cpu_exec(CPUArchState *env)
- * local variables as longjmp is marked 'noreturn'. */
- cpu = current_cpu;
- env = cpu->env_ptr;
-+#if !(defined(CONFIG_USER_ONLY) && \
-+ (defined(TARGET_M68K) || defined(TARGET_PPC) || defined(TARGET_S390X)))
-+ cc = CPU_GET_CLASS(cpu);
-+#endif
- }
- } /* for(;;) */
-
diff --git a/emulators/qemu-devel/files/pcap-patch b/emulators/qemu-devel/files/pcap-patch
index 1428b20345c3..1688360e8c6c 100644
--- a/emulators/qemu-devel/files/pcap-patch
+++ b/emulators/qemu-devel/files/pcap-patch
@@ -1,16 +1,16 @@
--- configure.orig
+++ configure
-@@ -241,6 +241,9 @@ gtk=""
- gtkabi="2.0"
+@@ -261,6 +261,9 @@ gtkabi="2.0"
tpm="no"
libssh2=""
+ vhdx=""
+pcap="no"
+pcap_create="no"
+bpf="no"
# parse CC options first
for opt do
-@@ -748,6 +751,10 @@ for opt do
+@@ -787,6 +790,10 @@ for opt do
;;
--enable-vnc-ws) vnc_ws="yes"
;;
@@ -21,7 +21,7 @@
--disable-slirp) slirp="no"
;;
--disable-uuid) uuid="no"
-@@ -1843,6 +1850,51 @@ EOF
+@@ -1884,6 +1891,51 @@ EOF
fi
##########################################
@@ -73,15 +73,15 @@
# VNC TLS/WS detection
if test "$vnc" = "yes" -a \( "$vnc_tls" != "no" -o "$vnc_ws" != "no" \) ; then
cat > $TMPC <<EOF
-@@ -3549,6 +3601,7 @@ echo "Audio drivers $audio_drv_list"
- echo "Block whitelist $block_drv_whitelist"
- echo "Mixer emulation $mixemu"
+@@ -3747,6 +3799,7 @@ echo "Audio drivers $audio_drv_list"
+ echo "Block whitelist (rw) $block_drv_rw_whitelist"
+ echo "Block whitelist (ro) $block_drv_ro_whitelist"
echo "VirtFS support $virtfs"
+echo "pcap support $pcap"
echo "VNC support $vnc"
if test "$vnc" = "yes" ; then
echo "VNC TLS support $vnc_tls"
-@@ -3701,6 +3754,15 @@ fi
+@@ -3897,6 +3950,15 @@ fi
if test "$profiler" = "yes" ; then
echo "CONFIG_PROFILER=y" >> $config_host_mak
fi
diff --git a/emulators/qemu-devel/files/prepatch-configure b/emulators/qemu-devel/files/prepatch-configure
new file mode 100644
index 000000000000..1b4708fc382f
--- /dev/null
+++ b/emulators/qemu-devel/files/prepatch-configure
@@ -0,0 +1,10 @@
+--- a/configure
++++ b/configure
+@@ -491,6 +491,7 @@ FreeBSD)
+ audio_possible_drivers="oss sdl esd pa"
+ # needed for kinfo_getvmmap(3) in libutil.h
+ LIBS="-lutil $LIBS"
++ netmap="" # enable netmap autodetect
+ ;;
+ DragonFly)
+ bsd="yes"
diff --git a/emulators/qemu-devel/pkg-plist b/emulators/qemu-devel/pkg-plist
index 98b4e9498c7c..98097b7f1197 100644
--- a/emulators/qemu-devel/pkg-plist
+++ b/emulators/qemu-devel/pkg-plist
@@ -26,7 +26,6 @@ bin/qemu-system-i386
%%NONX86%%bin/qemu-system-sparc64
%%NONX86%%bin/qemu-system-unicore32
%%BSD_USER%%bin/qemu-arm
-%%BSD_USER%%bin/qemu-armeb
%%BSD_USER%%bin/qemu-i386
%%BSD_USER%%bin/qemu-mips
%%BSD_USER64%%bin/qemu-mips64
@@ -48,6 +47,7 @@ etc/qemu-ifdown.sample
etc/qemu/target-x86_64.conf.sample
@exec if [ ! -f %D/etc/qemu/target-x86_64.conf ] ; then cp -p %D/%F %D/etc/qemu/target-x86_64.conf; fi
@dirrmtry etc/qemu
+%%DATADIR%%/QEMU,tcx.bin
%%DATADIR%%/acpi-dsdt.aml
%%DATADIR%%/q35-acpi-dsdt.aml
%%DATADIR%%/bios.bin
@@ -89,6 +89,7 @@ etc/qemu/target-x86_64.conf.sample
%%DATADIR%%/keymaps/ar
%%DATADIR%%/keymaps/bepo
%%DATADIR%%/keymaps/common
+%%DATADIR%%/keymaps/cz
%%DATADIR%%/keymaps/da
%%DATADIR%%/keymaps/de
%%DATADIR%%/keymaps/de-ch