aboutsummaryrefslogtreecommitdiff
path: root/emulators/qemu-launcher
diff options
context:
space:
mode:
authorMartin Wilke <miwi@FreeBSD.org>2006-11-15 20:43:41 +0000
committerMartin Wilke <miwi@FreeBSD.org>2006-11-15 20:43:41 +0000
commit1e9c841fe2568c5c076630047407675aa48334a1 (patch)
tree788eea9f6cbba90f7a0fd87a26b71988bbfd7bfa /emulators/qemu-launcher
parent938c732c1135bf6a2e4363919e7bbcb9bbb0dab6 (diff)
downloadports-1e9c841fe2568c5c076630047407675aa48334a1.tar.gz
ports-1e9c841fe2568c5c076630047407675aa48334a1.zip
Notes
Diffstat (limited to 'emulators/qemu-launcher')
-rw-r--r--emulators/qemu-launcher/Makefile24
-rw-r--r--emulators/qemu-launcher/distinfo6
-rw-r--r--emulators/qemu-launcher/files/patch-Makefile28
-rw-r--r--emulators/qemu-launcher/pkg-descr6
-rw-r--r--emulators/qemu-launcher/pkg-plist29
5 files changed, 64 insertions, 29 deletions
diff --git a/emulators/qemu-launcher/Makefile b/emulators/qemu-launcher/Makefile
index ebe4647e346b..de1b36216311 100644
--- a/emulators/qemu-launcher/Makefile
+++ b/emulators/qemu-launcher/Makefile
@@ -6,11 +6,10 @@
#
PORTNAME= qemu-launcher
-PORTVERSION= 1.5.1
-PORTREVISION= 1
+PORTVERSION= 1.7.2
CATEGORIES= emulators
-MASTER_SITES= http://emeitner.f2o.org/debian/
-DISTNAME= ${PORTNAME}_${PORTVERSION}-1
+MASTER_SITES= http://download.gna.org/qemulaunch/1.7.x/
+DISTNAME= ${PORTNAME}_${PORTVERSION}
MAINTAINER= wxs@atarininja.org
COMMENT= A GTK front-end to Qemu
@@ -20,23 +19,16 @@ RUN_DEPENDS= ${SITE_PERL}/${PERL_ARCH}/Gtk2:${PORTSDIR}/x11-toolkits/p5-Gtk2 \
${SITE_PERL}/${PERL_ARCH}/Gnome2.pm:${PORTSDIR}/x11-toolkits/p5-Gnome2 \
${SITE_PERL}/${PERL_ARCH}/Locale/gettext.pm:${PORTSDIR}/devel/p5-Locale-gettext
-WRKSRC= ${WRKDIR}/trunk
-
+WRKSRC= ${WRKDIR}/${PORTNAME}-${PORTVERSION}
USE_PERL5= yes
NO_BUILD= yes
+USE_GNOME= gtk20
+INSTALLS_ICONS= yes
+USE_GETTEXT= yes
MAN1= qemu-launcher.1
post-patch:
- @${REINPLACE_CMD} -e 's,usr,usr/local,g' ${WRKSRC}/qemu-launcher
-
-# XXX: Currently not installing qemu-launcher.desktop or qemu-launcher.xpm
-do-install:
- ${INSTALL_SCRIPT} ${WRKSRC}/qemu-launcher ${PREFIX}/bin
- ${INSTALL_MAN} ${WRKSRC}/qemu-launcher.1 ${PREFIX}/man/man1
- ${MKDIR} ${PREFIX}/share/qemu-launcher/glade
-.for file in diskimages.glade qemulauncher.glade qemulauncher.png
- ${INSTALL_DATA} ${WRKSRC}/glade/${file} ${PREFIX}/share/qemu-launcher/glade
-.endfor
+ @${REINPLACE_CMD} -e 's,usr,usr/local,g' ${WRKSRC}/qemu-launcher.pl
.include <bsd.port.mk>
diff --git a/emulators/qemu-launcher/distinfo b/emulators/qemu-launcher/distinfo
index a3d1303c8b88..2fe52fc5b72d 100644
--- a/emulators/qemu-launcher/distinfo
+++ b/emulators/qemu-launcher/distinfo
@@ -1,3 +1,3 @@
-MD5 (qemu-launcher_1.5.1-1.tar.gz) = 818ade9464af93798f8cab87217d5437
-SHA256 (qemu-launcher_1.5.1-1.tar.gz) = a6a5d2794b1c5a9c10681e958e158c43502fa179e1ad898ff5f3aefd7d774e66
-SIZE (qemu-launcher_1.5.1-1.tar.gz) = 33684
+MD5 (qemu-launcher_1.7.2.tar.gz) = 3243dd94b8b9be8a754db9cc9aaa2f17
+SHA256 (qemu-launcher_1.7.2.tar.gz) = ea84978a122e278557a019cdba1de01bae177c75c42794261c201fb7f00f8c3f
+SIZE (qemu-launcher_1.7.2.tar.gz) = 59659
diff --git a/emulators/qemu-launcher/files/patch-Makefile b/emulators/qemu-launcher/files/patch-Makefile
new file mode 100644
index 000000000000..b20c7e508ab6
--- /dev/null
+++ b/emulators/qemu-launcher/files/patch-Makefile
@@ -0,0 +1,28 @@
+--- Makefile.orig Fri Sep 29 14:04:21 2006
++++ Makefile Mon Nov 13 15:29:22 2006
+@@ -3,12 +3,12 @@
+
+ # Intall things to the following directories
+ PREFIX = /usr/local
+-MANDIR = $(PREFIX)/share/man/man1
++MANDIR = $(PREFIX)/man/man1
+ BINDIR = $(PREFIX)/bin
+ SHAREDIR = $(PREFIX)/share/qemu-launcher
+-PIXMAPSDIR = $(PREFIX)/share/pixmaps
+-ICONSDIR = $(PREFIX)/share/icons/hicolor
+-DOCSDIR = $(PREFIX)/share/doc/qemu-launcher
++PIXMAPSDIR = $(SHAREDIR)/pixmaps
++ICONSDIR = $(SHAREDIR)/icons/hicolor
++DOCSDIR = $(SHAREDIR)/doc
+ LOCALEDIR = $(PREFIX)/share/locale
+ APPLICATIONSDIR = $(PREFIX)/share/applications
+
+@@ -50,7 +50,7 @@
+
+ install -d $(DESTDIR)$(MANDIR)
+ install -m644 $(MANPAGE) $(DESTDIR)$(MANDIR)
+- gzip --best $(DESTDIR)$(MANDIR)/$(MANPAGE)
++ #gzip --best $(DESTDIR)$(MANDIR)/$(MANPAGE)
+
+ install -d $(DESTDIR)$(APPLICATIONSDIR)
+ install -m644 $(MENUFILE) $(DESTDIR)$(APPLICATIONSDIR)
diff --git a/emulators/qemu-launcher/pkg-descr b/emulators/qemu-launcher/pkg-descr
index 6602aedf504d..fdac652de2c6 100644
--- a/emulators/qemu-launcher/pkg-descr
+++ b/emulators/qemu-launcher/pkg-descr
@@ -1,7 +1,3 @@
Qemu Launcher is a GTK front-end for the Qemu x86 PC emulator.
-WWW: http://emeitner.f2o.org/qemu_launcher
-
--- WXS
-Wesley Shields
-wxs@csh.rit.edu
+WWW: https://gna.org/projects/qemulaunch
diff --git a/emulators/qemu-launcher/pkg-plist b/emulators/qemu-launcher/pkg-plist
index b386a07c8171..d881f948bb42 100644
--- a/emulators/qemu-launcher/pkg-plist
+++ b/emulators/qemu-launcher/pkg-plist
@@ -1,6 +1,25 @@
bin/qemu-launcher
-%%DATADIR%%/glade/diskimages.glade
-%%DATADIR%%/glade/qemulauncher.glade
-%%DATADIR%%/glade/qemulauncher.png
-@dirrm share/qemu-launcher/glade
-@dirrm share/qemu-launcher
+%%DATADIR%%/qemulauncher.png
+%%DATADIR%%/window-icon.png
+%%DATADIR%%/qemulauncher.glade
+%%DATADIR%%/doc/README
+%%DATADIR%%/doc/TODO
+share/applications/qemu-launcher.desktop
+share/locale/lt/LC_MESSAGES/qemu-launcher.mo
+%%DATADIR%%/pixmaps/qemu-launcher-16x16.xpm
+%%DATADIR%%/pixmaps/qemu-launcher-32x32.xpm
+%%DATADIR%%/icons/hicolor/scalable/apps/qemu-launcher.svg
+%%DATADIR%%/icons/hicolor/16x16/apps/qemu-launcher.png
+%%DATADIR%%/icons/hicolor/48x48/apps/qemu-launcher.png
+@dirrm share/applications/
+@dirrm %%DATADIR%%/pixmaps/
+@dirrm %%DATADIR%%/icons/hicolor/scalable/apps
+@dirrm %%DATADIR%%/icons/hicolor/scalable/
+@dirrm %%DATADIR%%/icons/hicolor/16x16/apps
+@dirrm %%DATADIR%%/icons/hicolor/16x16/
+@dirrm %%DATADIR%%/icons/hicolor/48x48/apps
+@dirrm %%DATADIR%%/icons/hicolor/48x48/
+@dirrm %%DATADIR%%/icons/hicolor/
+@dirrm %%DATADIR%%/icons/
+@dirrm %%DATADIR%%/doc/
+@dirrm %%DATADIR%%