aboutsummaryrefslogtreecommitdiff
path: root/emulators/qemu/Makefile
diff options
context:
space:
mode:
authorNorikatsu Shigemura <nork@FreeBSD.org>2006-08-07 16:10:27 +0000
committerNorikatsu Shigemura <nork@FreeBSD.org>2006-08-07 16:10:27 +0000
commitabffcb30ec97e8b7fe50b51b323a63201f83190d (patch)
tree14535343032cf24b54d2d185d006e38ee894f846 /emulators/qemu/Makefile
parent826d991f606c4ee01defa9be677d6caf59f02f22 (diff)
Notes
Diffstat (limited to 'emulators/qemu/Makefile')
-rw-r--r--emulators/qemu/Makefile12
1 files changed, 10 insertions, 2 deletions
diff --git a/emulators/qemu/Makefile b/emulators/qemu/Makefile
index 0563c8a4b8c1..9efe2446d401 100644
--- a/emulators/qemu/Makefile
+++ b/emulators/qemu/Makefile
@@ -6,8 +6,7 @@
#
PORTNAME= qemu
-PORTVERSION= 0.8.1
-PORTREVISION= 2
+PORTVERSION= 0.8.2
CATEGORIES= emulators
MASTER_SITES= http://www.qemu.org/:release \
http://people.fruitsalad.org/nox/qemu/:snapshot \
@@ -75,6 +74,12 @@ pre-everything::
@${ECHO_MSG} "then you also need samba, you can have this port install it by defining"
@${ECHO_MSG} "WITH_SAMBA."
.endif
+.if !defined(WITH_RTL8139_TIMER)
+ @${ECHO_MSG} "Notice: if you want to use qemu's rtl8139c+ nic with a FreeBSD guest"
+ @${ECHO_MSG} "(qemu -net nic,model=rtl8139 -net user or tap ... - will use re(4)"
+ @${ECHO_MSG} "instead of ed(4) which should use less cpu), then you need to enable"
+ @${ECHO_MSG} "the emulated rtl8139 timer by defining WITH_RTL8139_TIMER."
+.endif
post-extract:
@${MKDIR} ${WRKSRC}/kqemu
@@ -90,6 +95,9 @@ post-patch:
.if defined(WITH_HACKS_CIRRUS) || defined (WITH_HACKS)
@cd ${WRKSRC} ; ${PATCH} --quiet < ${DISTDIR}/${DIST_SUBDIR}/patch3_cirrus
.endif
+.if defined(WITH_RTL8139_TIMER)
+ @cd ${WRKSRC} && ${PATCH} --quiet < ${FILESDIR}/rtl8139-re-patch
+.endif
post-install:
@${CAT} ${PKGMESSAGE}