aboutsummaryrefslogtreecommitdiff
path: root/emulators/qemu/Makefile
diff options
context:
space:
mode:
authorJuergen Lock <nox@FreeBSD.org>2009-12-06 19:37:46 +0000
committerJuergen Lock <nox@FreeBSD.org>2009-12-06 19:37:46 +0000
commitb987bd37c9ef735647d3a4ba66db5c7b88c2a993 (patch)
tree8929f0c86b3c65495580a6b839d41d2acf5a3ad9 /emulators/qemu/Makefile
parent3971cd580f5c0a3488a65e119aea3e53482744f4 (diff)
downloadports-b987bd37c9ef735647d3a4ba66db5c7b88c2a993.tar.gz
ports-b987bd37c9ef735647d3a4ba66db5c7b88c2a993.zip
Notes
Diffstat (limited to 'emulators/qemu/Makefile')
-rw-r--r--emulators/qemu/Makefile12
1 files changed, 5 insertions, 7 deletions
diff --git a/emulators/qemu/Makefile b/emulators/qemu/Makefile
index a2fd1511e0c3..5fac48c23701 100644
--- a/emulators/qemu/Makefile
+++ b/emulators/qemu/Makefile
@@ -6,8 +6,7 @@
#
PORTNAME= qemu
-PORTVERSION= 0.10.6
-PORTREVISION= 3
+PORTVERSION= 0.11.1
CATEGORIES= emulators
MASTER_SITES= ${MASTER_SITE_SAVANNAH} \
http://bellard.org/qemu/
@@ -34,7 +33,6 @@ OPTIONS= KQEMU "Build with (alpha!) accelerator module" Off \
GNUTLS "gnutls dependency (vnc encryption)" On \
PCAP "pcap dependency (networking with bpf)" On \
CDROM_DMA "IDE CDROM DMA" On \
- PHYS_CDROM "Physical CDROM fixes" On \
ADD_AUDIO "Emulate more audio hardware (experimental!)" Off \
ALL_TARGETS "Also build non-x86 targets" On
@@ -52,7 +50,7 @@ CFLAGS:= ${CFLAGS:C/-fno-tree-vrp//}
CONFIGURE_ARGS+= --prefix=${PREFIX} --cc=${CC}
.if defined(WITHOUT_SDL)
-CONFIGURE_ARGS+= --disable-sdl --disable-gfx-check
+CONFIGURE_ARGS+= --disable-sdl
.else
USE_SDL= sdl
.endif
@@ -71,6 +69,9 @@ CONFIGURE_ARGS+= --enable-pcap
CONFIGURE_ARGS+= --audio-card-list=ac97,es1370,sb16,cs4231a,adlib,gus
.endif
+# XXX
+CONFIGURE_ARGS+= --disable-bsd-user
+
.if defined(WITH_SAMBA)
RUN_DEPENDS+= ${LOCALBASE}/sbin/smbd:${PORTSDIR}/net/samba3
.endif
@@ -111,9 +112,6 @@ post-patch:
.if defined(WITHOUT_CDROM_DMA)
@cd ${WRKSRC} && ${PATCH} --quiet < ${FILESDIR}/cdrom-dma-patch
.endif
-.if defined(WITH_PHYS_CDROM)
- @cd ${WRKSRC} && ${PATCH} -p1 --quiet < ${FILESDIR}/phys-cdrom-freebsd-patch
-.endif
@${REINPLACE_CMD} -E \
-e "s|^(CFLAGS=).*|\1${CFLAGS} -fno-strict-aliasing|" \
-e "s|^(LDFLAGS=).*|\1${LDFLAGS}|" \