aboutsummaryrefslogtreecommitdiff
path: root/emulators/qemu/Makefile
diff options
context:
space:
mode:
authorShaun Amott <shaun@FreeBSD.org>2006-08-21 23:02:01 +0000
committerShaun Amott <shaun@FreeBSD.org>2006-08-21 23:02:01 +0000
commitdaf9bed6c4571dbe6481411363257bb1d3655830 (patch)
tree00a8ba4f2cb05c72f7f5e74220c430131298e3b7 /emulators/qemu/Makefile
parent5c04e700a2776adb285725c1d4683407dad21df6 (diff)
downloadports-daf9bed6c4571dbe6481411363257bb1d3655830.tar.gz
ports-daf9bed6c4571dbe6481411363257bb1d3655830.zip
Notes
Diffstat (limited to 'emulators/qemu/Makefile')
-rw-r--r--emulators/qemu/Makefile13
1 files changed, 12 insertions, 1 deletions
diff --git a/emulators/qemu/Makefile b/emulators/qemu/Makefile
index 9efe2446d401..09f4b2cd1121 100644
--- a/emulators/qemu/Makefile
+++ b/emulators/qemu/Makefile
@@ -7,6 +7,7 @@
PORTNAME= qemu
PORTVERSION= 0.8.2
+PORTREVISION= 1
CATEGORIES= emulators
MASTER_SITES= http://www.qemu.org/:release \
http://people.fruitsalad.org/nox/qemu/:snapshot \
@@ -39,9 +40,11 @@ USE_SDL= sdl
USE_PERL5= yes
PATCH_STRIP= -p1
CONFIGURE_ARGS+= --prefix=${PREFIX} --cc=${CC}
-MAKE_ENV+= BSD_MAKE=${MAKE}
+MAKE_ENV+= BSD_MAKE="${MAKE}" CFLAGS="${CFLAGS}" LDFLAGS="${LDFLAGS}"
MAN1= qemu.1 qemu-img.1
ONLY_FOR_ARCHS= amd64 i386
+WITHOUT_CPU_CFLAGS=yes #to avoid problems with register allocation
+
.if defined(WITH_KQEMU)
CONFIGURE_ARGS+= --enable-kqemu
.else
@@ -98,6 +101,14 @@ post-patch:
.if defined(WITH_RTL8139_TIMER)
@cd ${WRKSRC} && ${PATCH} --quiet < ${FILESDIR}/rtl8139-re-patch
.endif
+ @${REINPLACE_CMD} -E \
+ -e "s,^(CFLAGS=).*,\1${CFLAGS} -fno-strict-aliasing," \
+ -e "s,^(LDFLAGS=).*,\1${LDFLAGS}," \
+ ${WRKSRC}/Makefile.target
+ @${REINPLACE_CMD} -E \
+ -e "s,^(CFLAGS=).*,\1${CFLAGS} -fno-strict-aliasing -I.," \
+ -e "s,^(LDFLAGS=).*,\1${LDFLAGS}," \
+ ${WRKSRC}/Makefile
post-install:
@${CAT} ${PKGMESSAGE}