aboutsummaryrefslogtreecommitdiff
path: root/emulators/qemu
diff options
context:
space:
mode:
authorJuergen Lock <nox@FreeBSD.org>2008-03-21 17:31:52 +0000
committerJuergen Lock <nox@FreeBSD.org>2008-03-21 17:31:52 +0000
commite2f267539d0b5951c542e651f4672c14b5a9ac84 (patch)
tree6bcf28c0e3e5d44254bd5667ba6ca4d296e081fc /emulators/qemu
parent11c4608375b4e144c6c53fee96f7faf2c4eb2a43 (diff)
downloadports-e2f267539d0b5951c542e651f4672c14b5a9ac84.tar.gz
ports-e2f267539d0b5951c542e651f4672c14b5a9ac84.zip
Notes
Diffstat (limited to 'emulators/qemu')
-rw-r--r--emulators/qemu/Makefile2
-rw-r--r--emulators/qemu/files/patch-vl.c12
2 files changed, 13 insertions, 1 deletions
diff --git a/emulators/qemu/Makefile b/emulators/qemu/Makefile
index 7257e8383e64..28e5d457626c 100644
--- a/emulators/qemu/Makefile
+++ b/emulators/qemu/Makefile
@@ -7,7 +7,7 @@
PORTNAME= qemu
PORTVERSION= 0.9.1
-PORTREVISION= 3
+PORTREVISION= 4
CATEGORIES= emulators
MASTER_SITES= http://fabrice.bellard.free.fr/qemu/:release \
http://qemu.org/:release \
diff --git a/emulators/qemu/files/patch-vl.c b/emulators/qemu/files/patch-vl.c
index 8f920b047bed..a69e42ffd8ba 100644
--- a/emulators/qemu/files/patch-vl.c
+++ b/emulators/qemu/files/patch-vl.c
@@ -33,6 +33,18 @@ Index: qemu/vl.c
if (strstart(filename, "/dev/", NULL)) {
return qemu_chr_open_tty(filename);
} else
+@@ -8423,6 +8423,11 @@
+ nb_nics = 0;
+ /* default mac address of the first network interface */
+
++#ifdef __FreeBSD__
++ if (modfind("aio") == -1)
++ fprintf(stderr, "warning: aio not (kld)loaded, may cause `Invalid system call' traps on disk IO\n");
++#endif
++
+ optind = 1;
+ for(;;) {
+ if (optind >= argc)
@@ -8784,6 +8784,7 @@
#ifdef TARGET_ARM
case QEMU_OPTION_old_param: