aboutsummaryrefslogtreecommitdiff
path: root/emulators/qemu
diff options
context:
space:
mode:
authorJuergen Lock <nox@FreeBSD.org>2007-05-26 16:08:17 +0000
committerJuergen Lock <nox@FreeBSD.org>2007-05-26 16:08:17 +0000
commit7cd4402a2b0f5cf27aa2e6fb23718ac59ea2031c (patch)
tree9e243d0faf3dd7a04e11796ef42a72594f700403 /emulators/qemu
parent6c1654e7295766022ffde1d1d51717838c4b16ee (diff)
downloadports-7cd4402a2b0f5cf27aa2e6fb23718ac59ea2031c.tar.gz
ports-7cd4402a2b0f5cf27aa2e6fb23718ac59ea2031c.zip
Notes
Diffstat (limited to 'emulators/qemu')
-rw-r--r--emulators/qemu/Makefile2
-rw-r--r--emulators/qemu/files/patch-block-qcow2.c25
2 files changed, 26 insertions, 1 deletions
diff --git a/emulators/qemu/Makefile b/emulators/qemu/Makefile
index fa995d213738..ac52a214aa43 100644
--- a/emulators/qemu/Makefile
+++ b/emulators/qemu/Makefile
@@ -7,7 +7,7 @@
PORTNAME= qemu
PORTVERSION= 0.9.0
-PORTREVISION= 2
+PORTREVISION= 3
CATEGORIES= emulators
MASTER_SITES= http://qemu.org/:release \
http://qemu-forum.ipi.fi/qemu-snapshots/:snapshot \
diff --git a/emulators/qemu/files/patch-block-qcow2.c b/emulators/qemu/files/patch-block-qcow2.c
new file mode 100644
index 000000000000..e392c5114ddc
--- /dev/null
+++ b/emulators/qemu/files/patch-block-qcow2.c
@@ -0,0 +1,25 @@
+Index: qemu/block-qcow2.c
+@@ -1886,6 +1886,8 @@
+ int64_t table_offset;
+ uint64_t data64;
+ uint32_t data32;
++ int old_table_size;
++ int64_t old_table_offset;
+
+ if (min_size <= s->refcount_table_size)
+ return 0;
+@@ -1931,10 +1933,14 @@
+ &data32, sizeof(data32)) != sizeof(data32))
+ goto fail;
+ qemu_free(s->refcount_table);
++ old_table_offset = s->refcount_table_offset;
++ old_table_size = s->refcount_table_size;
+ s->refcount_table = new_table;
+ s->refcount_table_size = new_table_size;
++ s->refcount_table_offset = table_offset;
+
+ update_refcount(bs, table_offset, new_table_size2, 1);
++ free_clusters(bs, old_table_offset, old_table_size * sizeof(uint64_t));
+ return 0;
+ fail:
+ free_clusters(bs, table_offset, new_table_size2);