aboutsummaryrefslogtreecommitdiff
path: root/emulators/qemu
diff options
context:
space:
mode:
authorAlan Somers <asomers@FreeBSD.org>2016-10-14 20:34:26 +0000
committerAlan Somers <asomers@FreeBSD.org>2016-10-14 20:34:26 +0000
commitf51dcaa2eae6f6468fb271163aaa7a148cf42aee (patch)
tree41b9133bfc2317fc1ca1d937da24d1530d2c9dea /emulators/qemu
parent217e68c35b135c571e02bd51fc6aac8db0c90d9a (diff)
downloadports-f51dcaa2eae6f6468fb271163aaa7a148cf42aee.tar.gz
ports-f51dcaa2eae6f6468fb271163aaa7a148cf42aee.zip
Notes
Diffstat (limited to 'emulators/qemu')
-rw-r--r--emulators/qemu/Makefile12
1 files changed, 7 insertions, 5 deletions
diff --git a/emulators/qemu/Makefile b/emulators/qemu/Makefile
index 9cff04751996..572f79957479 100644
--- a/emulators/qemu/Makefile
+++ b/emulators/qemu/Makefile
@@ -14,12 +14,14 @@ COMMENT?= QEMU CPU Emulator
LICENSE= GPLv2
HAS_CONFIGURE= yes
-USES= cpe gmake pkgconfig bison perl5 python:2,build tar:bzip2
+USES?= cpe gmake pkgconfig bison perl5 python:2,build tar:bzip2
USE_PERL5= build
+MAKE_ENV+= BSD_MAKE="${MAKE}"
+.if !defined(PKGNAMESUFFIX) || ${PKGNAMESUFFIX} != "-utils"
USE_XORG= pixman
USE_GNOME+= cairo glib20
-MAKE_ENV+= BSD_MAKE="${MAKE}"
ONLY_FOR_ARCHS= amd64 i386 powerpc powerpc64 # XXX someone wants to debug sparc64 hosts?
+.endif
OPTIONS_DEFINE= SAMBA X11 GTK2 OPENGL GNUTLS SASL JPEG PNG CURL \
CDROM_DMA PCAP USBREDIR GNS3 X86_TARGETS \
@@ -68,18 +70,18 @@ DOCS_BUILD_DEPENDS= texi2html:textproc/texi2html
DOCS_USES= makeinfo
DOCS_MAKE_ARGS_OFF= NOPORTDOCS=1
-PORTDOCS= docs qemu-doc.html qemu-tech.html qmp-commands.txt
+PORTDOCS?= docs qemu-doc.html qemu-tech.html qmp-commands.txt
WITHOUT_CPU_CFLAGS=yes #to avoid problems with register allocation
CFLAGS:= ${CFLAGS:C/-fno-tree-vrp//}
-CONFIGURE_ARGS+=--localstatedir=/var --extra-ldflags=-L\"${LOCALBASE}/lib\" \
+CONFIGURE_ARGS?=--localstatedir=/var --extra-ldflags=-L\"${LOCALBASE}/lib\" \
--disable-libssh2 --enable-debug \
--prefix=${PREFIX} --cc=${CC} --enable-docs --disable-kvm \
--disable-linux-user --disable-linux-aio --disable-xen \
--smbd=${LOCALBASE}/sbin/smbd --enable-debug-info --python=${PYTHON_CMD} \
--extra-cflags=-I${WRKSRC}\ -I${LOCALBASE}/include\ -DPREFIX=\\\"\"${PREFIX}\\\"\"
-LIB_DEPENDS+= libnettle.so:security/nettle \
+LIB_DEPENDS?= libnettle.so:security/nettle \
libfontconfig.so:x11-fonts/fontconfig \
libfreetype.so:print/freetype2