aboutsummaryrefslogtreecommitdiff
path: root/emulators/qemu
diff options
context:
space:
mode:
authorJuergen Lock <nox@FreeBSD.org>2008-11-18 20:07:53 +0000
committerJuergen Lock <nox@FreeBSD.org>2008-11-18 20:07:53 +0000
commit8a13eaf0cc624464141b7fb20e4165e0545869df (patch)
treeb69e00b4f048eafb8c7e60333a33fad2f4819394 /emulators/qemu
parent942750a0fef5e39183254a3e99177cef83468df6 (diff)
downloadports-8a13eaf0cc624464141b7fb20e4165e0545869df.tar.gz
ports-8a13eaf0cc624464141b7fb20e4165e0545869df.zip
Notes
Diffstat (limited to 'emulators/qemu')
-rw-r--r--emulators/qemu/Makefile11
1 files changed, 7 insertions, 4 deletions
diff --git a/emulators/qemu/Makefile b/emulators/qemu/Makefile
index d9cb1d2439c4..a3216aacc018 100644
--- a/emulators/qemu/Makefile
+++ b/emulators/qemu/Makefile
@@ -102,13 +102,16 @@ post-patch:
@cd ${WRKSRC} && ${PATCH} --quiet < ${FILESDIR}/cdrom-dma-patch
.endif
@${REINPLACE_CMD} -E \
- -e "s,^(CFLAGS=).*,\1${CFLAGS} -fno-strict-aliasing," \
- -e "s,^(LDFLAGS=).*,\1${LDFLAGS}," \
+ -e "s|^(CFLAGS=).*|\1${CFLAGS} -fno-strict-aliasing|" \
+ -e "s|^(LDFLAGS=).*|\1${LDFLAGS}|" \
${WRKSRC}/Makefile.target
@${REINPLACE_CMD} -E \
- -e "s,^(CFLAGS=).*,\1${CFLAGS} -fno-strict-aliasing -I.," \
- -e "s,^(LDFLAGS=).*,\1${LDFLAGS}," \
+ -e "s|^(CFLAGS=).*|\1${CFLAGS} -fno-strict-aliasing -I.|" \
+ -e "s|^(LDFLAGS=).*|\1${LDFLAGS}|" \
${WRKSRC}/Makefile
+ @${REINPLACE_CMD} -E \
+ -e "1s|^(#! )/usr/bin/perl|\1${PERL}|" \
+ ${WRKSRC}/texi2pod.pl
post-install:
@${INSTALL_SCRIPT} ${FILESDIR}/qemu-ifup.sample ${PREFIX}/etc