aboutsummaryrefslogtreecommitdiff
path: root/emulators/qmc2
diff options
context:
space:
mode:
authorAlejandro Pulver <alepulver@FreeBSD.org>2007-02-28 05:31:30 +0000
committerAlejandro Pulver <alepulver@FreeBSD.org>2007-02-28 05:31:30 +0000
commit82ad20039edaa7f68f9d9f0a8ecf082f1c514324 (patch)
tree725b3a7a38af244ec832d149ebaff23b04ee4b95 /emulators/qmc2
parent23aa27562b2500a8e223fee324c41d2b6a935f4e (diff)
downloadports-82ad20039edaa7f68f9d9f0a8ecf082f1c514324.tar.gz
ports-82ad20039edaa7f68f9d9f0a8ecf082f1c514324.zip
Notes
Diffstat (limited to 'emulators/qmc2')
-rw-r--r--emulators/qmc2/Makefile38
-rw-r--r--emulators/qmc2/distinfo3
-rw-r--r--emulators/qmc2/files/patch-Makefile40
-rw-r--r--emulators/qmc2/files/patch-arch__FreeBSD.cfg20
-rw-r--r--emulators/qmc2/pkg-descr16
-rw-r--r--emulators/qmc2/pkg-message12
-rw-r--r--emulators/qmc2/pkg-plist127
7 files changed, 256 insertions, 0 deletions
diff --git a/emulators/qmc2/Makefile b/emulators/qmc2/Makefile
new file mode 100644
index 000000000000..0b23083b9a5e
--- /dev/null
+++ b/emulators/qmc2/Makefile
@@ -0,0 +1,38 @@
+# New ports collection makefile for: qmc2
+# Date created: 2007-02-25
+# Whom: alepulver
+#
+# $FreeBSD$
+#
+
+PORTNAME= qmc2
+PORTVERSION= 0.1.b8
+CATEGORIES= emulators
+MASTER_SITES= SF
+
+MAINTAINER= alepulver@FreeBSD.org
+COMMENT= Qt 4 based UNIX MAME frontend supporting both XMAME and SDLMAME
+
+USE_BZIP2= yes
+USE_GMAKE= yes
+USE_QT_VER= 4
+MAKE_ENV= QTDIR="${QTDIR}" QMAKE="${QMAKE}" SYSCONFDIR="${PREFIX}/etc"
+WRKSRC= ${WRKDIR}/${PORTNAME}
+
+OPTIONS= XMAME "Enable support for XMAME instead of SDLMAME" off
+
+.include <bsd.port.pre.mk>
+
+.if defined(WITH_XMAME)
+MAKE_ENV+= SDLMAME=0
+RUN_DEPENDS+= xmame:${PORTSDIR}/emulators/xmame
+.else
+RUN_DEPENDS+= sdlmame:${PORTSDIR}/emulators/sdlmame
+.endif
+
+post-install:
+ @${ECHO_CMD}
+ @${CAT} ${PKGMESSAGE}
+ @${ECHO_CMD}
+
+.include <bsd.port.post.mk>
diff --git a/emulators/qmc2/distinfo b/emulators/qmc2/distinfo
new file mode 100644
index 000000000000..e74898a7dc96
--- /dev/null
+++ b/emulators/qmc2/distinfo
@@ -0,0 +1,3 @@
+MD5 (qmc2-0.1.b8.tar.bz2) = 9a9d227179f139ef0fcb6b23d7bf5229
+SHA256 (qmc2-0.1.b8.tar.bz2) = 82740eb2149f6c52b714da5e2ead2916122405a538edcbb4d80f9da285a39f27
+SIZE (qmc2-0.1.b8.tar.bz2) = 574284
diff --git a/emulators/qmc2/files/patch-Makefile b/emulators/qmc2/files/patch-Makefile
new file mode 100644
index 000000000000..0efca1b8b9c7
--- /dev/null
+++ b/emulators/qmc2/files/patch-Makefile
@@ -0,0 +1,40 @@
+--- ./Makefile.orig Fri Feb 2 10:19:00 2007
++++ ./Makefile Sun Feb 25 18:58:18 2007
+@@ -37,9 +37,6 @@
+ # you want to test-compile a specific target's code branch or if the "uname"
+ # command doesn't tell the correct OS-type of your system (see also OSREL and
+ # MACHINE)
+-ifndef ARCH
+-ARCH = $(shell uname)
+-endif
+
+ # OSREL: target system's OS-release - please only change this if you know what
+ # you are doing :).
+@@ -66,7 +63,7 @@
+ # END OF MAKE OPTIONS
+
+ # commands are platform-specific
+-include arch/$(ARCH).cfg
++include arch/FreeBSD.cfg
+
+ # QMAKEV: qmake version (major release)
+ ifndef QMAKEV
+@@ -183,7 +180,7 @@
+
+ install: bin lang
+ @echo "Installing QMC2 build v$(VERSION). Please wait..."
+- @$(MKDIR) $(DESTDIR)/$(PREFIX)/bin $(DESTDIR)/$(PREFIX)/share/$(PROJECT) $(DESTDIR)/$(SYSCONFDIR)/$(PROJECT)
++ @$(MKDIR) $(DESTDIR)/$(PREFIX)/bin $(DESTDIR)/$(PREFIX)/share/$(PROJECT) $(DESTDIR)/$(SYSCONFDIR)/$(PROJECT) $(DESTDIR)/$(PREFIX)/share/$(PROJECT)/lng
+ @$(RSYNC) ./$(PROJECT) $(DESTDIR)/$(PREFIX)/bin
+ @$(RSYNC) ./data/lng/*.qm $(DESTDIR)/$(DATADIR)/$(PROJECT)/lng/
+ @$(RSYNC) ./data/opt $(DESTDIR)/$(DATADIR)/$(PROJECT)/
+@@ -191,7 +188,8 @@
+ @$(RSYNC) ./data/doc $(DESTDIR)/$(DATADIR)/$(PROJECT)/
+ @$(RSYNC) ./data/prv $(DESTDIR)/$(DATADIR)/$(PROJECT)/
+ @$(RSYNC) ./data/fly $(DESTDIR)/$(DATADIR)/$(PROJECT)/
+- @$(SED) -e "s_DATADIR_$(DATADIR)_" < ./inst/$(PROJECT).ini.template > $(DESTDIR)/$(SYSCONFDIR)/$(PROJECT)/$(PROJECT).ini
++ @$(SED) -e "s_DATADIR_$(DATADIR)_" < ./inst/$(PROJECT).ini.template > $(DESTDIR)/$(SYSCONFDIR)/$(PROJECT)/$(PROJECT).ini.sample
++ @test -f $(DESTDIR)/$(SYSCONFDIR)/$(PROJECT)/$(PROJECT).ini || $(CP) $(DESTDIR)/$(SYSCONFDIR)/$(PROJECT)/$(PROJECT).ini.sample $(DESTDIR)/$(SYSCONFDIR)/$(PROJECT)/$(PROJECT).ini
+ @echo "Installation complete."
+
+ clean: Makefile.qmake
diff --git a/emulators/qmc2/files/patch-arch__FreeBSD.cfg b/emulators/qmc2/files/patch-arch__FreeBSD.cfg
new file mode 100644
index 000000000000..dcfd723d7138
--- /dev/null
+++ b/emulators/qmc2/files/patch-arch__FreeBSD.cfg
@@ -0,0 +1,20 @@
+--- ./arch/FreeBSD.cfg.orig Sun Jan 28 06:33:45 2007
++++ ./arch/FreeBSD.cfg Sun Feb 25 18:56:36 2007
+@@ -1,14 +1,14 @@
+-QMAKE = $(QTDIR)/bin/qmake
++QMAKE ?= $(QTDIR)/bin/qmake
+ LUPDATE = $(QTDIR)/bin/lupdate
+ LRELEASE = $(QTDIR)/bin/lrelease
+-MAKE = gmake
++MAKE ?= gmake
+ MKDIR = mkdir -p
+ RM = rm -f
+ LN = ln
+ RMDIR = rmdir
+ TIMECMD = time
+ CP = cp
+-RSYNC = rsync -a
++RSYNC = cp -r
+ OSNAME = FreeBSD
+ DATE = date +%Y%m%d%H%M%S
+ SED = sed
diff --git a/emulators/qmc2/pkg-descr b/emulators/qmc2/pkg-descr
new file mode 100644
index 000000000000..e54561d8202e
--- /dev/null
+++ b/emulators/qmc2/pkg-descr
@@ -0,0 +1,16 @@
+M.A.M.E. Catalog / Launcher II - also referred to as QMC2 - is the successor
+of one of the first XMAME GUI frontends available on this planet called
+QMamecat (derived from MAMECAT, which was text-only).
+
+QMamecat was based upon Qt 2; its development was frozen in 2003. QMC2 has
+been rebuilt from scratch as a Qt 4 project. Parts of the design and code were
+inspired by its predecessor, but it's not just a remake. We tried to make the
+new design as flexible as possible to minimize dependencies from frontend- and
+CLI-related MAME changes, which was a major deficiency of QMamecat. QMC2 now
+uses a template based MAME configuration scheme, which can easily be enhanced
+with additional command line options (defined in an XML template file).
+
+As a result of this flexible design, we are able to support multiple MAME
+targets - currently XMAME and SDLMAME!
+
+WWW: http://www.mameworld.net/mamecat/
diff --git a/emulators/qmc2/pkg-message b/emulators/qmc2/pkg-message
new file mode 100644
index 000000000000..a5f5fa14500d
--- /dev/null
+++ b/emulators/qmc2/pkg-message
@@ -0,0 +1,12 @@
+==============================================================================
+
+QMC2 has been installed.
+
+You can download game preview images (screenshots) at:
+
+http://www.mameworld.net/mamecat/download.html
+
+Extract them to a directory (like "~/.qmc/prv") and tell the program where to
+find them in the path configuration.
+
+==============================================================================
diff --git a/emulators/qmc2/pkg-plist b/emulators/qmc2/pkg-plist
new file mode 100644
index 000000000000..c030b6b62564
--- /dev/null
+++ b/emulators/qmc2/pkg-plist
@@ -0,0 +1,127 @@
+bin/qmc2
+@unexec cmp -s %D/etc/qmc2/qmc2.ini %D/etc/qmc2/qmc2.ini.sample && rm -f %D/etc/qmc2/qmc2.ini
+etc/qmc2/qmc2.ini.sample
+@exec test -f %D/etc/qmc2/qmc2.ini || cp %D/etc/qmc2/qmc2.ini.sample %D/etc/qmc2/qmc2.ini
+%%DATADIR%%/doc/html/de/changes.html
+%%DATADIR%%/doc/html/de/copying.html
+%%DATADIR%%/doc/html/de/credits.html
+%%DATADIR%%/doc/html/de/faq.html
+%%DATADIR%%/doc/html/de/img/balu.gif
+%%DATADIR%%/doc/html/de/img/jonas.gif
+%%DATADIR%%/doc/html/de/img/rene.gif
+%%DATADIR%%/doc/html/de/img/robert.gif
+%%DATADIR%%/doc/html/de/img/sammy.gif
+%%DATADIR%%/doc/html/de/img/sphere_blue.png
+%%DATADIR%%/doc/html/de/img/sphere_green.png
+%%DATADIR%%/doc/html/de/img/sphere_grey.png
+%%DATADIR%%/doc/html/de/img/sphere_red.png
+%%DATADIR%%/doc/html/de/img/sphere_yellowgreen.png
+%%DATADIR%%/doc/html/de/img/teddy.gif
+%%DATADIR%%/doc/html/de/index.html
+%%DATADIR%%/doc/html/de/readme.html
+%%DATADIR%%/doc/html/de/todo.html
+%%DATADIR%%/doc/html/us/changes.html
+%%DATADIR%%/doc/html/us/copying.html
+%%DATADIR%%/doc/html/us/credits.html
+%%DATADIR%%/doc/html/us/faq.html
+%%DATADIR%%/doc/html/us/img/balu.gif
+%%DATADIR%%/doc/html/us/img/jonas.gif
+%%DATADIR%%/doc/html/us/img/rene.gif
+%%DATADIR%%/doc/html/us/img/robert.gif
+%%DATADIR%%/doc/html/us/img/sammy.gif
+%%DATADIR%%/doc/html/us/img/sphere_blue.png
+%%DATADIR%%/doc/html/us/img/sphere_green.png
+%%DATADIR%%/doc/html/us/img/sphere_grey.png
+%%DATADIR%%/doc/html/us/img/sphere_red.png
+%%DATADIR%%/doc/html/us/img/sphere_yellowgreen.png
+%%DATADIR%%/doc/html/us/img/teddy.gif
+%%DATADIR%%/doc/html/us/index.html
+%%DATADIR%%/doc/html/us/readme.html
+%%DATADIR%%/doc/html/us/todo.html
+%%DATADIR%%/img/back.png
+%%DATADIR%%/img/camera.png
+%%DATADIR%%/img/cd.png
+%%DATADIR%%/img/clock.png
+%%DATADIR%%/img/colors.png
+%%DATADIR%%/img/configure.png
+%%DATADIR%%/img/controller.png
+%%DATADIR%%/img/down.png
+%%DATADIR%%/img/edit.png
+%%DATADIR%%/img/editcopy.png
+%%DATADIR%%/img/editcut.png
+%%DATADIR%%/img/editdelete.png
+%%DATADIR%%/img/editpaste.png
+%%DATADIR%%/img/edittrash.png
+%%DATADIR%%/img/exit.png
+%%DATADIR%%/img/favorites.png
+%%DATADIR%%/img/fileclose.png
+%%DATADIR%%/img/filefind.png
+%%DATADIR%%/img/filenew.png
+%%DATADIR%%/img/fileopen.png
+%%DATADIR%%/img/fileprint.png
+%%DATADIR%%/img/filesave.png
+%%DATADIR%%/img/filesaveas.png
+%%DATADIR%%/img/find.png
+%%DATADIR%%/img/fonts.png
+%%DATADIR%%/img/forward.png
+%%DATADIR%%/img/ghost.png
+%%DATADIR%%/img/help.png
+%%DATADIR%%/img/hint.png
+%%DATADIR%%/img/hint_small.png
+%%DATADIR%%/img/home.png
+%%DATADIR%%/img/info.png
+%%DATADIR%%/img/kill.png
+%%DATADIR%%/img/launch.png
+%%DATADIR%%/img/locale.png
+%%DATADIR%%/img/lock.png
+%%DATADIR%%/img/next-sail.png
+%%DATADIR%%/img/next.png
+%%DATADIR%%/img/no.png
+%%DATADIR%%/img/pencils.png
+%%DATADIR%%/img/previos-sail.png
+%%DATADIR%%/img/previous.png
+%%DATADIR%%/img/redo.png
+%%DATADIR%%/img/reload.png
+%%DATADIR%%/img/rom.png
+%%DATADIR%%/img/search.png
+%%DATADIR%%/img/sound.png
+%%DATADIR%%/img/sphere_blue.png
+%%DATADIR%%/img/sphere_green.png
+%%DATADIR%%/img/sphere_grey.png
+%%DATADIR%%/img/sphere_red.png
+%%DATADIR%%/img/sphere_yellowgreen.png
+%%DATADIR%%/img/stop.png
+%%DATADIR%%/img/terminate.png
+%%DATADIR%%/img/thumbnail.png
+%%DATADIR%%/img/time.png
+%%DATADIR%%/img/undo.png
+%%DATADIR%%/img/unlock.png
+%%DATADIR%%/img/up.png
+%%DATADIR%%/img/viewmag+.png
+%%DATADIR%%/img/viewmag-.png
+%%DATADIR%%/img/viewmagfit.png
+%%DATADIR%%/img/work.png
+%%DATADIR%%/img/yes.png
+%%DATADIR%%/lng/qmc2_de.qm
+%%DATADIR%%/lng/qt_de.qm
+%%DATADIR%%/opt/SDLMAME/template.xml
+%%DATADIR%%/opt/XMAME/template-SDL.xml
+%%DATADIR%%/opt/XMAME/template-X11-XV-OpenGL.xml
+%%DATADIR%%/opt/XMAME/template-all.xml
+%%DATADIR%%/opt/XMAME/template.xml
+%%DATADIR%%/opt/template.xml
+@dirrm %%DATADIR%%/prv
+@dirrm %%DATADIR%%/opt/XMAME
+@dirrm %%DATADIR%%/opt/SDLMAME
+@dirrm %%DATADIR%%/opt
+@dirrm %%DATADIR%%/lng
+@dirrm %%DATADIR%%/img
+@dirrm %%DATADIR%%/fly
+@dirrm %%DATADIR%%/doc/html/us/img
+@dirrm %%DATADIR%%/doc/html/us
+@dirrm %%DATADIR%%/doc/html/de/img
+@dirrm %%DATADIR%%/doc/html/de
+@dirrm %%DATADIR%%/doc/html
+@dirrm %%DATADIR%%/doc
+@dirrm %%DATADIR%%
+@dirrmtry etc/qmc2