aboutsummaryrefslogtreecommitdiff
path: root/emulators/qtemu
diff options
context:
space:
mode:
authorMartin Wilke <miwi@FreeBSD.org>2007-07-15 14:07:08 +0000
committerMartin Wilke <miwi@FreeBSD.org>2007-07-15 14:07:08 +0000
commitb2bcf7dda10f2d0a3a5add8e172305a85b58d058 (patch)
tree7c3f488ef5e067ce65364918f7cb6575b553768b /emulators/qtemu
parent3cfaa7007c5d342a3ae4c9e58ea59282ff4c79be (diff)
downloadports-b2bcf7dda10f2d0a3a5add8e172305a85b58d058.tar.gz
ports-b2bcf7dda10f2d0a3a5add8e172305a85b58d058.zip
Notes
Diffstat (limited to 'emulators/qtemu')
-rw-r--r--emulators/qtemu/Makefile13
-rw-r--r--emulators/qtemu/distinfo6
-rw-r--r--emulators/qtemu/files/patch-qtemu.pro18
-rw-r--r--emulators/qtemu/pkg-plist4
4 files changed, 18 insertions, 23 deletions
diff --git a/emulators/qtemu/Makefile b/emulators/qtemu/Makefile
index d4e8bc7b0371..c517e52f2352 100644
--- a/emulators/qtemu/Makefile
+++ b/emulators/qtemu/Makefile
@@ -6,15 +6,13 @@
#
PORTNAME= qtemu
-PORTVERSION= 1.0.3
+PORTVERSION= 1.0.4
CATEGORIES= emulators
MASTER_SITES= SF
MAINTAINER= makc@issp.ac.ru
COMMENT= A Qt4 front-end to Qemu
-WRKSRC= ${WRKDIR}/${PORTNAME}
-
USE_BZIP2= yes
USE_QT_VER= 4
QT_COMPONENTS= gui xml uic moc qmake rcc
@@ -29,23 +27,20 @@ DESKTOP_ENTRIES="QtEmu" "QEMU frontend" "" \
.if !defined(WITHOUT_NLS)
#QT_COMPONENTS+= linguist
BUILD_DEPENDS+= ${LOCALBASE}/bin/lupdate-qt4:${PORTSDIR}/devel/qt4-linguist
-QTI_LANG= cz de es ru tr
PLIST_SUB+= NLS=""
.else
PLIST_SUB+= NLS="@comment "
.endif
do-configure:
- (cd ${WRKSRC} && ${SETENV} ${CONFIGURE_ENV} ${QMAKE})
+ (cd ${WRKSRC} && ${LOCALBASE}/bin/lrelease-qt4 -verbose qtemu.pro \
+ && ${SETENV} ${CONFIGURE_ENV} ${QMAKE})
post-configure:
@${REINPLACE_CMD} -e \
's|^CC .*|CC=${CC}|; \
s|^CXX .*|CXX=${CXX}|; \
- s|^LINK .*|LINK=${CXX}|; \
- s|-pipe||; \
- s|^\(CFLAGS .*= \)|\1${CFLAGS}|; \
- s|^\(CXXFLAGS = \)|\1${CXXFLAGS}|' \
+ s|^LINK .*|LINK=${CXX}|' \
${WRKSRC}/Makefile
do-install:
diff --git a/emulators/qtemu/distinfo b/emulators/qtemu/distinfo
index fbb8f3533dd4..65d9f0cfa893 100644
--- a/emulators/qtemu/distinfo
+++ b/emulators/qtemu/distinfo
@@ -1,3 +1,3 @@
-MD5 (qtemu-1.0.3.tar.bz2) = 44560abe5b1df47f8ff6050d5864f453
-SHA256 (qtemu-1.0.3.tar.bz2) = b6db89fc88aced4453d17c0e52033846de72f36da16e9ff6659afb3397c959df
-SIZE (qtemu-1.0.3.tar.bz2) = 495051
+MD5 (qtemu-1.0.4.tar.bz2) = 4a29e0233c8b420b9581de68c6e0e93b
+SHA256 (qtemu-1.0.4.tar.bz2) = 51b230e9db005602b9c1c5a38c81999861d3fc0ab46f81311abf32bb61e07741
+SIZE (qtemu-1.0.4.tar.bz2) = 542624
diff --git a/emulators/qtemu/files/patch-qtemu.pro b/emulators/qtemu/files/patch-qtemu.pro
index 8f7aa525cabf..92b0e87249af 100644
--- a/emulators/qtemu/files/patch-qtemu.pro
+++ b/emulators/qtemu/files/patch-qtemu.pro
@@ -1,19 +1,17 @@
---- ./qtemu.pro.orig Mon Mar 19 15:56:21 2007
-+++ ./qtemu.pro Tue Jun 12 13:17:03 2007
-@@ -21,10 +21,12 @@
+--- ./qtemu.pro.orig Sat Jul 14 01:37:06 2007
++++ ./qtemu.pro Sat Jul 14 12:59:09 2007
+@@ -21,7 +21,7 @@
RC_FILE = qtemu.rc
}
TEMPLATE = app
-TRANSLATIONS = translations/template_qtemu.ts \
-- translations/qtemu_de.ts \
-+TRANSLATIONS = translations/qtemu_de.ts \
++TRANSLATIONS = \
+ translations/qtemu_de.ts \
translations/qtemu_tr.ts \
translations/qtemu_ru.ts \
- translations/qtemu_cz.ts \
+@@ -29,4 +29,4 @@
+ translations/qtemu_fr.ts \
+ translations/qtemu_it.ts \
translations/qtemu_es.ts
-CONFIG += debug_and_release
+CONFIG += release
-+
-+system($$(LOCALBASE)/bin/lupdate-qt4 -verbose qtemu.pro)
-+system($$(LOCALBASE)/bin/lrelease-qt4 -verbose qtemu.pro)
-\ No newline at end of file
diff --git a/emulators/qtemu/pkg-plist b/emulators/qtemu/pkg-plist
index 1c127a8f7f0d..ccc945ba544a 100644
--- a/emulators/qtemu/pkg-plist
+++ b/emulators/qtemu/pkg-plist
@@ -36,9 +36,11 @@ bin/qtemu
%%NLS%%%%DATADIR%%/translations/qtemu_cz.qm
%%NLS%%%%DATADIR%%/translations/qtemu_de.qm
%%NLS%%%%DATADIR%%/translations/qtemu_es.qm
+%%NLS%%%%DATADIR%%/translations/qtemu_fr.qm
+%%NLS%%%%DATADIR%%/translations/qtemu_it.qm
%%NLS%%%%DATADIR%%/translations/qtemu_ru.qm
%%NLS%%%%DATADIR%%/translations/qtemu_tr.qm
%%NLS%%@dirrm %%DATADIR%%/translations
-%%NLS%%@dirrm share/qtemu
+%%NLS%%@dirrm %%DATADIR%%
%%PORTDOCS%%@dirrm %%DOCSDIR%%/de
%%PORTDOCS%%@dirrm %%DOCSDIR%%