aboutsummaryrefslogtreecommitdiff
path: root/emulators/raine
diff options
context:
space:
mode:
authorDirk Meyer <dinoex@FreeBSD.org>2012-06-01 05:26:28 +0000
committerDirk Meyer <dinoex@FreeBSD.org>2012-06-01 05:26:28 +0000
commit2b74a89bc8342f0b9b737c37d87737caf7b0ea1e (patch)
treec04604583d8be53b3ed7f10975be828c731f87cb /emulators/raine
parent24315159daa0089f08acea4ba1b130fb6721ad5c (diff)
downloadports-2b74a89bc8342f0b9b737c37d87737caf7b0ea1e.tar.gz
ports-2b74a89bc8342f0b9b737c37d87737caf7b0ea1e.zip
Notes
Diffstat (limited to 'emulators/raine')
-rw-r--r--emulators/raine/Makefile4
-rw-r--r--emulators/raine/files/patch-patch-source_png_savepng.c11
-rw-r--r--emulators/raine/files/patch-source_png_loadpng.c29
3 files changed, 42 insertions, 2 deletions
diff --git a/emulators/raine/Makefile b/emulators/raine/Makefile
index 0381646d8dd3..3cee40691b56 100644
--- a/emulators/raine/Makefile
+++ b/emulators/raine/Makefile
@@ -7,7 +7,7 @@
PORTNAME= raine
PORTVERSION= 0.43.3
-PORTREVISION= 8
+PORTREVISION= 9
CATEGORIES= emulators games
MASTER_SITES= http://www.rainemu.com/html/archive/
DISTNAME= ${PORTNAME}s-${PORTVERSION}
@@ -17,7 +17,7 @@ COMMENT= Arcade Emulator for M68000, M68020 and Z80 based hardware
BUILD_DEPENDS= ${LOCALBASE}/bin/nasm:${PORTSDIR}/devel/nasm
LIB_DEPENDS= alleg.42:${PORTSDIR}/devel/allegro \
- png.6:${PORTSDIR}/graphics/png \
+ png15:${PORTSDIR}/graphics/png \
vga.1:${PORTSDIR}/graphics/svgalib
WRKSRC= ${WRKDIR}/${PORTNAME}-${PORTVERSION}
diff --git a/emulators/raine/files/patch-patch-source_png_savepng.c b/emulators/raine/files/patch-patch-source_png_savepng.c
new file mode 100644
index 000000000000..110b12470e39
--- /dev/null
+++ b/emulators/raine/files/patch-patch-source_png_savepng.c
@@ -0,0 +1,11 @@
+--- source/png/savepng.c.orig 2005-08-17 12:20:36.000000000 +0200
++++ source/png/savepng.c 2012-05-06 17:19:09.000000000 +0200
+@@ -188,7 +188,7 @@
+ goto Error;
+
+ /* Set error handling. */
+- if (setjmp(png_ptr->jmpbuf)) {
++ if (setjmp(png_jmpbuf(png_ptr))) {
+ /* If we get here, we had a problem reading the file. */
+ goto Error;
+ }
diff --git a/emulators/raine/files/patch-source_png_loadpng.c b/emulators/raine/files/patch-source_png_loadpng.c
new file mode 100644
index 000000000000..87bc1b566d0f
--- /dev/null
+++ b/emulators/raine/files/patch-source_png_loadpng.c
@@ -0,0 +1,29 @@
+--- source/png/loadpng.c.orig 2005-08-18 10:52:15.000000000 +0200
++++ source/png/loadpng.c 2012-05-06 15:58:26.000000000 +0200
+@@ -275,7 +275,7 @@
+ * the normal method of doing things with libpng). REQUIRED unless you
+ * set up your own error handlers in the png_create_read_struct() earlier.
+ */
+- if (setjmp(png_ptr->jmpbuf)) {
++ if (setjmp(png_jmpbuf(png_ptr))) {
+ /* Free all of the memory associated with the png_ptr and info_ptr */
+ png_destroy_read_struct(&png_ptr, &info_ptr, (png_infopp)NULL);
+ pack_fclose(fp);
+@@ -337,7 +337,7 @@
+ * the normal method of doing things with libpng). REQUIRED unless you
+ * set up your own error handlers in the png_create_read_struct() earlier.
+ */
+- if (setjmp(png_ptr->jmpbuf)) {
++ if (setjmp(png_jmpbuf(png_ptr))) {
+ /* Free all of the memory associated with the png_ptr and info_ptr */
+ png_destroy_read_struct(&png_ptr, &info_ptr, (png_infopp)NULL);
+ /* If we get here, we had a problem reading the file */
+@@ -435,7 +435,7 @@
+ * the normal method of doing things with libpng). REQUIRED unless you
+ * set up your own error handlers in the png_create_read_struct() earlier.
+ */
+- if (setjmp(png_ptr->jmpbuf)) {
++ if (setjmp(png_jmpbuf(png_ptr))) {
+ /* Free all of the memory associated with the png_ptr and info_ptr */
+ png_destroy_read_struct(&png_ptr, &info_ptr, (png_infopp)NULL);
+ /* If we get here, we had a problem reading the file */