aboutsummaryrefslogtreecommitdiff
path: root/emulators/rtc
diff options
context:
space:
mode:
authorAkinori MUSHA <knu@FreeBSD.org>2000-08-24 14:51:20 +0000
committerAkinori MUSHA <knu@FreeBSD.org>2000-08-24 14:51:20 +0000
commitf5e6c15f383ec0bf345d73995cb9f1444d7a4ebf (patch)
treef006d7c32e8ab10435efa539a89e4676069dc332 /emulators/rtc
parenta407b4fe8c1540751f0dbeb16e596a6d64b95c32 (diff)
downloadports-f5e6c15f383ec0bf345d73995cb9f1444d7a4ebf.tar.gz
ports-f5e6c15f383ec0bf345d73995cb9f1444d7a4ebf.zip
Notes
Diffstat (limited to 'emulators/rtc')
-rw-r--r--emulators/rtc/Makefile8
-rw-r--r--emulators/rtc/files/rtc_linux.c2
2 files changed, 8 insertions, 2 deletions
diff --git a/emulators/rtc/Makefile b/emulators/rtc/Makefile
index 8d3ab9b85f36..0e3ca74c995d 100644
--- a/emulators/rtc/Makefile
+++ b/emulators/rtc/Makefile
@@ -6,7 +6,7 @@
#
PORTNAME= rtc
-PORTVERSION= 2000.05.05
+PORTVERSION= 2000.08.24
CATEGORIES= emulators linux
MASTER_SITES= # none
DISTFILES= # none
@@ -44,6 +44,12 @@ do-extract:
${FILESDIR}/${STARTUP} > ${WRKDIR}/${STARTUP}
@cd ${FILESDIR} && ${CP} Makefile *.[ch] ${WRKSRC}/
+post-patch:
+.if !exists(/sys/compat/linux/linux_ioctl.h)
+ ${PERL} -i -pe 's,compat(/linux/linux_ioctl\.h),i386$$1,' \
+ ${WRKSRC}/rtc_linux.c
+.endif
+
pre-install:
${MKDIR} ${KMODDIR}
${MKDIR} ${DEVDIR}
diff --git a/emulators/rtc/files/rtc_linux.c b/emulators/rtc/files/rtc_linux.c
index 2eb04a433890..df112d87212d 100644
--- a/emulators/rtc/files/rtc_linux.c
+++ b/emulators/rtc/files/rtc_linux.c
@@ -33,7 +33,7 @@
#include <i386/linux/linux.h>
#include <i386/linux/linux_proto.h>
-#include <i386/linux/linux_ioctl.h>
+#include <compat/linux/linux_ioctl.h>
#include "rtc.h"