aboutsummaryrefslogtreecommitdiff
path: root/emulators/simh
diff options
context:
space:
mode:
authorAlex Kozlov <ak@FreeBSD.org>2017-04-10 10:26:49 +0000
committerAlex Kozlov <ak@FreeBSD.org>2017-04-10 10:26:49 +0000
commitf3463c55b4f801bf62c1ed08a15ded1652f85577 (patch)
treefab0138ed725efaabd9e887746d2d04f7348e37b /emulators/simh
parentd361465ad5a8dc1f83d62e4752dd0bfac92ed94a (diff)
downloadports-f3463c55b4f801bf62c1ed08a15ded1652f85577.tar.gz
ports-f3463c55b4f801bf62c1ed08a15ded1652f85577.zip
Notes
Diffstat (limited to 'emulators/simh')
-rw-r--r--emulators/simh/Makefile20
-rw-r--r--emulators/simh/distinfo3
-rw-r--r--emulators/simh/files/pkg-message.in6
-rw-r--r--emulators/simh/files/simh.1.in105
-rw-r--r--emulators/simh/pkg-descr3
-rw-r--r--emulators/simh/pkg-plist1
6 files changed, 129 insertions, 9 deletions
diff --git a/emulators/simh/Makefile b/emulators/simh/Makefile
index 981862309570..b6e3c18d67f9 100644
--- a/emulators/simh/Makefile
+++ b/emulators/simh/Makefile
@@ -3,10 +3,14 @@
PORTNAME= simh
PORTVERSION= 3.9.0
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= emulators
-MASTER_SITES= http://simh.trailing-edge.com/sources/
+MASTER_SITES= http://simh.trailing-edge.com/sources/:src \
+ http://www.ml1.org.uk/distfiles/:pdf \
+ http://www.ancientgeek.org.uk/distfiles/:pdf
DISTNAME= ${PORTNAME}v${PORTVERSION:R:S/.//}-${PORTVERSION:E}
+DISTFILES= ${PORTNAME}v${PORTVERSION:R:S/.//}-${PORTVERSION:E}.zip:src \
+ ${PORTNAME}_docpdf.zip:pdf
MAINTAINER= bob@eager.cx
COMMENT= Emulates classic DEC, HP, GRI, IBM, Altair, SDS, Honeywell, and others
@@ -16,13 +20,15 @@ LICENSE= BSD3CLAUSE
NO_WRKSUBDIR= yes
USES= gmake dos2unix zip
+DOS2UNIX_GLOB= *.c *.h *.txt *.mak *.ini makefile
CFLAGS+= -Wno-format-extra-args -Wno-comment -Wno-logical-op-parentheses -Wno-bitwise-op-parentheses
MAKE_ENV= GCC="${CC}" CFLAGS_O="${CFLAGS}" USE_NETWORK=1
MAKEFILE= makefile
-SUB_FILES= pkg-message
+SUB_FILES= pkg-message simh.1
-PORTDOCS= 0readme_${PORTVERSION:R:S/.//}.txt 0readme_ethernet.txt
+READMES= 0readme_${PORTVERSION:R:S/.//}.txt 0readme_ethernet.txt
+PORTDOCS= ${READMES} pdf/*
OPTIONS_DEFINE= DOCS
@@ -44,9 +50,11 @@ do-install:
${INSTALL_PROGRAM} ${WRKSRC}/BIN/* ${STAGEDIR}${PREFIX}/bin
@${MKDIR} ${STAGEDIR}${DATADIR}
${INSTALL_DATA} ${WRKSRC}/VAX/ka655x.bin ${STAGEDIR}${DATADIR}
+ ${INSTALL_MAN} ${WRKDIR}/simh.1 ${STAGEDIR}${MANPREFIX}/man/man1
do-install-DOCS-on:
- @${MKDIR} ${STAGEDIR}${DOCSDIR}
- (cd ${WRKSRC} && ${INSTALL_DATA} ${PORTDOCS} ${STAGEDIR}${DOCSDIR})
+ @${MKDIR} ${STAGEDIR}${DOCSDIR}/pdf
+ (cd ${WRKSRC} && ${INSTALL_DATA} ${READMES} ${STAGEDIR}${DOCSDIR})
+ (cd ${WRKSRC} && ${COPYTREE_SHARE} pdf ${STAGEDIR}${DOCSDIR})
.include <bsd.port.mk>
diff --git a/emulators/simh/distinfo b/emulators/simh/distinfo
index 4c4e61058c39..7cc8aa398390 100644
--- a/emulators/simh/distinfo
+++ b/emulators/simh/distinfo
@@ -1,2 +1,5 @@
+TIMESTAMP = 1490544722
SHA256 (simhv39-0.zip) = e49b259b66ad6311ca9066dee3d3693cd915106a6938a52ed685cdbada8eda3b
SIZE (simhv39-0.zip) = 3103657
+SHA256 (simh_docpdf.zip) = dff83e9a55f5e8bc2364489d6cc2a6731c60237acf37f4c46f080914896f8a0c
+SIZE (simh_docpdf.zip) = 2282195
diff --git a/emulators/simh/files/pkg-message.in b/emulators/simh/files/pkg-message.in
index ed8820bf1020..9ca73c2f4ec4 100644
--- a/emulators/simh/files/pkg-message.in
+++ b/emulators/simh/files/pkg-message.in
@@ -1,5 +1,9 @@
*********************************************************************
-The file needed by the VAX emulator is located in %%DATADIR%%
+The 'eclipse' emulator has been renamed to 'simh-eclipse'.
+
+The file needed by the VAX emulator is located in:
+
+ %%DATADIR%%
*********************************************************************
diff --git a/emulators/simh/files/simh.1.in b/emulators/simh/files/simh.1.in
new file mode 100644
index 000000000000..76162996b249
--- /dev/null
+++ b/emulators/simh/files/simh.1.in
@@ -0,0 +1,105 @@
+.Dd March 26, 2017
+.Dt SIMH 1 CON
+.Os
+.Sh NAME
+.Nm simh
+.Nd Simulation suite for various computer systems
+.Sh SYNOPSIS
+.Nm
+.Op Fl e
+.Op Fl q
+.Op Fl v
+.Oo
+.Ar startup-file
+.Op Ar arguments
+.Oc
+.Sh DESCRIPTION
+.Nm
+is a comprehensive suite of simulators for a number of legacy computer systems.
+.Pp
+Note that there is no actual
+.Nm
+command; each simulator is invoked with its own command.
+Currently, the
+available commands are:
+.Bd -ragged -offset indent
+.Sy altair ,
+.Sy altairz80 ,
+.Sy gri ,
+.Sy h316 ,
+.Sy hp2100 ,
+.Sy i1401 ,
+.Sy i1620 ,
+.Sy i7094 ,
+.Sy ibm1130 ,
+.Sy id16 ,
+.Sy id32 ,
+.Sy lgp ,
+.Sy nova ,
+.Sy pdp1 ,
+.Sy pdp10 ,
+.Sy pdp11 ,
+.Sy pdp15 ,
+.Sy pdp4 ,
+.Sy pdp7 ,
+.Sy pdp8 ,
+.Sy pdp9 ,
+.Sy s3 ,
+.Sy sds ,
+.Sy simh-eclipse ,
+.Sy swtp6800mp-a ,
+.Sy swtp6800mp-a2 ,
+.Sy vax ,
+.Sy vax780 .
+.Ed
+.Pp
+The following options are available for all of the commands:
+.Bl -tag -width indent
+.It Fl e
+Processing of
+.Ar startup-file
+(including nested command invocations) is aborted if
+a command error is encountered.
+.It Fl q
+Certain informational messages are suppressed.
+.It Fl v
+The commands in
+.Ar startup-file
+are echoed before they are executed.
+.El
+.Pp
+If
+.Ar startup-file
+is specified, it is used as an initial source of simulator commands.
+If
+.Ar startup-file
+is not specified,
+the simulator looks for a startup file consisting of the simulator
+name (including its path components) plus the extension
+.Pa .ini .
+.Pp
+If a startup file is specified, either on the
+command line or implicitly via the
+.Pa .ini
+capability, it should contain a series of non-interactive simulator
+commands, one per line.
+These commands can be used to set up standard parameters, for example disk
+sizes.
+.Pp
+After initializing its internal structures and processing the startup file (if any),
+the simulator types out its name and version and then prompts for input with:
+.Bd -ragged -offset indent
+.Sy sim>
+.Ed
+.Sh EXIT STATUS
+.Nm
+exits 0 on success, and >0 if an error occurs.
+.Sh SEE ALSO
+Documentation is available for each of the simulators. There is
+also generic simulator documentation. It can be found locally in
+.Pa %%DOCSDIR%%
+(if installed), and also at
+.Pa http://simh.trailing-edge.com/pdf/all_docs.html .
+.Sh AUTHORS
+.An "Robert M. Supnik and many others" .
+.Fx "port maintenance, and this manual page, by" An "Bob Eager" Aq bob@eager.cx .
diff --git a/emulators/simh/pkg-descr b/emulators/simh/pkg-descr
index 6216d2e36ab6..2174750b8076 100644
--- a/emulators/simh/pkg-descr
+++ b/emulators/simh/pkg-descr
@@ -14,7 +14,6 @@ SIMH implements simulators for:
- Scientific Data Systems SDS 940
These simulators are capable of running the Unix V5, V6 and V7 binaries
-licenced for non-commercial use by SCO. See ${WRKDIR}/simh_doc.txt for
-further details.
+licenced for non-commercial use by SCO. See documentation for further details.
WWW: http://simh.trailing-edge.com
diff --git a/emulators/simh/pkg-plist b/emulators/simh/pkg-plist
index 2ca5c0e0b15c..7613f8f31ee4 100644
--- a/emulators/simh/pkg-plist
+++ b/emulators/simh/pkg-plist
@@ -26,4 +26,5 @@ bin/swtp6800mp-a
bin/swtp6800mp-a2
bin/vax
bin/vax780
+man/man1/simh.1.gz
%%DATADIR%%/ka655x.bin