aboutsummaryrefslogtreecommitdiff
path: root/emulators/skyeye/files
diff options
context:
space:
mode:
authorPav Lucistnik <pav@FreeBSD.org>2005-07-28 13:20:05 +0000
committerPav Lucistnik <pav@FreeBSD.org>2005-07-28 13:20:05 +0000
commit522698182ccbd963914f95ca6c16358bb23c7f7f (patch)
tree76c2454c9de67a4a5eec28b77e3a3d5145b5c7d4 /emulators/skyeye/files
parent00bb43d38e0be42e61af7498afa04737bf63b0de (diff)
Notes
Diffstat (limited to 'emulators/skyeye/files')
-rw-r--r--emulators/skyeye/files/patch-Makefile.in51
-rw-r--r--emulators/skyeye/files/patch-etc_Makefile.in11
-rw-r--r--emulators/skyeye/files/patch-gdb_doc_Makefile.in10
-rw-r--r--emulators/skyeye/files/patch-sim_arm_armdefs.h24
-rw-r--r--emulators/skyeye/files/patch-sim_arm_configure12
-rw-r--r--emulators/skyeye/files/patch-sim_arm_skyeye-ne2k.c27
-rw-r--r--emulators/skyeye/files/patch-sim_arm_skyeye_net_tuntap.c68
-rw-r--r--emulators/skyeye/files/patch-sim_arm_skyeye_net_vnet.c15
-rw-r--r--emulators/skyeye/files/patch-tcl_unix_Makefile.in19
-rw-r--r--emulators/skyeye/files/patch-usegtk-1.2.sh9
-rw-r--r--emulators/skyeye/files/patch-usegtk-2.0.sh9
11 files changed, 255 insertions, 0 deletions
diff --git a/emulators/skyeye/files/patch-Makefile.in b/emulators/skyeye/files/patch-Makefile.in
new file mode 100644
index 000000000000..cbb5adb97b9e
--- /dev/null
+++ b/emulators/skyeye/files/patch-Makefile.in
@@ -0,0 +1,51 @@
+--- Makefile.in.orig Tue Jul 19 22:33:06 2005
++++ Makefile.in Tue Jul 19 22:36:07 2005
+@@ -668,7 +668,6 @@
+ install-autoconf \
+ install-automake \
+ install-bash \
+- install-bfd \
+ install-bzip2 \
+ install-opcodes \
+ install-binutils \
+@@ -693,9 +692,6 @@
+ install-gzip \
+ install-hello \
+ install-indent \
+- install-intl \
+- install-tcl \
+- install-itcl \
+ install-ld \
+ install-libgui \
+ install-libiberty \
+@@ -707,7 +703,6 @@
+ install-perl \
+ install-prms \
+ install-rcs \
+- install-readline \
+ install-recode \
+ install-sed \
+ install-send-pr \
+@@ -748,10 +743,7 @@
+ INSTALL_X11_MODULES = \
+ install-gdb \
+ install-guile \
+- install-expect \
+- install-tclX \
+- install-tk \
+- install-tix
++ install-expect
+
+ # This is a list of the targets for all of the modules which are compiled
+ # using $(TARGET_FLAGS_TO_PASS).
+@@ -1755,8 +1747,8 @@
+ all-target-libiberty: configure-target-libiberty
+ all-target: $(ALL_TARGET_MODULES)
+ install-target: $(INSTALL_TARGET_MODULES)
+-install-gdb: install-tcl install-tk install-itcl install-tix install-libgui
+-install-sid: install-tcl install-tk
++install-gdb:
++install-sid:
+ ### other supporting targets
+
+ MAKEDIRS= \
diff --git a/emulators/skyeye/files/patch-etc_Makefile.in b/emulators/skyeye/files/patch-etc_Makefile.in
new file mode 100644
index 000000000000..4807e076e2e0
--- /dev/null
+++ b/emulators/skyeye/files/patch-etc_Makefile.in
@@ -0,0 +1,11 @@
+--- etc/Makefile.in.orig Tue Jul 19 23:03:00 2005
++++ etc/Makefile.in Tue Jul 19 23:03:14 2005
+@@ -52,7 +52,7 @@
+ all:
+
+ # We want install to imply install-info as per GNU standards.
+-install: install-info
++install:
+
+ uninstall:
+
diff --git a/emulators/skyeye/files/patch-gdb_doc_Makefile.in b/emulators/skyeye/files/patch-gdb_doc_Makefile.in
new file mode 100644
index 000000000000..873cada9c1b3
--- /dev/null
+++ b/emulators/skyeye/files/patch-gdb_doc_Makefile.in
@@ -0,0 +1,10 @@
+--- gdb/doc/Makefile.in.orig Tue Jul 19 22:38:16 2005
++++ gdb/doc/Makefile.in Tue Jul 19 22:38:36 2005
+@@ -449,6 +449,6 @@
+ maintainer-clean realclean: distclean
+ rm -f GDBvn.texi *.info* *.dvi *.ps *.html *.pdf
+
+-install: install-info
++install:
+
+ uninstall: uninstall-info
diff --git a/emulators/skyeye/files/patch-sim_arm_armdefs.h b/emulators/skyeye/files/patch-sim_arm_armdefs.h
new file mode 100644
index 000000000000..128895d7afe2
--- /dev/null
+++ b/emulators/skyeye/files/patch-sim_arm_armdefs.h
@@ -0,0 +1,24 @@
+--- sim/arm/armdefs.h.orig Wed May 11 22:10:09 2005
++++ sim/arm/armdefs.h Sat Jul 16 18:25:48 2005
+@@ -22,6 +22,13 @@
+ #include <stdlib.h>
+ #include <errno.h>
+
++
++#ifdef __FreeBSD__
++#include <sys/select.h>
++#define MAP_ANONYMOUS MAP_ANON
++#endif
++
++
+ //teawater add for arm2x86 2005.02.14-------------------------------------------
+ #include <sys/mman.h>
+ //AJ2D--------------------------------------------------------------------------
+@@ -63,6 +70,7 @@
+ typedef unsigned char uint8_t;
+ typedef unsigned short uint16_t;
+ typedef unsigned int uint32_t;
++typedef int int32_t;
+ #if defined (__x86_64__)
+ typedef unsigned long uint64_t;
+ #else
diff --git a/emulators/skyeye/files/patch-sim_arm_configure b/emulators/skyeye/files/patch-sim_arm_configure
new file mode 100644
index 000000000000..63abe035eb47
--- /dev/null
+++ b/emulators/skyeye/files/patch-sim_arm_configure
@@ -0,0 +1,12 @@
+--- sim/arm/configure.orig Wed Jul 20 13:40:44 2005
++++ sim/arm/configure Wed Jul 20 13:42:23 2005
+@@ -3620,7 +3620,8 @@
+ echo "$ac_t""no" 1>&6
+ fi
+ #2004-09-29 chy define GTK_CONFIG
+- GTK_CONFIG=/usr/bin/pkg-config
++# GTK_CONFIG=/usr/bin/pkg-config
++ GTK_CONFIG=/usr/local/bin/pkg-config
+ min_gtk_version=1.1.3
+ echo $ac_n "checking for GTK - version >= $min_gtk_version""... $ac_c" 1>&6
+ echo "configure:3626: checking for GTK - version >= $min_gtk_version" >&5
diff --git a/emulators/skyeye/files/patch-sim_arm_skyeye-ne2k.c b/emulators/skyeye/files/patch-sim_arm_skyeye-ne2k.c
new file mode 100644
index 000000000000..86a7c6b24763
--- /dev/null
+++ b/emulators/skyeye/files/patch-sim_arm_skyeye-ne2k.c
@@ -0,0 +1,27 @@
+--- sim/arm/skyeye-ne2k.c.orig Tue Mar 1 14:51:24 2005
++++ sim/arm/skyeye-ne2k.c Sat Jul 16 18:17:14 2005
+@@ -26,13 +26,23 @@
+ * 02/25/2003 initial version
+ * yangye <yangye@163.net>
+ */
+-
++#ifdef __linux__
+ //#include <linux/if.h>
+ #include <net/if.h>
+ #include <linux/if_tun.h>
+ //#include <sys/types.h>
+ //#include <sys/stat.h>
+ //#include <fcntl.h>
++#endif
++
++#ifdef __FreeBSD__
++#include <sys/types.h>
++#include <sys/socket.h>
++#include <net/if.h>
++#include <net/if_tun.h>
++#endif
++
++
+ #include <sys/ioctl.h>
+ #include <armdefs.h>
+ #include <clps7110.h>
diff --git a/emulators/skyeye/files/patch-sim_arm_skyeye_net_tuntap.c b/emulators/skyeye/files/patch-sim_arm_skyeye_net_tuntap.c
new file mode 100644
index 000000000000..f227b65cec86
--- /dev/null
+++ b/emulators/skyeye/files/patch-sim_arm_skyeye_net_tuntap.c
@@ -0,0 +1,68 @@
+--- sim/arm/skyeye_net_tuntap.c.orig Tue Mar 1 14:51:24 2005
++++ sim/arm/skyeye_net_tuntap.c Sat Jul 16 18:22:57 2005
+@@ -26,8 +26,19 @@
+ * chenyu <chenyu@hpclab.cs.tsinghua.edu.cn>
+ */
+
++#ifdef __linux__
+ #include <net/if.h>
+ #include <linux/if_tun.h>
++#endif
++
++#ifdef __FreeBSD__
++#include <sys/socket.h>
++#include <net/if.h>
++#include <net/if_tun.h>
++#include <fcntl.h>
++#endif
++
++
+ #include <sys/ioctl.h>
+ #include "armdefs.h"
+
+@@ -51,7 +62,7 @@
+ DBG_PRINT("tapif_init begin\n");
+
+ firsttime++;
+-
++#ifdef __linux__
+ //tapif_fd = open("/dev/net/tun", O_RDWR);
+ tapif_fd = open("/dev/net/tun", 2);
+ DBG_PRINT("tapif_init: fd %d\n", tapif_fd);
+@@ -68,13 +79,36 @@
+ exit(1);
+ //return ;
+ }
++#endif
+
++#ifdef __FreeBSD__
++ tapif_fd = open("/dev/tap", O_RDWR);
++ DBG_PRINT("tapif_init: fd %d\n", tapif_fd);
++ if(tapif_fd == -1) {
++ perror("tapif_init:open");
++ printf("-----------------------------------------------------------\n");
++ printf("NOTICE: You should run as root if you require network\n");
++ printf("NOTICE: load the kernel tap module with 'kldload if_tap'\n");
++ printf("NOTICE: and execute 'cat /dev/tap'. there should be a \n");
++ printf("NOTICE: device node under /dev/ (e.g. /dev/tap0).\n");
++ printf("-----------------------------------------------------------\n");
++ exit(1);
++ }
++#endif
++
++#if !defined(__FreeBSD__)&&!defined(__linux__)
++ printf("NOTICE: No network support for your OS(yet). Bugging out!\n");
++ exit(1);
++#endif
++
++#ifndef __FreeBSD__
+ memset(&ifr, 0, sizeof(ifr));
+ ifr.ifr_flags = IFF_TAP|IFF_NO_PI;
+ if (ioctl(tapif_fd, TUNSETIFF, (void *) &ifr) < 0) {
+ perror("tapif_init: icotl TUNSETIFF error");
+ exit(-1);
+ }
++#endif
+
+ if(firsttime==1){
+ snprintf(buf, sizeof(buf), "ifconfig tap0 inet %d.%d.%d.%d",
diff --git a/emulators/skyeye/files/patch-sim_arm_skyeye_net_vnet.c b/emulators/skyeye/files/patch-sim_arm_skyeye_net_vnet.c
new file mode 100644
index 000000000000..58c09e3d8766
--- /dev/null
+++ b/emulators/skyeye/files/patch-sim_arm_skyeye_net_vnet.c
@@ -0,0 +1,15 @@
+--- sim/arm/skyeye_net_vnet.c.orig Tue Mar 1 14:51:24 2005
++++ sim/arm/skyeye_net_vnet.c Sat Jul 16 18:23:34 2005
+@@ -26,6 +26,12 @@
+ * chenyu <chenyu@hpclab.cs.tsinghua.edu.cn>
+ */
+ #include <fcntl.h>
++
++#ifdef __FreeBSD__
++#include <sys/socket.h>
++#endif
++
++
+ #include <net/if.h>
+ //#include <linux/if_tun.h>
+ #include <sys/ioctl.h>
diff --git a/emulators/skyeye/files/patch-tcl_unix_Makefile.in b/emulators/skyeye/files/patch-tcl_unix_Makefile.in
new file mode 100644
index 000000000000..7dcc2afc09bd
--- /dev/null
+++ b/emulators/skyeye/files/patch-tcl_unix_Makefile.in
@@ -0,0 +1,19 @@
+*** tcl/unix/Makefile.in.orig Tue Jul 19 00:29:52 2005
+--- tcl/unix/Makefile.in Mon Jul 18 00:08:02 2005
+***************
+*** 194,200 ****
+ # once we have created the initial executable, but in some cases you
+ # may want to use a target without having made tclsh on these sources
+ # (like for make genstubs)
+! TCL_EXE = tclsh
+
+ # The symbols below provide support for dynamic loading and shared
+ # libraries. See configure.in for a description of what the
+--- 194,200 ----
+ # once we have created the initial executable, but in some cases you
+ # may want to use a target without having made tclsh on these sources
+ # (like for make genstubs)
+! TCL_EXE = tclsh${VERSION}
+
+ # The symbols below provide support for dynamic loading and shared
+ # libraries. See configure.in for a description of what the
diff --git a/emulators/skyeye/files/patch-usegtk-1.2.sh b/emulators/skyeye/files/patch-usegtk-1.2.sh
new file mode 100644
index 000000000000..71ebc9234dc6
--- /dev/null
+++ b/emulators/skyeye/files/patch-usegtk-1.2.sh
@@ -0,0 +1,9 @@
+--- usegtk-1.2.sh.orig Wed Jul 20 13:28:34 2005
++++ usegtk-1.2.sh Wed Jul 20 13:29:18 2005
+@@ -1,5 +1,5 @@
+ #! /bin/sh
+ cp gdb/Makefile.in.gtk-1.2 gdb/Makefile.in
+ cp sim/arm/Makefile.in.gtk-1.2 sim/arm/Makefile.in
+-cp sim/arm/configure.gtk-1.2 sim/arm/configure
++cp sim/arm/configure.gtk1.2 sim/arm/configure
+
diff --git a/emulators/skyeye/files/patch-usegtk-2.0.sh b/emulators/skyeye/files/patch-usegtk-2.0.sh
new file mode 100644
index 000000000000..a28f79c782ad
--- /dev/null
+++ b/emulators/skyeye/files/patch-usegtk-2.0.sh
@@ -0,0 +1,9 @@
+--- usegtk-2.0.sh.orig Wed Jul 20 13:28:03 2005
++++ usegtk-2.0.sh Wed Jul 20 13:25:21 2005
+@@ -1,5 +1,5 @@
+ #! /bin/sh
+ cp gdb/Makefile.in.gtk-2.0 gdb/Makefile.in
+ cp sim/arm/Makefile.in.gtk-2.0 sim/arm/Makefile.in
+-cp sim/arm/configure.gtk-2.0 sim/arm/configure
++cp sim/arm/configure.gtk2.0 sim/arm/configure
+