aboutsummaryrefslogtreecommitdiff
path: root/emulators/snes9x-gtk
diff options
context:
space:
mode:
authorMartin Wilke <miwi@FreeBSD.org>2010-01-27 22:30:47 +0000
committerMartin Wilke <miwi@FreeBSD.org>2010-01-27 22:30:47 +0000
commit2d8ad5d2b5687225466bebc20f0489459730f4c7 (patch)
treeaef0bb0e0dc85ef92f08516426a4878c678e3d12 /emulators/snes9x-gtk
parent544e10f1580508a609a058df90d66b3ca8b1e2a3 (diff)
Notes
Diffstat (limited to 'emulators/snes9x-gtk')
-rw-r--r--emulators/snes9x-gtk/Makefile120
-rw-r--r--emulators/snes9x-gtk/distinfo3
-rw-r--r--emulators/snes9x-gtk/pkg-descr3
-rw-r--r--emulators/snes9x-gtk/pkg-plist6
4 files changed, 132 insertions, 0 deletions
diff --git a/emulators/snes9x-gtk/Makefile b/emulators/snes9x-gtk/Makefile
new file mode 100644
index 000000000000..bd0111440ab3
--- /dev/null
+++ b/emulators/snes9x-gtk/Makefile
@@ -0,0 +1,120 @@
+# New ports collection makefile for: snes9x-gtk
+# Date created: 2009-12-12
+# Whom: okeeblow <root@cooltrainer.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= snes9x
+PORTVERSION= 1.51r78
+CATEGORIES= emulators
+MASTER_SITES= http://snes9x-gtk.googlecode.com/files/
+PKGNAMESUFFIX= -gtk
+DISTNAME= snes9x-1.51-src-gtk-78
+
+MAINTAINER= root@cooltrainer.org
+COMMENT= Super Nintendo Entertainment System(SNES) Emulator
+
+LIB_DEPENDS= png.5:${PORTSDIR}/graphics/png
+
+USE_PERL= 5.8.1+
+USE_BZIP2= yes
+USE_XORG= x11 sm ice xext
+USE_GMAKE= yes
+USE_GNOME= gtk20 desktopfileutils pkgconfig intltool libglade2 libxml2
+GNU_CONFIGURE= yes
+USE_GETTEXT= yes
+USE_SDL= sdl
+CONFIGURE_ENV+= CPPFLAGS="-I${LOCALBASE}/include" \
+ LDFLAGS="-L${LOCALBASE}/lib"
+
+WRKSRC= ${WRKDIR}/snes9x-1.51-src/gtk
+
+OPTIONS= DEBUG "Enable debug information" off \
+ OPENGL "Enable OpenGL support" off \
+ SCREENSHOT "Enable screenshot support" on \
+ X86_ASM "Use i386 optimization (only for i386)" on \
+ MMX "Enable MMX (only for i386)" off \
+ JMA "Enable JMA archive decompression support" on \
+ NETPLAY "Enable network support" on \
+ XV "Enable XVideo output on GTK" on \
+ XRANDR "Enable XRandR support on GTK" on
+
+.include <bsd.port.pre.mk>
+
+.if defined(WITH_DEBUG)
+CONFIGURE_ARGS+= --with-debug
+.else
+CONFIGURE_ARGS+= --without-debug
+.endif
+
+.if ${ARCH} == "i386"
+.if !defined(WITHOUT_X86_ASM)
+BUILD_DEPENDS+= nasm:${PORTSDIR}/devel/nasm
+CONFIGURE_ARGS+= --with-assembler
+.else
+CONFIGURE_ARGS+= --without-assembler
+.endif
+
+.if defined(WITH_MMX) && !defined(PACKAGE_BUILDING)
+CONFIGURE_ARGS+= --with-mmx
+.else
+CONFIGURE_ARGS+= --without-mmx
+.endif
+.endif
+
+.if !defined(WITHOUT_OPENGL)
+CONFIGURE_ARGS+= --with-opengl
+USE_GL= glu
+.else
+CONFIGURE_ARGS+= --without-opengl
+.endif
+
+.if !defined(WITHOUT_SCREENSHOT)
+LIB_DEPENDS+= png.5:${PORTSDIR}/graphics/png
+CONFIGURE_ARGS+= --with-screenshot
+.else
+CONFIGURE_ARGS+= --without-screenshot
+.endif
+
+.if !defined(WITHOUT_JMA)
+CONFIGURE_ARGS+= --with-jma-decomp
+.else
+CONFIGURE_ARGS+= --without-jma-decomp
+.endif
+
+.if !defined(WITHOUT_NETPLAY)
+CONFIGURE_ARGS+= --with-netplay
+.else
+CONFIGURE_ARGS+= --without-netplay
+.endif
+
+.if !defined(WITHOUT_XV)
+CONFIGURE_ARGS+= --with-xv
+USE_XORG+= xv
+.else
+CONFIGURE_ARGS+= --without-xv
+.endif
+
+.if !defined(WITHOUT_XRANDR)
+CONFIGURE_ARGS+= --with-xrandr
+USE_XORG+= xrandr
+.else
+CONFIGURE_ARGS+= --without-xrandr
+.endif
+
+.if exists(/usr/lib/libusbhid.a)
+CONFIGURE_ARGS+= --with-joystick
+.else
+CONFIGURE_ARGS+= --without-joystick
+.endif
+
+do-install:
+ ${INSTALL_PROGRAM} ${WRKSRC}/${PORTNAME}${PKGNAMESUFFIX} ${PREFIX}/bin/${PORTNAME}${PKGNAMESUFFIX}
+ ${INSTALL_DATA} ${WRKSRC}/data/snes9x.svg ${PREFIX}/share/pixmaps
+ ${INSTALL_DATA} ${WRKSRC}/data/snes9x.desktop ${PREFIX}/share/applications
+
+post-install:
+ -@update-desktop-database
+
+.include <bsd.port.post.mk>
diff --git a/emulators/snes9x-gtk/distinfo b/emulators/snes9x-gtk/distinfo
new file mode 100644
index 000000000000..e6a855b4e961
--- /dev/null
+++ b/emulators/snes9x-gtk/distinfo
@@ -0,0 +1,3 @@
+MD5 (snes9x-1.51-src-gtk-78.tar.bz2) = 900abc119e874b59f364fc9f5187c724
+SHA256 (snes9x-1.51-src-gtk-78.tar.bz2) = 543001d7a84b05e9bd4159b10bc42f87e36b555ef715e2db1ebaaf1586143c88
+SIZE (snes9x-1.51-src-gtk-78.tar.bz2) = 894388
diff --git a/emulators/snes9x-gtk/pkg-descr b/emulators/snes9x-gtk/pkg-descr
new file mode 100644
index 000000000000..66d7c0134a71
--- /dev/null
+++ b/emulators/snes9x-gtk/pkg-descr
@@ -0,0 +1,3 @@
+Super Nintendo Entertainment System(SNES) Emulator with GTK GUI
+
+WWW: http://code.google.com/p/snes9x-gtk/
diff --git a/emulators/snes9x-gtk/pkg-plist b/emulators/snes9x-gtk/pkg-plist
new file mode 100644
index 000000000000..f315db0b8951
--- /dev/null
+++ b/emulators/snes9x-gtk/pkg-plist
@@ -0,0 +1,6 @@
+bin/snes9x-gtk
+share/pixmaps/snes9x.svg
+share/applications/snes9x.desktop
+@dirrmtry share/applications
+@exec %%LOCALBASE%%/bin/update-desktop-database > /dev/null || /usr/bin/true
+@unexec %%LOCALBASE%%/bin/update-desktop-database > /dev/null || /usr/bin/true