aboutsummaryrefslogtreecommitdiff
path: root/emulators/spim
diff options
context:
space:
mode:
authorSteve Price <steve@FreeBSD.org>2001-02-27 04:55:17 +0000
committerSteve Price <steve@FreeBSD.org>2001-02-27 04:55:17 +0000
commitf31050845b44173f2cf07aa36a3a0b9644f75078 (patch)
treec08ad08e5a43f6f3cb824236a2816b5aa32a7c1e /emulators/spim
parent46bf532fac284002a8c2d3e6cf1c786b8dc1dcba (diff)
downloadports-f31050845b44173f2cf07aa36a3a0b9644f75078.tar.gz
ports-f31050845b44173f2cf07aa36a3a0b9644f75078.zip
Notes
Diffstat (limited to 'emulators/spim')
-rw-r--r--emulators/spim/Makefile4
-rw-r--r--emulators/spim/distinfo2
-rw-r--r--emulators/spim/files/patch-0111
-rw-r--r--emulators/spim/files/patch-0211
-rw-r--r--emulators/spim/files/patch-0367
-rw-r--r--emulators/spim/pkg-plist6
6 files changed, 10 insertions, 91 deletions
diff --git a/emulators/spim/Makefile b/emulators/spim/Makefile
index 5836e58ea73a..376b746af2ae 100644
--- a/emulators/spim/Makefile
+++ b/emulators/spim/Makefile
@@ -7,7 +7,7 @@
#
PORTNAME= spim
-PORTVERSION= 6.2
+PORTVERSION= 6.3
CATEGORIES= emulators
MASTER_SITES= ftp://ftp.cs.wisc.edu/pub/spim/
DISTNAME= ${PORTNAME}${PORTVERSION}
@@ -15,7 +15,7 @@ DISTNAME= ${PORTNAME}${PORTVERSION}
MAINTAINER= ports@FreeBSD.org
PREFIX?= ${LOCALBASE}
-NO_WRKSUBDIR= yes
+WRKSRC= ${WRKDIR}/${PORTNAME}-${PORTVERSION}
HAS_CONFIGURE= yes
CONFIGURE_SCRIPT= Configure
USE_IMAKE= yes
diff --git a/emulators/spim/distinfo b/emulators/spim/distinfo
index 428e812a9dac..c5f17e33e6d8 100644
--- a/emulators/spim/distinfo
+++ b/emulators/spim/distinfo
@@ -1 +1 @@
-MD5 (spim6.2.tar.gz) = fccec0eaf1e2c2ed76375180e2b39491
+MD5 (spim6.3.tar.gz) = 04b1909f3ff647f1f04437f297c9ad84
diff --git a/emulators/spim/files/patch-01 b/emulators/spim/files/patch-01
index 369590faf3dd..e1df4551ca36 100644
--- a/emulators/spim/files/patch-01
+++ b/emulators/spim/files/patch-01
@@ -1,7 +1,6 @@
-diff -ru Imakefile.orig Imakefile
---- Imakefile.orig Fri Sep 20 22:44:50 1996
-+++ Imakefile Mon Feb 3 11:26:40 1997
-@@ -57,13 +57,13 @@
+--- Imakefile.orig Sun Jan 14 20:55:15 2001
++++ Imakefile Sun Feb 11 23:49:11 2001
+@@ -44,13 +44,13 @@
#
# Full path for directory that will hold the trap handler file:
@@ -18,12 +17,10 @@ diff -ru Imakefile.orig Imakefile
# If you have flex, use it instead of lex. If you use flex, define this
-@@ -291,7 +291,7 @@
+@@ -255,7 +255,7 @@
mv -f lex.yy.c.xx lex.yy.c
depend::
- makedepend -w10 *.c
+ makedepend -w10 -I$(X11BASE)/include *.c
- #
- # DO NOT DELETE THIS LINE -- make depend depends on it.
diff --git a/emulators/spim/files/patch-02 b/emulators/spim/files/patch-02
deleted file mode 100644
index dcc77703eaa3..000000000000
--- a/emulators/spim/files/patch-02
+++ /dev/null
@@ -1,11 +0,0 @@
---- cl-except.h.orig Fri Aug 25 07:05:25 1995
-+++ cl-except.h Mon Oct 28 23:34:02 1996
-@@ -25,7 +25,7 @@
- #define _BSD_SIGNALS
- #endif
-
--#include <syscall.h>
-+#include <sys/syscall.h>
- #include <signal.h>
-
- /* gdb-style for tracking each signal */
diff --git a/emulators/spim/files/patch-03 b/emulators/spim/files/patch-03
deleted file mode 100644
index 9d2c6e1418d7..000000000000
--- a/emulators/spim/files/patch-03
+++ /dev/null
@@ -1,67 +0,0 @@
---- cl-except.c.orig Fri Aug 25 07:13:05 1995
-+++ cl-except.c Tue Oct 29 00:37:44 1996
-@@ -46,6 +46,7 @@
- /* Exported Variables: */
-
- mem_addr breakpoint_reinsert; /* !0 -> reinsert break at this address */
-+spim_proc proc; /* spim's signal tracking structure */
-
-
- /* Imported Variables: */
-@@ -67,14 +68,14 @@
- #ifdef __STDC__
- static void intercept_signals (int sig, int code, struct sigcontext *scp);
- static mem_addr compute_branch_target (instruction *inst);
--static void psignal (int sig);
-+static void spim_psignal (int sig);
- static int issig (void);
- static int psig (void);
- static void sendsig (void);
- #else
- static void intercept_signals ();
- static mem_addr compute_branch_target ();
--static void psignal ();
-+static void spim_psignal ();
- static int issig ();
- static int psig ();
- static void sendsig ();
-@@ -266,7 +267,7 @@
-
- else if (retval == 0)
- /* bad system call --> turn into a signal */
-- psignal (excpt_handler[SYSCALL_EXCPT].sig);
-+ spim_psignal (excpt_handler[SYSCALL_EXCPT].sig);
-
- retval = !retval; /* retval == 1 -> syscall ok;
- * retval == 0 -> syscall bad */
-@@ -286,7 +287,7 @@
- case IBUS_EXCPT:
- case DBUS_EXCPT:
- case CPU_EXCPT:
-- psignal (excpt_handler[excpt_code].sig);
-+ spim_psignal (excpt_handler[excpt_code].sig);
- break;
-
-
-@@ -456,7 +457,7 @@
- }
- else if (spim_related_sig & (1 << sig))
- cycle_steps = 0;
-- else psignal (sig);
-+ else spim_psignal (sig);
- }
-
-
-@@ -466,10 +467,10 @@
-
- #ifdef __STDC__
- static void
--psignal (int sig)
-+spim_psignal (int sig)
- #else
- static void
--psignal (sig)
-+spim_psignal (sig)
- int sig;
- #endif
- {
diff --git a/emulators/spim/pkg-plist b/emulators/spim/pkg-plist
index 31f1b82e2468..bd1fe2f424db 100644
--- a/emulators/spim/pkg-plist
+++ b/emulators/spim/pkg-plist
@@ -1,7 +1,7 @@
bin/spim
bin/xspim
share/spim/trap.handler
-share/doc/spim/spim.ps.gz
-share/doc/spim/cycle.ps.gz
-@dirrm share/doc/spim
+%%PORTDOCS%%share/doc/spim/spim.ps.gz
+%%PORTDOCS%%share/doc/spim/cycle.ps.gz
+%%PORTDOCS%%@dirrm share/doc/spim
@dirrm share/spim