aboutsummaryrefslogtreecommitdiff
path: root/emulators/stella/Makefile
diff options
context:
space:
mode:
authorYing-Chieh Liao <ijliao@FreeBSD.org>2003-01-02 08:02:49 +0000
committerYing-Chieh Liao <ijliao@FreeBSD.org>2003-01-02 08:02:49 +0000
commit33dfe3dc81041cb09da76f3a0c33c276bbac58d3 (patch)
tree1d18a65ede60be73ff6e92c59db38a9b30c5aaa2 /emulators/stella/Makefile
parentf0764c3fe0d09df0771a6911cbc49a53f6a68974 (diff)
downloadports-33dfe3dc81041cb09da76f3a0c33c276bbac58d3.tar.gz
ports-33dfe3dc81041cb09da76f3a0c33c276bbac58d3.zip
Notes
Diffstat (limited to 'emulators/stella/Makefile')
-rw-r--r--emulators/stella/Makefile35
1 files changed, 21 insertions, 14 deletions
diff --git a/emulators/stella/Makefile b/emulators/stella/Makefile
index 632a47874e83..ff4e8995fbcd 100644
--- a/emulators/stella/Makefile
+++ b/emulators/stella/Makefile
@@ -1,14 +1,15 @@
-# New ports collection makefile for: stella-1.1
-# Date created: March 4, 1999
-# Whom: Jacques Vidrine <nectar@FreeBSD.org>
+# New ports collection makefile for: stella
+# Date created: March 4, 1999
+# Whom: Jacques Vidrine <nectar@FreeBSD.org>
#
# $FreeBSD$
#
PORTNAME= stella
-PORTVERSION= 1.1
+PORTVERSION= 1.2
CATEGORIES= emulators
-MASTER_SITES= ftp://ftp.eos.ncsu.edu/pub/bsvc/stella/1.1/
+MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
+MASTER_SITE_SUBDIR= ${PORTNAME}
DISTNAME= ${PORTNAME}-${PORTVERSION}-src
MAINTAINER= ports@FreeBSD.org
@@ -17,16 +18,21 @@ USE_XLIB= yes
PORTTOP= ${WRKDIR}/${PKGNAME}
WRKSRC= ${PORTTOP}/src/build
+USE_GMAKE= yes
MAKEFILE= makefile
ALL_TARGET= freebsd-x
USE_XLIB= yes
-ROMSDIR= ${PREFIX}/share/stella/roms
-ROMS= ELK.BIN OKIEDOKE.BIN OYSTR29.BIN TEST.BIN TPS.BIN
DOCSDIR= ${PREFIX}/share/doc/stella
-DOCS= docs/Stella.pdf games/docs/elk.doc games/docs/okiedoke.doc \
- games/docs/oystron.doc games/docs/tps.doc
+DOCS= docs/stella.html
+GFX= docs/graphics/chucky_cheese.png \
+ docs/graphics/circuit.png \
+ docs/graphics/console.png \
+ docs/graphics/jr_pacman.png \
+ docs/graphics/pacman.png \
+ docs/graphics/secret_quest.png \
+ docs/graphics/space_invaders.png
post-build:
@(cd ${PORTTOP}/src/ui/sound && \
@@ -34,13 +40,10 @@ post-build:
${MAKE_ARGS} oss)
do-install:
-.for exe in src/build/xstella src/ui/sound/stella-sound
+.for exe in src/build/stella.x11 src/ui/sound/stella-sound
${INSTALL_PROGRAM} ${PORTTOP}/${exe} ${PREFIX}/bin/
.endfor
- ${MKDIR} ${ROMSDIR}
-.for rom in ${ROMS}
- ${INSTALL_DATA} ${PORTTOP}/games/ROMS/${rom} ${ROMSDIR}/
-.endfor
+ ${MKDIR} ${PREFIX}/share/stella
${INSTALL_DATA} ${PORTTOP}/src/emucore/stella.pro \
${PREFIX}/share/stella/
.if !defined(NOPORTDOCS)
@@ -48,6 +51,10 @@ do-install:
.for doc in ${DOCS}
${INSTALL_DATA} ${PORTTOP}/${doc} ${DOCSDIR}/
.endfor
+ ${MKDIR} ${DOCSDIR}/graphics
+.for gfx in ${GFX}
+ ${INSTALL_DATA} ${PORTTOP}/${gfx} ${DOCSDIR}/graphics/
+.endfor
.endif
.include <bsd.port.mk>